LZW31-SN Minimum Level - Expected Behavior

I have installed a dimmer in my office and I have 2 different types light bulbs. Both are made by GE but 2 of the bulbs are a LED canned light replacement and two are regular LED bulb in a pendant light. Even though they’re the same manufacturer and series, they have different dimming profiles. I went in and set the Minimum Level to 30, as that seems to be about the level that appears in Hubitat when I dim the lights to the point that one of the light pairs goes out.

When dimming with the paddle now that the minimum = 30, I would expect that when I press and hold the paddle down, the light would dim to level 30 and then the lights would turn off. What I am seeing though, is that dimming with the dimmer paddle, the light continues to dim all the way down to levels below 30 and not skipping from 30 to 0, which is what I would expect.

Yes this is correct. The min and max is the minimum and maximum power to the bulb and it will dim from off to full with-in the min and max you set. If i am clear in my explanation?

@jmallentn noticing the same thing. Also, the dimming curve on these devices is NOT linear, I have a set of incandescent light bulbs that don’t come on until about 22%. This should NOT happen with incandescent which can dim down to 1% since they are analog.

I had great hopes for these dimmers but they are flawed in several ways with no time table or expectation set from the company if these issues will be resolved. Looks like I’ll have to recommend other dimmers to my clientele.

I experience this also, the dimmer continues dimming below the “minimum” setting specified so that in a fixture with 5 bulbs, a couple will turn off before the others. I thought avoiding this sort of thing was why the minimum setting existed. Certainly doesn’t seem like the behavior I expected.

@Sky320 I don’t think I do understand what you’re driving at. @jmallentn was asking about dimming downwards, but you are talking about dimming upwards?

@martybird and @jmallentn , okay thanks for asking as I didn’t feel I was very clear. Once the min max are set it shows as full range dimming from zero to 100 and 100 to zero. So when 30 is set to min it will show as on 1 (anything under 30 will register as off). I hope I am answering what you are looking for?

@Sky320 I’m still not sure what you mean, but what i THINK you are trying to say is that if you set a min and a max then what is reported back to the hub is a pseudo-range of 1 - 100, so no the dimmer reports 1 - 100 but within the parameters you specified.

I believe I understand @Sky320’s explanation, and that is how I expect it to work … but as @Bry says, it is not what actually happens, using the physical dimm-down button at the switch, the minimum (eg, absolute 30) is not respected as a rescaled “1”.
The lights just blow past the absolute-30 level and keep on dimming down to absolute 0, as if the minimum level setting has no value specified.

Edit: I’m using firmware 1.48, and Inovelli’s driver from 2020-10-01, C-7 hub is (letting dust settle on subsequent hotfixes, 141 is solid for me, also problem predates this Hubitat release anyway).

Thanks for all the input. The behavior @martybird is describing matches what I see and what I was asking. I have the minimum set to 30 in Hubitat, but when dimming with the paddle, the light doesn’t seem to turn off at level 30 like I’d like. Since I have 2 different types of LED bulbs (recessed and edison) the edisons dim much more aggressively and turn off around level 25, while the recessed continue to dim. However I’d expect them to all turn off at the same time when using the paddle, now that I’ve set the minimum level at a number higher than where the edison bulbs turn off.

The minimum level parameter is actually independent from the level state. You will still see the level going from 0 to 100, but if you set the min and max to 25 and 75 respectively, the hardware is outputting no less than 25 and no more than 75 of the full wave with the hardware doing the math behind the scenes at a lower level of the hardware/firmware than is exposed to the user.

Every LED bulb type is going to have different dimming behavior. The best thing you can do is reset your min and max values to the default 1 and 99, then manually dim to find the value in which the first bulb type turns off (this is your parameter 5 min), and the value in which the last bulb stops increasing in brightness (this is your parameter 6 max).

1 Like

@fatherdoctor Yep, I think the key for those trying to evaluate their levels is to reset the parameters to 1 and 99. Only then can you see what your illumination is for a given percentage prior to limiting. I didn’t see it until I reset the parameters as you suggested.

For those trying to replicate, reset your min and max to 1 and 99. Now turn the dimmer on and set it to 45%. Observe the brightness level of the bulb(s). Now trim your min to 45. You’ll find that you can’t dim to a brightness level below what you just saw at 45%. You can take it down to 1% but the illumination will be at the 45% level prior to trimming.

1 Like

I believe I have done this resetting and re-evaluating multiple times (it’s a logical troubleshooting approach) but it was to no avail. That said, I will give the process yet another shot when I next have a chance (prob a few weeks, am between houses back & forth).

Hopefully @jmallentn can get a good result.

OK, this seems to have worked. I went in and set the minimum value to 1, then saved and clicked “Configure”. Then I got the brightness to just above where the edison bulbs themselves turned off (for me this wound up being 45) and then set the minimum brightness to 45, saved and then configured. Now the switch does what I’d expect when I hold the down button, it will dim to where the edison bulbs are dim but still on and then stop.

Thanks for the help. I feel like I tried all this more than once but for some reason it wouldn’t work!

1 Like

was hoping to hear this :slight_smile: bodes well.

Out of curiosity, now that this is setup, if you set the level to 1 via software, do the lights now go to the 45 level of brightness?

Yes. What we were discussing before takes place. So if you clip at 45 and 90, for example, the old 45 - 90 range becomes 1 - 99.

I can confirm that setting to 1 after setting the minimum to 45 will set the level to a brightness = 45.

1 Like

@bry - I definitely get that is intended to happen.

@jmallentn - thank you for confirming it actually does happen. :+1:

@martybird The first switch I installed was behaving as you described. Ie it didn’t matter what minimum dim level I entered into configuration either at the switch or in hubitat it would go below that value when dimmed. Tried hard reset, but same result, and Inovelli tech support didn’t really offer any other solutions. I ended up just moving the switch to another location (same brand of lights) and now I can get it to work, go figure.

One thing to note that has been pointed out but is not made particularly clear is the minimum and maximum dim parameters become the new 1-99. Also not sure if the state of the switch matters when applying these, since you could be at “20” then set min dim to 30 so now the switch is in an excluded value… Might cause problems but I’m not sure.

1 Like

Yep, it can be a bit confusing at first. The best approach is to set the dimmer to 1 - 99 and then dim up and down to determine your ideal min and max values. You’re correct in that after you set the new min and max, that brightness range then becomes the new 1-99.

Finally got a chance to play with this. Per Bry’s suggestion, reset the values to 1 and 99, found where I wanted the minimum, set it (hit configure & refresh) … now it actually behaves as expected.

Repeated the process on 3 additional dimmers, all working correctly now.


This was very confusing to me as well. For future people who find this thread or have this mis-understanding, here is a quick sketch of how setting the min level to 30 and max level to 90 in the config still shows 1% to 99% levels. The programming does all of the math for you!: