LZW31-SN not updating in Hubitat with new firmware

I updated the firmware for my Inovelli LZW31-SN yesterday to version 1.52. Now there are some issues with Hubitat.

The switch works fine manually, and I can control the ON/OFF from Hubitat, however, the “Current States” is not refreshing. If I click OFF from the devices within the Hubitat page, the lights go off (assuming they were on) but the current states continues to show “ON”. If I click the REFRESH button, the current states updates to the correct value (OFF in this case).

Any ideas what is wrong? This is the case for two switches, so seems like it’s not the particular switch.

As a side note, I have some LZW31 (non-scene) switches that I updated yesterday also. This behavior is not present with those.

Just so we can capture some more data – can you let me know what version of Hubitat you’re running as well as the hub model (ie: C5, C7)?

I posted the same issue in the Firmware v1.52 (beta) thread. Current states is not updating. For me it happened on 4 of 6 LZW31-SN’s I updated. The four that didn’t work were paired with S2, the two that worked had no security. So I tried excluding one of the 4 and included back in with no security, current state started updating. I excluded and included again with S2 to get back to where I started, and now it works! I’m running Hubitat on a C7.

I’m using 2.2.4 and on a C7 hub…

I’m going to try right now. I’m on (C-7)

Edit: Seems to work for me?

I updated the firmware the old way though where I changed the driver to the Firmware Updater if that means anything. I think there’s a new way to do it, but I’ve never used that way.

There is a new way, yes. The Device Firmware Updater app. It allows a bit more control over the update process and may (in the future) not be limited to just Z-Wave updates.