LZW31-SN Notifications not working

hub v2, US customer Rev E

My hub is v2, rev E as well.

Got word back from support that they are still looking into the issue but are unable to replicate the problems we’re having.

Hang tight guys, we are looking into the issue. Should have some feedback shortly.

Ok, I am seeing that the wrong device handler update got pushed to github on Monday. Sorry about that! Can you guys test out the updated device handler?

Tested out the new DTH and everything works now!!!

Thanks for digging into the issue and getting us the fix. My wife is going to royally hate you because you know I’m going to be up all night messing with LED colors and setting up annoying flashing notifications everywhere!

1 Like

Confirming both that notifications work and default LED strip color can be changed. Thanks!

1 Like

Working great! now this is the best switch on the market!

1 Like

Works for me too. Thanks for a quick fix!

1 Like

Worked for me as well. Thank you.

I am still having problems…this is what I did:

  1. Updated the DTH with the one noted above, saved it, then published it.
  2. Went to Edit the Device, made sure the “Type” was correct, then clicked “Update”.
  3. Made sure Switch Child Device was still installed.
  4. Changed the color of the “LED Strip Color” & setup several “LED Notifications” in Smartthings Classic App.
  5. “Notifications” are visible from the notifications created with in the Smartthings Classic App and are selected to turn them on.

The LED Strip Color still did not change nor did any of the LED Notifications work.

Is there something that I still need to do?

Thank you! Happy Thanksgiving!

Some how it got both the “LED Strip Color” & “LED Notifications” to work.

Its was either one of the following things that made it work:

  1. I went into IDE/Devices/Device Properties (for the “Switch Child Device”) and clicked “Update”
  2. I “Pubished” the “Switch Child Device”

Cool! Now I will custom the notifications and look into buying more of these switches.

Good evening all,
Im experiencing a similar issue the two I bought by where I can only get 4 of the 5 configured notifications to reflect on either switch #5 is just completely ignored. I have set 5 up differently and the same on both, it doesnt work on either.

Using the device handler linked above for the switch, and I’ve tried both this and this DTH for the child switch device with the same result for each.

Im using the classic app, both my switches are on FW1.35 and my hub version is 000.020.00012 (ShieldTV Dongle)

Can someone please confirm that have all 5 notifications working using the DTHs linked above?

@Jon-G, you’re using this one for the switch right? https://github.com/InovelliUSA/SmartThingsInovelli/tree/master/devicetypes/inovelliusa/inovelli-dimmer-red-series-lzw31-sn.src - Dated 2019-11-20 “Bumping number of notifications to 5.”

I have installed the Switch Handler for the LZW31-SN. It can control the lighting as intended. Howver, I also created a child handler for the generation of a notification. I cannot get that to work. I can see the state change on my PC when I initiate it on my Phone app, however nothing happens. I have the 5/6/20 code for my device handler

Could you show us some screen shots of your setup?

Here are a couple of screenshots. Let me know if you need more specific ones.



@motougo - I’m not familiar with SmartThings, but there are several users using notifications. @Eric_Inovelli - Any guides out there for setting up?

You can ignore this issue. Turns out I have the LZW31 and not the LZW31-SN. No wonder I couldn’t set the Notification LEDs! DOH!

Thanks anyway!