LZW31-SN Notifications not working

Hi I just got the LZW31–SN after the long wait! I downloaded the device handler for the switch as well as the switch child device. When I went into the smartthings app I created a notification (yellow solid LED). When I click save it create the device under the Switch menu. However, when I manually turn the notification on, nothing happens, it remains the normal blue. How can I get notifications working? Also after creating a notification, how do I then go back and delete it?

I have found out how to delete notifications, but I still can’t get the notifications to work at all.

What hub you using? Hubitat or ST?

Smartthings. I also find that when I change the switch’s settings (like the standard LED intensity) is doesn’t really make the changes, or if it does it takes a very long time to go in effect.

1 Like

SmartThings user here as well. Notifications works great for me. I would check to make sure you are using the correct device handler installed in SmartThings. Their website is a little confusing with device handlers, so it’s possible just a mix up. I just go straight to the GitHub repo


Having the same troubles as @Lauzca with notifications. The Notification devices appear on LZW31-SN device page in the SmartThings Classic app. ST is even able to turn them on/off. But, the LZW31-SN does not change the LED light as expected.

Also as @Lauzca mentioned, I also see that changing the device handler settings either does not take effect or takes a very long time. I positive I’m using the correct device handler.

Same situation here as well. I’m on ST and the app can control on/off/dimming but none of the settings stick. Even changing the LED strip color in app does nothing to the actual switch’s LED color.

I contacted Support last night and have yet to hear/read from them. Perhaps some of us got a bad batch as it seems others have no issues.

Same here as well. Can set dimming limits, ramping, etc. Can change LED strip settings, but it remains at blue. Can create child devices for notifications, but they don’t change the LED strip.

Im having the same issue - LED adjusts when switch is dimmed, but never changes color when adjusted, and doesnt change with notifications. I have child device handler installed and it shows the notification on/off switches, but just doesn’t show on the switch.

I have 3 more switches, will try to get another installed tonight to see if that one works at all.

Did a little more tinkering on my side. I installed another switch to see if perhaps the 1st one was a dud. Interesting thing I noted when I paired the 1st switch it showed up as a “Zwave metering device” - the 2nd switch showed up as “Inovelli Dimmer Red Series”.

I went into the Smarthings IDE while at the same time messing around in the ST app settings for the LED Strip - I would then refresh the Device view in the IDE and sure enough the parameters do update there (LED color is parameter 13 for example) - for whatever reason those changes did not make it to the physical switch. I then discovered that if I hit “Edit” under the Inovelli device in the IDE and then hit “update”, the color on the switch changes to the desired setting. So, it looks like the switch needs an extra push from the IDE to update.

I could not get notification LED settings to take effect regardless of what I tried. Not sure the above info helps anyone here but perhaps it helps the Inovelli team debug to some extent.

1 Like

sparq - So you could not get your original switch to work (the one showing up as Zwave metering device) that is the same thing mine is showing up as, but your second switch worked just fine?

Nope - neither switch is working (in terms of notifications and other settings sticking). I was just noting that the switches also showed up differently in the SmartThings app - but neither is working.

Heh, the “Update” trick from @sparq also worked for me to get the LED status light to change colors. But still nothing for the notifications.

I can also confirm that I can get the LED to change by editing device and saving, but also nothing for notifications.

Yep Same issue. Not updating for me either.

I think their device handler webpage is broke. When you click the red series device handler you get the black series. Make sure you are getting the correct device handler installed. and then editing your device in ST IDE and choosing LZW31. I just searched github for inovelli’s repo and found the handler from there.This page might work better too:

Don’t think that’s the issue (in my case at least). Quadruple-checked I’ve got the correct DTHs installed and associated to switch (see screenshot).

Perhaps it’s a hub version compatibly issue since it seems some are able to get things to work? What is everyone’s hub version number? I’ve got a Version 2, Revision E…

I have model STH-ETH-250, firmware 000.027.00009.

I’m having the same problem with my red series dimmer. What’s interesting is that the notifications and led bar color settings are working on my red series non dimmer I purchased last month (LZW30-SN) through the same hub. The non dimmer changes I make on the smartthings classic Android app are going through immediately for the non dimmer.

I’m on smartthings V2 hub as well.