LZW31-SN "Please wake your sleepy device" hubitat

Hello, in the past I have successfully updated my firmware on my Inovelli Red Series Dimmers (LZW31-SN).
However now I am running into all sorts of issues updating via Hubitat.

I have the most recent version of the Z-Wave Firmware Updater tool, and updated LZW31-SN drivers.
When on the firmware update tool, the “Get Version Report” button does not respond, and nothing gets output to the logs with “enable debug logging” on.

Trying to update the firmware just goes

  • firmwareUpdateProgress : Starting… Getting current version"

then

  • firmwareUpdateProgress : Please wake up your sleepy device
  • lockedBy : None
  • currentFirmwareVersion : null
  • firmwareUploadPercent : null
  • manufacturerId : null
  • firmwareTarget : null

The device is communicating normally with the hub as I am able to send on/off commands to it.
I have tried the “air gap” technique multiple times and it still does not help.
Please help!

Additional hub info:
Hubitat Elevation® Platform Version 2.2.9.146
Hardware Version Rev C-7

I was encountering the same issue. Give this a shot.

Thank you so much! That worked!

I’m going through the same thing here. What am I supposed to do with the code @blackhawk5732 posted? Does that just replace the app I had previously downloaded?

Thanks,

Not the whole code, just replace that section. It was the last part of the code for me.

Hey @stevenkandres – did you get this resolved yet?

@markman641 – just so I’m clear and can modify instructions in our KB, are you saying that code (from GitHub) replaces the same (or similar) code in the Firmware Updater driver?

Current Code:

GitHub Code:

Edit: Thanks @blackhawk5732 for the solution :slight_smile:

I switched to the Device Firmware Updater app that Hubitat has and then it worked fine, thanks for following up.

Correct

1 Like

Rant for Eric_inovelli
So I got my Red dimmers last year and just installed them on my Hubitat. Went to update them and got to the “Please wake up your sleepy device” problem after installing target 0.

Searching I find this thread where a snippet of code is listed as the solution. The next post is from someone who askes what do I do with this. The answer is to find a similar code and replace what is there. Really, it’s been 6 weeks since the “solution” was found and I still have to cut and paste?

How are we ever going to get to Mars? Isn’t this why we pay $45-50 a dimmer.

So this is your first post and it’s a rant . . . ok . . . that’s a great way to get started . . .

So your HUBITAT updater isn’t working. Yes, apparently you do have to cut and paste. But maybe that’s because Hubitat hasn’t updated their code. Or maybe they’re not going to and a user in this community, where we all help each other, usually, found a solution.

What exactly is it that you expect Inovelli to do? They don’t own Hubitat, so they’re not going to update Hubitat code.

If your Hubitat updater isn’t working, then try the SiLabs PC Controller. It generally works flawlessly.

Or, you might even try explaining what you don’t understand and I’ll bet someone will actually help you.

smh

I just managed to find this thread due to hitting this problem, and I think I get the frustration from topetterson - and the corresponding misunderstanding and rant frustration from Bry

Looks like there’s potentially 2 fixes (either modifying the code or using the built in hubitat app).

The problem is that the fix that markman641 indicates fixes it hasn’t made it over to the inovelli driver in the inovelli howto link

I think the expectation is that if there’s a fix, the driver in the howto should get updated or the docs point to the workaround. That way anyone going down this path doesn’t have to hunt through webforums looking for a fix (like I’m doing this fine afternoon). I understand the frustration, as the resident debugger of the house’s automation system.

3 Likes

and FWIW, I made that change in the supplied driver and it is now making progress on the firmware.

Unless I’m misunderstanding, the Hubitat Z-Wave Firmware Updater was written by Bryan Copeland (different Bryan . . not me). Bryan is a software engineer at Hubitat. The Github repository in which that code resides is his.

There seems to be some expectation that Inovelli should modify “their” code. But it’s not their code, it’s either Bryan’s or Hubitat’s, I’m not sure which. So the only person that can update that code or approve a pull request is Bryan Copeland at Hubitat. In the meantime, you are just going to have to copy/paste the updated code into your tool should you choose to use it.

There is also a thread on Bryan’s Hubitat Z-Wave Firmware Updater. I’d suggest a Hubitat user reach out to him and inquire about an update. There may be a reason he is has not updated his tool.

@bcopeland

1 Like

I think the point you’re (still) missing, is that the instructions in the Inovelli KB instructs us to use the flawed firmware updater. Yes, we understand it isn’t written by Inovelli, but you now know it has an error, and you know what the fix is. As a gesture of kindness to your customers, it would be helpful for you to point us in the right direction to be able to update the firmware successfully.

Alternatively, maybe you should write your own updater so you provide the tools required to update the firmware on your product.

1 Like

Fair point, I think (which I haven’t been missing, lol). I don’t know if I would term it “flawed”, as not everyone seems to have that issue. You also have to remember that the tool was designed as a universal Z-wave tool, so it may generally work well. (I am just speaking from my reading, since I don’t use Hubitat and I use the SILabs tool.)

So Inovelli may update their guide based on the prior input from Mark, but that’s up to them.

I agree it would be great if Inovelli would write their own tool. They can speak on that. But if I had to guess, at present they just don’t have the bandwidth to do that, as it is no secret that they are an extremely small company.

Inovelli should never be responsible for Hubitat breaking their own code. There are many solutions outside of Hubitat that work to update firmware, and on a 5-day turnaround is unrealistic.

Hubitat is 100% responsible for the ability to update CLEAN firmware from Inovelli on their hub. Inovelli made the proper recommendation at the time of publishing and is no longer responsible for keeping track of Hubitat changes.

No question.

3 Likes

You appear to not get it either. I buy a product from Inovelli. I come to their support pages to find out there is a new firmware version. I look to the article on the INOVELLI site for instructions on how to flash it. If Inovelli is relying on 3rd party tools to flash the firmware to their products, it’s in their best interest to ensure they actually work.

I’m not blaming Inovelli for the 3rd party code that (sometimes) doesn’t work, but I do think it’s their responsibility to provide the best (most up-to-date) info possible for supporting their product, and serving their customers.

If there are other, better, tools for flashing the firmware, maybe those could also be mentioned in the Knowledge Base article.