LZW31-SN Semi-Brick help

Hey guys, I need a bit of help here. Last night I went through all of my dimmers (LZW31-SN) and all of them updated just fine to 1.57 w/1.45 Holtek… except one. I went through the same process to update it with my Aeotek Z-Stick and the PC Controller as all the others, however it seems to be semi-bricked. I’m not sure if it lost power at some point briefly due to the dimmable LED being somewhat problematic (it never totally shuts off, sometimes at full brightness the dimmer will cut all power…). Could being a non-neutral setup cause firmware update issues? I wouldn’t think so, but… I don’t know.

The current state of the dimmer:

  • It seems to do nothing with the relay (it’s always “off” yet slightly leaking power as evidenced by my LED being always-slightly-on)
  • The LED goes through the three color flashes when the airgap is first connected again, briefly flashes at full power, then cuts off and will not light up until argapped then connected again
  • I can pair and unpair without issues with either the PC Controller or (I think) zwave-js in Home Assistant, both securely and in non-secure mode
  • When you hit the paddle, the relevant state (on or off) shows in Home Assistant, and you can toggle it on and off there as well, but no power changes ever occur via the relay, however the dimmer is slightly leaking power as evidenced by my LED being always-slightly-on (this was the case pre-upgrade, so the same behavior).
  • When the airgap is connected again, the LED bulb on the circuit flashes at full intensity briefly before the dimmer cuts out.
  • Firmware details post-upgrade: Command Class Version: 4; Manufacturer ID: 03 1E; Firmware ID: 01 01; Firmware Version: (empty box); Hardware Version: 0; Checksum: FA C1
  • Attempting to re-update with the same or higher (1.61 beta, Target 0) firmware seems to go through the process, but the behavior remains the same and Current Firmware information remains unchanged.

At this point I’m unsure of how to proceed or if this dimmer can be saved. I don’t use any other hub or have any way to update the device other than the PC Controller, unless there’s a way to do so directly on the board somehow (micro usb or something might be a nice addition on future products!)

Any/all help with this would be GREATLY appreciated!

1 Like

Have you done a hard reset? Config hold until red?

1 Like

Hard reset (holding config at all) seems to do nothing. LEDs do not light up indicating it’s doing anything (no green/yellow/red at all) at any time other than on initial hard poweron (airgap pulled and pushed in again).

Did you flash the bin to Target 1 as well? I know that you said that you flashed others successfully but there was no mention of Target 1 when you stated you flashed the 1.61 beta.

When you do a Get in the PC controller, does it return the firmware that you are expecting? You posted that firmware was blank, but I suspect that is what is being reported in HA. Also, FWIW, at least in SmartThings, when the firmware version isn’t displayed that means the switch did not join properly to the hub. Not sure if that is the same with HA.

I don’t know if this will help as I have never flashed a non-neutral, but you might consider moving the switch temporarily to a box where you can provide it a hot and a neutral. It can’t hurt and you can see if that might make a difference.

You could also try temporarily substituting an incandescent load. I suppose it’s possible that different firmwares could interact differently with LED bulbs.

Yes, I flashed the 1.45 Holtek bin to Target 1 on all of them when updating to 1.57. Target 1 should not need to be reflashed every time you do Target 0 since they’re separate… does it? (Either way, I tried reflashing Target one with 1.45 as well, it didn’t make a difference.)

That’s the information I posted where the line is blank. That’s directly from the PC controller when clicking “Get” on the device. All my others show the expected 1.57 there. I haven’t even really looked in HA for the version numbers because I don’t do any sort of firmware work there. I use zwavejs on there. Maybe it’s “joining” the network on the Z-Stick I have but not functioning right so it doesn’t do anything? It includes and excludes but beyond that and appearing to accept OTA updates (but not?), I don’t know.

Additionally to my OP, I changed every setting on the switch and back to “factory” again to save them all in case there was garbage data being loaded. However the new parameters after 1.35(?) Aren’t available to update, like parameter 51, 52, etc. That makes me think it was partially flashed but not fully, and thus is in an inconsistent state. Thoughts on this anyone?

I can try moving it and/or using incandescent bulbs (if I even have any… I’d have to look!). The thing that concerns me is complete lack of any LEDs on the switch post cold-boot, almost as if the “bootloader” portion is fine but the actual “OS” part is buggered. I’m using PC related terms here since I’m not really sure what parts firmware would have or how a smart light switch “boots up” lol. But the thinking with this is, if the initial boot part is still working and it’s still able to be added to the zwave network, then hopefully there would be some way to manually reflash it (even if extreme or require soldering or a programmer of some kind, etc), akin to reinstalling windows on a PC that has the BIOS and bootloader intact.

Thanks for the suggestions, I’ll try moving the switch to my test electrical box to update it so it has neutral and a heavier load. I have a couple 40W fixtures I can connect for that.

If anyone has any other suggestions, please let me know!

Update to the chaos: Connecting the dimmer with the “bad” flash to a neutral wire (on my test bench) and removing a load (no bulbs/etc) brought it up in a “working” state, however the firmware version would still not show at all. I moved it to another non-neutral location that had different bulbs, and it behaved… oddly. The bulbs in the second non-neutral were also dimmable, but were staying on full brightness even though the dimmer itself was off. Changing bulbs, re-interviewing, changing all the parameters again, all yielded the same result. So I took it out and connected it to my test bench again and connected via the PC Controller, and all of a sudden I was getting a firmware version on it of 1.57?? I re-flashed both Target 0 and 1 with 1.57 and 1.45 Holtek, respectively, just to be sure it was a good flash.

Side-question: do these dimmers need to do any kind of like… full-power reboot/reset when they update firmware before the firmware fully sets in or something? If so, that could explain the issue(s) I was having. None of the bulbs I have like to be at full (99% in parameter settings) power. When they’re at full power they blink and shut off along with the dimmer, for whatever reason (no LEDs, nothing).

Side-note: I now recall having one of my dimmers that I attempted to install initially in a non-neutral location when I got my first batch of these that simply would NOT work at all without neutral. Attempting this particular dimmer in that location yields the exact same results - no LEDs at all (not even boot ones), no lights, seemingly no power at all, yet a different dimmer (same model, even same datecode) works just fine in non-neutral there. Could this possibly be a defective unit?

After the flash0, they reboot themselves. You should notice the startup flash after it successfully flashes. That’s why you have to wait a few seconds after boot up in order to flash flash1.

Did you set your dimmer parameters correctly for the type of switch (neutral vs non-neutral)?

Yes, I set the parameter correctly. I even changed every parameter to something different then back again to be sure they were all set with valid data. All of mine are no-neutral capable and the dimmer in question was set to be non-neutral. However as mentioned, the dimmer in question does absolutely nothing in one non-neutral location (not even powering on), and in another non-neutral location it behaves as in my initial post (three color boot, bright flash, then nothing). I’m honestly thinking this one is just partially bad and can’t be used in a no neutral setting. Other dimmers (same model and even date code on the devices, bought at the same time) in the same exact locations work as expected without issues. Unfortunately it’s one of the first ones I bought way back in like 2018 or 2019 sometime and I’m not sure if the company would exchange/replace it at this point. I guess 9 out of 10 isn’t too bad :person_shrugging: