LZW31-SN, Smart Bulb Mode, and Philips Hue bulbs

TL;DR: Is there an issue with Smart Bulb Mode keeping the “light” entity reported by the dimmer to be 100% constantly? Clicking the paddles up or down on the dimmer does not change its value.

I have a LZW31-SN dimmer with Smart Bulb mode enabled, wired up to Philips Hue bulbs. I’ve paired it with an HUSBZB-1 USB key and successfully imported it into Home Assistant using the new-ish OpenZWave integration. I’ve verified that ZWave events are coming into HA properly by watching for the scenechanged events, which reliably show up when clicking any of the buttons on the dimmer.

My question is how to make the dimmer work with Hue bulbs. The best advice I’ve read is to create an automation that respond to the dimmer’s light entity and then change the Hue bulb brightness. However in testing, clicking the paddle up or down does not change the “light” entity which is associated with the dimmer (I know this read a bit oddly, but the dimmer reports itself to be a light as that’s the only way currently to get the current dimmer value into Home Assistant). However, if I manually change the value of the dimmer’s “light” entity I can see that the automation does work and changes the brightness of the Hue bulbs.

Is there an issue with Smart Bulb Mode keeping the “light” entity reported by the dimmer to be 100% constantly?

I was going to ask a similar question, so I’ll ask it here.

In my experience, “Smart Bulb Mode” activates passthrough voltage, but still allows dimming levels to be shown on the switch. 1% through 100% all show as 124V on my switch. You might validate that is your experience as well @nosuch. If it’s not constant voltage then the setting isn’t properly applying at the switch device and you might have to try via config button to confirm setting.

My problem is when the switch is OFF, a.k.a. Level 0. It is cutting power to my smart bulbs and they are no longer reporting or able to be tweaked.

My desired “Smart Bulb Mode” is that I can turn the switch “off” but that voltage continues to flow. I will essentially set up on my end the control of the lights to “off” with scene control (scene 2, button 1 controls bulbs off). I need this as I have a few of these smart switches controlling zigbee bulbs. With HA this is near instant from scene control through ST to control the zigbee bulbs, but once I allow the switch to go to “off” they report as offline.

@EricM_Inovelli was there intentional design behind cutting voltage when switch is off in “smart bulb mode”?

1 Like

When you say that smart bulb mode still allows dimming levels to be shown on the switch, how would you check this? Do you mean that the LED on the switch changes level when tapping the paddles up or down? I’m my case the LED is always on 100%. I thought I had seen others with the same result. Any chance you can share your complete config?

Yes, I can dim the switch to 1% and the full line voltage is passed through to the bulb just as if the switch were at 100%, but the presented level on the LED bar changes and is configurable.

I use this for my adaptive lighting that follows circadian rhythms, through the morning and evening both dimmers and smart bulbs are adapted in brightness. This works great so I can see that both smart bulbs and smart dimmers are at ~25% levels or 75%, etc.

My config for smart bulb mode is as follows:

Note that the master bathroom dimmer powers both the master bathroom counter and sink bulbs (Nodes 21 and 23).

No, it is a change that I have been trying to push through since September. To leave power output at 100% even when the dimmer gets “turned off”.

3 Likes

Nice. Lots of separate conversations this this effect, but glad to hear it is in the works.

You guys flat out rock.

Kevin

@kreene1987 I replicated the settings that you had that were visible on my switch, but still no luck. The voltage is always on and constant which is correct (smart bulb mode is working). If I modify the “Inovelli dimmer: level” value via Home Assistant (standard lovelace entity card; looks like a light bulb) then I do see the LED values changing on the switch. However if I push the up or down paddles on the switch the level doesn’t change. Any chance you could share your other settings so I can see what I may have done wrong? Any other steps you took when setting it up that come to mind?

Here’s my current setup for reference:
Config values:


System values:


User values:

Thanks for the tag @nosuch. Let’s get you set up properly.

So if I am understanding correctly, you are wanting to be able to both locally and via z-wave increase or decrease the brightness of the switch and then make the bulbs match that same brightness, yes?

Assuming so, the following SHOULD work:

  1. Change protection to none/off, but keep smart bulb mode on. This will allow you to locally dim the switch brightness via paddle HOLD, but will keep power at 100% to the bulb. By having protection on, you are currently telling the switch that you don’t want anything to happen except a scene to be passed from the switch, but no actual switch modifications to be allowed.

  2. Build a link between switch level and bulb level. This can be done in a variety of ways (automations, node-red, etc.).

Essentially what will happen is you will hold the switch down and the bar will decrease to X% (let’s say 30%). After you release the down paddle, it will send the new level to the hub, which can then trigger your chosen automation (based on changed state). The chosen automation will then send a command to the impacted bulbs to change brightness to match the level of the switch.

Since you are using 2 different technologies, you will have to go through the hub and there might be a perceptible delay. If you were to use z-wave bulbs/fixtures, they could be associated such that a change in the dimmer level would immediately result in a change to the bulb level without going through the hub. I have to do the same with my zigbee can fixtures and it’s not perfect but it’s pretty darn fast after the paddle is released.

You can also disable the delay if you want to for faster performance since you are not relying on scene controls. If you still want to retain scene controls (for example at the same switch you want double up to go to 100%) then you can leave that setting as-is (instant-on disabled).

Kevin

Note: You will still have the same issue I am having where when the switch is pressed down once or commanded off by z-wave that it will cut power to the bulbs and they will show offline. @EricM_Inovelli is working on firmware to resolve, but for now that is the only real negative to this setup.

1 Like

The protection mode was causing the issue - turning it off enabled the paddles to change the LED level on the switch, which also triggered the automation in Home Assistant to change bulb brightness. Thanks for this, it makes sense now that I understand the setting.

Not sure I’m understanding the instant on feature - my preferred functionality would be that the light dims up or down while I hold the paddle (not on release). I tried changing instant-on to enabled (700ms) but that didn’t appear to do the trick. Could that be an issue with my automation?

1 Like

Eric, do you have any idea on ETA for this if this has been going on this long? More than willing (hoping) to test for you!

I’m not sure on the timeline, but we are working on it. There was a new engineer assigned to the project and he is having a hard time understanding the requirements. So I am trying to help him know what he is supposed to do.

1 Like

Easy: “When smart bulb mode is enabled, power should always be passed through the relay at 100%” :slight_smile: I know it’s not that simple as there are other competing settings and there’s also the dimmer bulb to consider, but imo smart bulb mode should supersede any other setting or value. It’s been difficult to use the dimmers in a smart bulb setup as they keep getting turned off by family members.

1 Like

You need to turn on disable local control. That keeps the switch/dimmer from working locally. You can still use it as a scene controller.

Smart Bulb Mode only insures full output from the switch. If you are using a smart bulb, you need to turn both settings on. There is a reason that the two settings are separate, so this is intentional.

I originally did have local control disabled (see top of thread). I wasn’t happy with the scene only control as that’s now how I expect a dimmer to work. Ideally I’d like something as easy as Lutron Aurora - being able to adjust the dimmer and see the lights update to reflect it. I’m fine with a little delay due to the automation, but having to hold down the dimmer, watch the LED level until it reflects what I perceive to be the light level that I want, and then release it to see the result isn’t great. Honestly I’m not very happy with the setup and considering replacing them with something else that works like anyone would expect of a dimmer (like the Aurora).

Side note: Totally get the delay in going from ZWave to ZigBee that’s inherent and I’m good with that. Delay is not the issue, it’s the behavior.

LOL, I know it is that easy for you and I. It is more of a “language” issue as well as a “please explain why in the world anyone would want this” issue. They sometimes don’t accept my usual answer to the second question “BECAUSE THE COMMUNITY WANTS IT!” so I have to actually explain the situation.

As a community focused person, I get it :slight_smile: My $0.02, find someone internal to dogfood your products with Hue bulbs. The required intermediate piece to run the automations is somewhat unique. It’s also a documentation gap - I’ve found ZWave bulb blog posts but nothing that directly shows the best experience with ZigBee (which I have to believe are more common). Appreciate your responses, it keeps me wanting to be a fan of your products!

Just twiddling my thumbs with 1% flashlights in my bedrooms.

Nah you guys are incredible and I can be patient. Really really wish you could bring this in-house for firmware, sounds like you guys are doing a lot of waiting when you could do it in a heartbeat.

Good news is Nathan and Eric M. are working on this :slight_smile:

The problem is that there was a, “misunderstanding” (idk, it’s pretty clear in the contract we signed) with allowing the source code to be given to us (well Eric) so we could modify it. So, we’re having to go around the manufacturer and build the code from scratch using a separate company who specializes in Z-Wave. Once that’s completed, Eric M can make modifications. Unfortunately his bandwidth is limited for him to learn and write the original source code otherwise we would’ve definitely done it already – but he will be able to make minor modifications.

I cannot wait for the day to come!

2 Likes

So, I recently bought some LZW31-SN to work as scene controllers in outlet switch gangs. I can’t have them function as physical dimmers but my hope was to still have the LED bar to be a dim level mirror for my smart lights (Hue). From my understanding on reading this thread, there’s no way to do this currently with any combination of “Smart Bulb Mode”, “Local Control”, etc?

I thought these settings would allow the switch to basically bridge line and load at all times and yet keep other functions of the switch for virtual use, without affecting power level at the load.

I believe that fix is coming in an update. I can’t wait