LZW31-SN stopped sending scene / status events to hubitat after firmware upgrade

I have 4 LZW31-SN switches and upgraded them from z-wave 1.45 to 1.61 and holtek 1.41 to 1.45. All 4 now exhibit the problem. I first noticed that scene event reports like double tap up (push 2) or triple down (hold 3) was no longer sending those events to hubitat. Then I noticed that even single tap is not being sent so hubitat only knows the status of the switch when manually polled or refreshed (clicking the respective button in the driver view).

I have tried setting 50. Button Press Delay to 700ms. I have toggled 51. Disable Physical On/Off Delay yes/no/no selection multiple times (right now its on “No (default)”. I have toggled power from the circuit breaker hoping that would somehow bring the functionality back to life.

Any ideas on how to resolved this?


Try factory resetting one of the switches and add back into the network.

I thought maybe local protection was enabled, but think it should still be sending scenes to the hub unless the parameter 50 was set incorrectly. But sounds like you’ve triple checked that.

confirmed on the triple checking of param 50 (tried a few different values on that too). I’m not sure why its not sending scene status on even a single tap.

I should have time tomorrow to try the factory reset. I was really hoping I would not have to do that as I have a lot of rules/configuration setup on my hub…

@random9 Did you flash the correct firmware? You did use the -SN firmware correct? There’s been a few who flashed the incorrect .otz file.


Direct link to download (folder path)

1 Like

I see parameter 50 (button press event/multi-tap “delay”) mentioned but not 51 (enable/disable physical on/off delay, which also determines whether multi-taps are available in the first place). I’m not exactly sure when both were introduced but know the latter came before the former (which is why they are somewhat overlapping, the first being an easy attempt at addressing one specific concern related to this feature). But in any case, new parameters seem to come initialized to some random value, so setting them one way and then setting them back to what you want (or really just setting them how you want in the first place, but not all drivers handle this well if the initial value isn’t clear…) may help.

If you don’t trust your driver, the Basic Z-Wave Tool can also get or set the value of any parameter. I haven’t found that necessary myself but have found the need to set new values after firmware upgrades for new parameters, including the same problem you had, and I think this was the solution. (I honestly don’t remember if all button events or just multi-taps were gone…sounds like they all are for you and this parameter doesn’t sound like it should do that, but, again, I don’t recall…)

1 Like

I confirmed, downloaded “LZW31-SN_1.61.otz” - browser history shows the only firmware download page I went to was https://support.inovelli.com/portal/en/kb/articles/firmware-change-log-lzw31-sn-dimmer-switch-red-series

1 Like

@BertABCD1234 - sorry if it wasn’t clear in my original post, but yes, I changed 51 multiple times without success as well.

Interesting idea with the Basic Z-Wave Tool, I do have that already setup, but I figure its worth a try before I go the road of a factory reset (something I’m really trying to avoid).

Update: tried the Basic Z-Wave Tool for param 50 and 51 without success :frowning:

Did you try changing param 50 to 1 and then back to 7? I vaguely remember having the same issue.

Just to make sure: what does the Basic Z-Wave Tool say if you run the “Get Parameter Report” command for (at least) these two parameters, 50 and 51? (The output will be in “Logs.”)

Just tried it. no success. I had previously tried other values like 300ms, 600ms, 700ms… they all change the behavior of the switch, but no reporting of the tap/scene events back to hubitat.

ConfigurationReport- parameterNumber:50, size:1, value:7
ConfigurationReport- parameterNumber:51, size:1, value:1

If these other things don’t work out, you can also try flashing it again.

just tried that, but no change in behavior

Solved: exclusion / inclusion fixed it!

Painful (I was really trying to avoid doing this) as all my rules, automations, etc. now need to be fixed, but at least it’s working.


Oof. That is a PITA, but at least it’s fully functional again.

Check out the new Settings > Swap Apps Device feature if you’re on platform version 2.3.1 (or the Settings > Z-Wave Details “Replace” feature on the node on any recent C-7 platform version, though that is trickier and pickier in my experience — and be sure you don’t use the same hub to perform a general [or regular] exclusion on the device first, though you’ll need to either do that or reset it to get the node marked as failed and thus eligible for this in the first place … have I mentioned how much easier the other thing might be? :smiley: ).

thanks for the pointer, I was not aware of that feature. of course, I already when through the exclusion/inclusion thus deleting the device (such that it would not be in the old and then re-adding it. no worries, just a pain but already through it.

Really hoping future firmware updates don’t cause this painful experience…