LZW31-SN Switch Acting Irratic

I’ve been wiring the whole house with Inovelli Smart Switches, and ran into a non-neutral wire situation, so ended up ordering an LZW31-SN to deal with this scenario (easier than trying to run a neutral wire to the box). I am having an issue where the switch is now acting irractically.

Here is a run-down of my situation.

LZW31-SN Red Dimmer Run In a Single Pole Setup w/ No-Neutral.
It is powering 2 LED Bay Lights in my Garage
Wattage wasn’t enough draw as I had to wire in one of the Aotec Bypass to get the switch to function correctly.
Switch connected / controlled via Hubitat (installed LZW31-SN Drivers)

Now it is working correctly, but having some issues I am thinking maybe related to setup? Initially the settings had the dimming speed set to 3 (default) but I don’t care about using the switch in a “dimmer” type usage. I just want it to act as an off / switch instantly.

I set the dimming rate to 0 in order to have it work as an off / on switch. As soon as I did this it stopped working. IE I’d hit the switch and it would just flash the colors green / red / blue then not turn on. As soon as I turned dimming rate back to 3 it would come on normally.

All settings on the switch are still set to default. It seems the longer I leave the switch alone the weirded it acts. For example I came home today and went into the garage (lights are motion sensing to turn on) and I could tell the light switch was triggered but it didnt’ come on. I had to go manually hold the light switch up and eventually after 10 seconds it came on.

Any ideas how to start trouble shooting this one? or perhaps what settings you would suggest. The dimming rate feels slow to respond so would prefer to use it as an “on / off”. Anytime I set it to anything lower than 3 it basically stops functioning.

@GregW - That is a weird one. I use dimming speed of 1 and haven’t had any issues like yours. I wonder if you just need to RMA that guy because the color flashing almost sounds like it’s restarting after power restoral. You don’t have line and load swapped do you? You also have it set for single pole vice 3 way right?

Hmm don’t think I have the load / line switched. Made me 2nd guess myself so just pulled it apart to check. It’s correct (verified with multimeter) that the line is in the line and load is in the load?

How do I ensure its set for “single pole vice 3 way”? Under ‘switch type’ in the settings there is “load only”, 3 way toggle and 3 way momentary. (right now it’s got nothing selected). Should I select it as “load only”?

For example here is what happens when I have my dimming speed on anything less than 3.

It might be hard to see from the gif but after I hit the button it just flashes those colors and go back. It trakes hitting the button 3 times there to get it to eventually turn on…Turn it back to dimming speed 3 and it’s fine. Then say 6 or 7 hours later I’ll walk into the room and even with dimming speed 3 it’ll do something similar again (had to hold down the “on” button earlier to even get it to turn on)

@GregW Yes go ahead and set those parameters for Load only and neutral or non neutral (whichever is right). Make sure you save it.

Just set it to Load only (already had the AC Power type set to “no neutral”) and saved prefernces.

As soon as I set that ramp rate to 0 it does the same thing as above again in that video. Set it back to 3 it will work (but again kind of sporatically). I’ll test again tommorow but once I leave it for a few hours it seems really laggy to respond.


Yea please reach out to Team Inovelli. You may need to replace it. @Eric_Inovelli @anon64478871 @EricM_Inovelli - Some weird indications for a simple single load non-neutral setup. Any ideas?

That light sequence seems to be the same as what it does when you pull the air-gap and push it back in like it’s rebooting.

Before you give up and RMA this, airgap the dimmer and try installing a pure incandescent load, no LEDs, then re-enable the dimmer. I have seen this sort of odd behavior myself, even on a circuit with one incandescent and one LED it still behaved oddly, untill I tried only incandescent, then eventually got it working with one DIFFERENT BRAND LED, and one incandescent bulb. Clearly just having the one Feit LED was causing problems, when I swapped for a Philips bulb it worked correctly. Good luck

@jsbeddow - Definitely worth trying this. I gave up on all my Feit bulbs. Just not worth the hassle. They’re loud when on a dimmer…I recently just bought Great Eagle bulbs from Amazon and they’re silent for me.

To be kind of honest it seems like now trying to swap bulbs would be kind of a pain in the ass. The rest of the house is all on LED recessed lighting, and the inovelli LZW30’s all worked great (about 15 of em wired up).

This was the one that didn’t have a neutral wire in the bundle so I purchased the LZ31 seperate (like $80 CAD by the time it landed). Then had to get the Aotec bypass after figuring out the switch wouldn’t’ work. So was another $50 by the time I factor in shipping etc to get it here.

So now I am into this thing for $130 for a smart switch and then I’ve gotta start replacing the Garage Lights on kind of a chance that it’s the LED’s that it isn’t liking. At that point I feel like I am almost better off to try to just bring a neutral down to that box instead of trying to screw around with this setup and just use an LZW30 which has given me no problems and are cheaper.