LZW31-SN Switches Bricked after Update

I have about 7 Inovelli devices. However, I have 3x Inovelli LZW31-SN switches that are bricked, or at least I think they are.

They had worked properly before, with local control disabled (and in one case, still enabled). However, Home Assistant had an update for these switches to the latest firmware. I used the built in Home Assistant updater to update them, but they hung and never updated.

The switches actually still showed up as connected, but will not respond to any commands. I cannot enable/disable local control, or any other controls. The switch still powers up in the last connected state (one is off, one is on) and it lights up, but none of the local controls (multiple presses of the config button, either paddles) do anything to change the state. It makes me think that the firmware is just hosed on it.

Is there any way to either (a) send these in to get them re-flashed to a working firmware again, or (b) take them apart myself, and flash them to a working firmware? Especially given the availability of these switches, I’d like to still be able to use them. The HomeSeer switches I have are kinda meh, and I don’t love the Eaton replacements I got either. Ideally, I’d love to use these again, if I could get good firmware again.

From what I can tell, the devices themselves are still fine. Upon returning power to them, I can see them initialize by blinking lights on the switch and (maybe) turning on the load (for the ones that were on before they got bricked) so I think it’s just a firmware thing.

Any assistance would be appreciated :slight_smile:

Did you flash both sets of firmware? Flash 0 and 1?

ZwaveJS is supposed to have a web based user interface. You could try accessing it and see if it will update from there. Do it manually, downloading the firmware and updating both end points.

I’m not sure on zwaveJS. I use zwaveJS-ui which has the updating capability.

I believe Z-Wave JS only tried to flash firmware 0.

@PJF I was using the Z-Wave JS interface.

The underlying issue now is that I am not able to flash any firmware on these switches, nor get them into any configuration mode. Once I removed them from my Z-Wave controller, I’m unable to pair them again, reset them locally, etc.

1 Like

I’d look at getting PC Controller to flash them from a zwave stick.

2 Likes

I would try using SILabs PC Controller. Exclude using that tool, then add.

1 Like

For both your and @harjms suggestion - how can I adopt / flash them using that if none of the actions on the actual switch do anything? To be clear: I cannot put the switches into any mode that would let them be adopted by a controller. Nothing works at all.

1 Like

You can’t even factory reset?

Nope, no commands work. I’ve tried all of the (press the config button however many times) commands, and it responds to nothing. It seems totally bricked. It makes me sad because these are far better than the Homeseer switches I have, but this last update attempt just … made this happen :frowning:

Did you try a config long press for about 40 seconds and wait for the LED to turn red? That’s a factory reset. It’s not a x times thing, just press it and hold it down for a while.

1 Like

Yeah, I tried that as well. Just as a sanity check, I’ll re-hook it up and try that to be sure, but I’m fairly certain I did.

2 Likes

Oookay. Sad to report - 40 seconds waiting for the LED to turn red did not work. As before, both switches did nothing after that time period was reached (even waited a good 20-30s longer in case I was counting too fast).

FWIW - not a huge deal. I have like 6 Zigbee versions of the switches I can replace them with (though the recent recall of them affected all of mine :frowning:) BUT - given the supply shortages, if there’s any way to get them fixed (even if it involves paying to send them in) it feels like it’d be worth it.

Make sure the switch doesn’t think it’s still part of a network. It should NOT brick due to firmware only being partially flashed (only one endpoint) in theory.

Put network in exclude mode and hit the config 3 times. See if it excludes itself somehow (doesn’t have to be part of network to exclude) and then it might pair up again.

The network no longer exists, but I did put my new network into exclude, and hit config 3 times. Nothing happened on the switch side, and it continues to not respond.

For what its worth, I don’t know if the one endpoint even got successfully flashed, or if something happened mid update that has put the switches in this catatonic state.

Same here.

Bricked during firmware update won’t respond to local button presses. Will have to replace it.

I’m hoping we don’t need to fully replace them? I can’t imagine they can’t be flashed using some other method… any thoughts from any Inovelli folks? Would love to keep this hardware working (especially since I can’t use any of my new Blue switches yet since they’re subject to the recall :frowning: )

I would be surprised if there was a way, hardware buttons no longer working isn’t a good sign. I haven’t tried much yet but it’s no longer accessible in the network and physical buttons have no response.

I’m guessing if there are pins in the device maybe flashing it with some kind of hardware flasher might help.

I’ll pull mine out on the weekend hopefully to see.