LZW31-SN turns off randomly

So, I appear to be on version 1.35. Why do I doubt updating the firmware is easy?

It’s not hard per say but you need to purchase a USB zwave stick and download some software

This is the stick Inovelli usually recommends but almost one should work.
https://www.amazon.com/dp/B00VKEH1BQ/ref=cm_sw_r_cp_apa_fabc_H6McGbWTF4Y1K?_encoding=UTF8&psc=1

So after I spent $40 for a switch, I’m now supposed to spend another $35 to make the switch work how it should have out of the box? Not to mention the time trying to figure out how to update it and the risk of bricking it. I already have over 3hrs in swapping switches from room to room and changing settings, trying to figure out what I was doing wrong. I do appreciate your responses and time though. Probably just going to find a different product. My experience with Inovelli hasn’t been great from the beginning. This is just another mark against them.

Just to be clear, there is no way to update the red series dimmer switch firmware with smartthings? I must buy a usb dongle and us PC? I ask because someone I know has the combo fan/light switch with smartthings and claims he is getting update alerts and is able to update via smartthings.

Hey Dave – apologies for the frustration and hopefully we can turn this around for you as I went through your ticket history and yes, it’s been a fun adventure to say the least (although, it does look like we made things right with the almond paddles).

A couple of options for you – let me know which one works best for you.

  1. We can send out new switches with the latest firmware on them and you can send back the old ones
  2. You can send us the old ones and we’ll flash the firmware on it for you (we’ll pay shipping)
  3. We can send you a Z-Stick and help you over the phone with the update process

As far as the update process goes with ST – as far as I’m aware, there’s no way to update all products at this time via the Hub. They are piloting a process where Z-Wave can be updated over-the-air, but that’s with select products. If your friend has ZigBee, then I do believe they support OTA.

I sincerely am sorry for the frustration and am thankful for you being one of the early supporters of our new switches and as you may have noticed, we’ve come a long way since they’ve been released and the bug that you are experiencing is one of them.

Feel free to either respond here, or shoot me a PM and we’ll take care of you!

So I bought the $35 stick and am now trying to download the Silicon labs PC controller software (via the link in “how to”). I registered an account and now am being told I have to first download either a controller sdk or embedded sdk before downloading “z-wave tools”. What am I missing?

You did do well with the almond paddles. Thank you for that. I tried the z-wave.me stick with the convoluted software and got to where it is supposed to find the USB stick as a serial interface, but it doesn’t. I looked through device manager and the USB is showing up “PCI data acquisition device” and like 4 unknown devices. I’m on windows 8.1. Went looking for drivers, but none see to work. I’ve now put at least another hour into this. I’m not looking to cost you money, but if there is any way to just get updated switches sent, that would be great. The wife isn’t going to go for the 7 most used switches being missing for two weeks. I also have 3 switches that I haven’t installed yet. If possible, it would be preferred to do all 10 at once. Let me know what you need to get this going? Also, any chance you would have the Light Almond covers for the GEN 1 dimmers (not sure they even existed) you used to sell?

Hey man sorry I didn’t catch this thread. I’m going to send you a PM so I can keep track of our conversation as it’s hard to monitor all the threads whereas a PM shows up in my email as well.

Hey just checking to see if this issue was ever isolated and resolved. I have a Black Series LZW31 in a 3way setup with a dumb switch that behaves erratically whenever the dumb switch is in the off position. The Switch is at firmware version v1.57. I can turn on the switch over zwave and it will turn off anywhere from a few seconds later to a few minutes. If I turn it on at the smart switch the behavior is similar. Sometimes it will turn on an off several times every couple seconds before eventually staying off. The switches controls 6, 9w leds that are usually turned on via automation to 50% brightness. I have already set the max dimming to 80% as per suggestions earlier in this thread.

I was having some connectivity issues with this switch a few weeks back although its quite close to other zwave devices, however this is what prompted me to do the firmware upgrade. I hadn’t really noticed this turning off issue prior to that.

Make sure your wiring is 100%. I had this issue and thought I had it nailed, but in troubleshooting discovered I had to rewire the fixture. It worked exactly as you are describing.

Thanks for the reply. I double checked the wiring and it appears right to me. This switched worked fine for the last 3 months so a wiring issue was a hard sell. I did wonder about perhaps something becoming loose, ie marr connectors etc. however I replaced everything with wago fasteners and tightened things up to be sure.

My next plan is to replace the switch, as I was lucky enough to purchase 8 used ones on facebook marketplace. Availability in Canada is a challenge. Worst case, I relocate this unit to a spot not requiring a 3way connection.

I have subsequently installed another switch and had the same issue, however this one now works perfectly with a max dim setting of 85. As I’m running the current firmware on everything, I’m assuming this issue was never resolved.

Rob, one thing I forgot to mention is that in upgrading the firmware, some of the parameters get wonky settings. I would recommend you exclude, hard reset the switch (config for 20s until red LED bar), include, and reset parameters.

Also ensure you are using the latest driver/handler (what hub are you using?) on your platform.

Hardware failure is unlikely considering historical failure rates on these devices.

Using Home Assistant with Z-Wave JS with an Aeotec Zwave Gen5 stick. I will try the hard reset today and report back. thanks

Reset and included. Reconfigured and switch is having same unfortunate behavior. Works properly when dumb switch is on. When dumb switch is off, turning on over zwave or from smart switch stays on for a few seconds, then turns off. Max Dimming set to 85

Hoping you or someone else can clarify this. Been googling all day with no clear answer.

I have all my LZW31 switches at firmware version 1.57, however I was totally unaware that the firmware in some cases had two components or targets. What is the significance of this and could this have an impact on how the switch was behaving ie the turning itself off. I went back and downloaded the current .bin file and flashed it on this morning, but haven’t tested yet.

In the configuration I’m having trouble with a couple parameters.

(11) Power On State: all the docs I can find say that 101 will return the switch to its previous state, however regardless of how I set this, it reverts back to 100

(12) Association Settings: I attempted to disable all, however the Timer parameter keeps going back to Enabled.

I have (51) Physical On/Off Delay disabled as I have no scenes, so not sure about the importance of setting (50) Configure Physical On/Off Delay, however I try to set to 0 and it says it has to be between 1 and 7

Switches have one MCU but dimmers have 2 MCUs, so when you flash a dimmer, you must flash both targets 0 (.otz) and 1 (.bin). It’s certainly possible that failing to flash both targets could cause your issue, as the code is split between the 2 MCUs. As to whether or not it could cause your specific problem, I don’t think you’ll know until you have properly flashed.

The Firmware Change Log details flashing both targets:

1 Like

Bry,

Thanks for your input. It does appear that this was the problem. I don’t want to jinx myself but the switch has been working as expected for a couple hours now. I did not have this problem when the switch was first installed, so its very possible the troubles started after a partial firmware update. As the switches are seldom used manually it may have been several weeks before the dumb switch was in the off position.

I think you figured out your issue on this, but feel free to tag me again. I go into hiding on weekends and usually check back Monday mornings (now!).

One of the best resources I have found universally for settings and parameter checks is devices.zwave-js.io.

Specifically for this device, here is the link: Z-Wave JS Config DB Browser

This should give you a description of all parameters, whether they are working or not in the firmware version you have, etc.

If you have any specific questions about them, feel free to tag/reach out. I’ll hit on the few you have listed:

Brightness After Power Failure (#11): This allows you to say if you lose power in the middle of the night, would you rather have it come back ON, OFF, or the state it was in when it lost power (this is in cold memory). I typically select 101 because coming back to the last state makes the most sense to me. 101 should be a valid entry, if it is going back to 100 please post your logs while attempting to set to 101. (also confirm hub, maybe again?)

Association Behavior (#12): When should the switch send commands to associated devices? This is the behavior of the switch when associated to other devices (like bulbs) and is made up by adding up 4 partial parameters:
image

Another way of viewing this is in the z-wave chart:
image

In 99% of installations all 4 should be ENABLED which gives you a total of 15 (1+2+4+8). By flagging any to 0 you would subtract that mask amount from the total to get your new value. The table in the second image is easier though.

Button Delay Period (#50): This is the period from when the button is RELEASED to when it sends the command of button presses count. This is when you are in a multi-tap environment using scenes as some individuals wanted a faster response time than the default 700ms. This is a balance between sending the scene too fast and having to wait for action after the last release on a multi-press. I have mine set at 5 (500ms) and do use scene control for 99% of my switches since I am using multi-taps (2x) to turn on/off entire areas in my installation.

Button Delay (#51): When enabled, this allows scene control (multi-tap) to be sent to the hub. When disabled, it removes #50 delay period because more than single taps are disabled. You will still get single up/down/config scenes though. I rarely disable this, again because I want to use multi-taps.

It sounds like your install you want to keep it simple for now and disable #51 (set 0), which will disregard #51 entirely (no impact/change needed, except maybe set it non-zero after updating firmware since the switch can get confused after firmware updates if there was data there previously, I’d recommend a quick 5 entry to be safe), and you don’t have any association requirements at this time (you don’t have any 2x reds in a 3-way arragement) so you want 15 for param 12.

Hopefully this all helps. Hopefully the revised .bin works!

2 Likes