PC controller download link not working

The link to get PC Controller that this page points you to doesnt work. https://support.inovelli.com/portal/en/kb/articles/how-to-update-device-firmware-z-wave-smartthings-secondary-controller-method

it sends you to https://siliconlabs.force.com/s/validatezwsdk?ContentId=0681M000006WUzV%20&ContentType=SDK&rURL=https%3A//www.silabs.com/products/development-tools/software/z-wave/embedded-sdk.html

That page gives you the following message when you goto it. Please help.

1 Like

Try this. I have a vague recollection that I had to download a SDK first. I didn’t use it, but I think I had to download it.


The URL looks like it’s for the SDK but I get the PC Controller download. If it wants you to dl the SDK, do it and disregard it and then try the URL again.

I get the same error message when I click on your link.

Did you create an account and log in?

Yes, I created an account and I am logged into their site.

Ok, so go find a sdk and download it. Then see if it will let you d/l the controller.

Not sure where to find an SDK. I tried installing simplicity studio, logged in, found some sdks and downloaded them. tried to click on the link for pc controller and got the same message.

I just went through this trying to get PC Controller installed as well. So for the current version, you do install Simplicity Studio. Once in Simplicity Studio, log in with your SILabs account.
Click on Tools (edit - actually, you can just click Install next to Tools to skip the next step and go straight to the Technology Type screen)

Add/Remove (I feel like my first time loading this up had a different screen here)

Install by Technology Type

Choose Z-Wave and then hit Next

Your account should have Development access, so nothing to do on this page but hit Next

You should be good to uncheck everything except for PC Controller, then hit Next to install it

Once it’s done installing, to run it, on the main Simplicity Studio window, click Tools again, then select Z-Wave PC Controller, and then OK

A bit of a pain, but that should get you there


Thanks @dbemis!

1 Like

I ended up using the instructions at Z-Wave command class configuration tool download. : Aeotec Group to download Simplicity Studio, but it doesn’t work for me. The Login screen is just completely blank, no matter what I do. No way to login, and if I don’t login, the list of software I can install is empty - 0 products found.

I went digging through various support posts on the Silicon Labs website, and they point to things like editing an INI file to enable the windows cert trust store, or manually installing Internet Explorer 11 (!!!) to get things to work.

I tried it all on my Windows 10 machine, and nothing works. Sure would be nice if the instructions here at Inovelli could be updated with more accurate information.

I know this thread is old but I had the same problem with Simplicity Studio 5 and the only solution is to right click on studio.exe or the desktop shortcut and choose run this program as administrator.

So for anyone like me searching the forums and or google and you are struggling with this same situation.

  1. Download simplicity studio as above
  2. click tools as above.
  3. Click manage installed packages (with box logo)
  4. Click the tools header
  5. Find Z-Wave PC controller and click install button

go back to tools and launch controller as above.

they seem to have taken Z-Wave out of the “by technology type” options and have to manually add it in now.

Once you install the PC controller software, I recommend creating a manual copy of the folder (typically located in C:\SiliconLabs\SimplicityStudio\v5_2\developer\tools\zwave).

The PC software does not require Simplicity studio to run (only to install). If you copy the folder somewhere safe you can uninstall simplicity studio and still run it.

important to note, do not do what user jtronicus suggested while you are mid firmware update :rofl:

luckily I didn’t brick my switch, but closing out of simplicity studio also closed out of the zwave controller since I had opened from it from within the studio and my firmware update was killed mid stream.

If you don’t want to bother with downloading the Simplicity Studio, iblinds.com has a download link for the PC controller 5.39.