Firmware v1.36 (Beta) | LZW36 | Fan + Light - Red Series

Z-Wave 700 is using a different file format for Z-Wave updates. So, there will not be a .bin file released (or .otz for that matter).

My guess is that as more and more 700 series devices come out, zwavejs will support them.

Side note: the gbl file is a “binary” file. Does it not let you select that extension?

I hadn’t tried for fear of messing something up. Is it all target 0 in this case(i guess the z-wave chip)?

Bypassing my fear I tried it and it “just worked”. 100x more straightforward than doing it with SiLabs software.

1 Like

Nice, I believe there are some users on the forums that have used this update method, but I wasn’t sure.

1 Like

Can anyone provide me a link to the PC Controller 5.39+ for Windows? There is no link that I can find to any software like this on SiLabs’ site. The link from this thread takes me to a page on their site that says “Please download either a Controller SDK or Embedded SDK before downloading Z-Wave tools.” Somehow I downloaded a half gig file called “Simplicity Studio” which doesn’t look like it is the right software since the screenshots don’t match. Thanks.

1 Like

If you installed Simplicity Studio, you can use it to launch the Controller software by going to Tools → Z-Wave PC Controller:

If You dont see it under tools, you can install it by going to Install → Tools → Z-wave PC Controller:

This is the only way I know of to get the latest version of the software (I managed to find an older version online, but not the latest)


Thank you and jtronicus for the detailed instructions! That was very helpful and I was able to now figure out how to install and launch it. I appreciate it. Only issue now is that I follow the inclusion instructions and the “Network Management” option is greyed out in the PC Controller App. I’ve tried the Discover process but nothing shows up. Is this because I have to also have a separate Z-stick to do the update? I’m using SmartThings, and from what I can tell, I can’t flash without a z-stick because SmartThings doesn’t support OTA.

This is definitely a much higher learning curve for firmware installation than most devices I’ve used. I think reflashing BIOS on my desktop has to be easier than this.

Yep. You need to a Zwave USB device plugged in. I’m using this one:

1 Like

Thank you. Lastly, do you think any firmware updates are significant enough that they justify purchasing the zstick to update the firmware? I received my switch from factory when they first came out so it has the very first firmware that was on the released version.

I think you have to evaluate how you are using the switch, if something is broken and whether or not there is a new feature you’d like. Personally, I subscribe to the “if it’s not broken don’t fix it” school. Pretty much everything I have works out of the box in my application so I have no reason to update. But I’m not using the functions that others are seeking through the firmware updates.

1 Like

Just updated to this firmware and noticed that setting the config value for the Light LED Brightness When Off will set the Light LED On Brightness to default, ignoring the current value until it is set again.

Anyone else seeing this issue?

I have tried restarting the switch after the upgrade as well as trying the upgrade again and reinterviewing the node. No luck.

At the moment my solution is to just send the on value immediately after updating the off value but it would be good to see a fix. Thanks!

Has anyone had an issue where the canopy module does not work at all after installing this firmware? I updated one of my devices last night and the canopy will not do ANYTHING, even after breaker flip for 1 min or so. No lights, no fan. Switch is reporting and working perfectly.

Not sure what might have happened?

Try pairing the canopy again?

I should be more detailed. I tried resetting the canopy via D + E for 20s (or whatever the process is) and tried pairing again after breaker reset, and it won’t connect. The canopy isn’t even pulsing after 30s either. I’ll try leaving the breaker off for a bit longer today and report back.

Is 1.36 still latest for the fan/light switch? It just seems like it’s been out for a while, and I thought there would have been more updates since then.


I believe so. It’s the latest on the firmware download page.

1 Like

I wanted to update as I am replacing my canopies this weekend with the revised units. I pulled everything apart and re-installed a new canopy, but this same switch still was acting up. I returned power to the circuit with the switch air-gapped, the canopy unit pulsed, and I paired the switch (closed air gap, did the procedure). Upon completing the pairing, the light went to min, the fan stayed off, but the 36 controlled NOTHING. Level changes on both rendered zero results.

Flashed back to 1.31 and it’s working perfectly.

I actually have had entirely zero luck with 1.36 installed myself. I had to get Inovelli to send me one already updated to get my Living Room Fan to work properly (distance was too far and was dropping on 1.31). So I am wondering if anyone else has any issues with 1.36? I flashed it at least 4 times to the switch, but it acted as if the canopy unit was not connected at all even after a successful pair (green lights).

I can’t comment, since all of my LZW36’s are still running the short-lived v1.34 firmware…

1 Like

Mine were also on 1.34 but I just updated one of them to 1.36 to test and it seems to be working just as well. Turned on/off fan and light both via the hub and the switch itself. I’ll update if something stops working, but nothing yet.

1 Like