Firmware v1.36 (Beta) | LZW36 | Fan + Light - Red Series

We are releasing a beta firmware for the LZW36. See the link for bug fixes and enhancements. One notable addition:

Parameter 51 to disable the 700ms delay from when you press the physical on/off buttons. This is similar to what we released on the switch a bit ago.

You will need to update your Hubitat driver or SmartThings device handler to expose the new setting

This firmware should be stable, but if there are any issues, please let us know.

7 Likes

I updated my LZW36 via the modified Hubitat Z-Wave Firmware Updater to 1.36 and enabled the Disable Physical On/Off Delay, it now turns on/off much faster than I was able to get it by just changing the ramp rates to 0 before! Thanks for the update, I think my wife will appreciate it!

2 Likes

I wish i could use .gbl files with homeseer but i cannot. Any chance for a .hex?

I asked our engineer some time ago and they were not able to convert the binary file to hex. I’ll ask again but you might want to check if Homeseer plans on supporting gbl files. I believe they are the standard going forward with Z-Wave 700.

When I go to apply this update, this is what I get:

[2020-08-20 02:57:19.637 pm [error] java.lang.NullPointerException: Cannot invoke method and() on null object on line 461 (firmwareStore)

Can you tell me what I should do to resolve this error?

1 Like

@jesse.sissom what method are you trying to use to apply the update?

The updater driver on hubitat local.

I’m having the same update problem as @jessie.sissom.
This is on the latest Hubitat firmware (2.2.3.119).
In my case, I had the switch added with all of the security options off (i.e., I un-checked the S2 and S0 boxes when adding it).

Sorry, I’m still on 2.2.2.129 because it is working great for me and Ive heard to many issues with not being able to boot after upgrading and my hub is a C-3 so I don’t have any experience with the C-7 hubs yet.

@jvm33 @jesse.sissom I don’t think there is a problem with the update file as I’ve used it a couple times in Hubitat. Is it possible that you are not using the Binary version of the z-wave updater. There are two versions floating around now.

I installed the this firmware on my device but cannot see the new parameters. I have excluded and included the device multiple times, but still no luck. I have confirmed that the application version is in fact 1.36. Any ideas? I am using Zwave2Mqtt.

Have the new drivers saved?

Sorry, I am unsure what you mean by this? Fairly new to Zwave devices.

I may be off…not a user of open zwave…whenever a new firmware comes out with new features, usually (for Hubitat/SmartThings etc…), we have to upgrade the drivers to support the new features. Open Z wave may be different, but here is the link to the latest 36.xml file.

I’m not sure how you import or if you do. :man_shrugging: It may be automatic.

Looking through this .xml file, it does not seem to have the new configuration parameter (index=“51”). Am I missing something?

Let’s get the man with the plan @EricM_Inovelli - Driver update required for param 51 on Open Zwave platform?

I have added it to our personal config file location but haven’t had a chance to test it yet. @Myztillx can you test it out and I will submit it to open-zwave as a PR?

https://github.com/InovelliUSA/OpenZWave/blob/master/config/inovelli/lzw36.xml

1 Like

Thanks @EricM_Inovelli! I know you’re a busy guy!

1 Like

I’ll try and take a look this weekend when I have some time and get back to you!