LZW31-SN, Zigbee downlights and Home Assistant - Config help

Posted this on Reddit earlier and Eric suggested I post here as well.

Fairly new to HA, Installed this year - Not a coder, but work in IT and can figure most things out…just not this apparently!

Hardware:
Windows PC running Oracle VirtualBox running an Ubuntu VM
HUSBZB-1 Quickstick Combo
(1) Inovelli LZW31-SN (Red Series Dimmer - running latest firmware)
(2) GE Aux Swithches
(13) ETI CCT Zigbee Downlight (Tunable white 6" downlight)
Neutral in every box

Software:
Home Assistant
Core - 2021.10.4
Supervisor - 2021.10.0
Host - Home Assistant OS 6.5

Configuration:
Using jerelabs/zwave-js-inovelli-lzw31-sn-red-series-dimmer.yaml Blueprint to create an automation to turn lights on and off and dim. I am not able to get this to work remotely reliably.

I know my wiring is correct as when I first installed, set the Inovelli switch to recognize the aux switches, everything worked as expected from every switch. The dimming worked but only by actually reducing the power to the lights, which I know I don’t want. When I disable the internal relay (Local Protection) I can get the lights to turn on and off from the main switch, but not the aux switches. Dimming also doesn’t work, though at this point I’m really just concentrating on getting on and off functionality, followed by dimming. I figure I can work on tuning later. I have tried every combination of Local Protection, Smart Bulb Mode, and activating the lights as a group via scene recall and individually as devices, with varying degrees of failure.

If anyone out there has a similar configuration (i.e., Inovelli Red Series Dimmer, controlling zigbee can lights) and has made the switch work like an ordinary dimmer, and is willing to share, I would appreciate it very much.

Hey! Thanks for coming over here – glad to have you :slight_smile:

Hopefully the community lives up to my hype left on Reddit!

Anyway, I promised I’d tag a few ppl to see if they can help: @kreene1987, @kendrosg, @jtronicus, @stu1811 do you guys have something similar or can help point @cromulent1 in the right direction?

@EricM_Inovelli – I know you’ve been messing with HA lately, maybe you have an idea?

You don’t want to disable local control. Just set SBM. That keeps the dimmer output on at 100% all the time. Then, check that you can dim the LED bar up and down using the switch paddles or the aux paddles. If that works, then you’re almost there, HA should have the switch internal dimmed level and you pass that to the light when it changes.

I never used a blueprint for anything zwave because the zwave landscape on home assistant is changing so much that most blueprints seemed obsolete pretty fast.

Automations are pretty easy to do entirely through the GUI though. The first thing to know is which HomeAssistant plugin/integration you’re using for zwave?

Just to clarfy… by latest firmware do you mean 1.57?

As far as parameter you want to set:
21 = 0 (No Netrual) or 1 (Neutral)
22 = 2 (Aux switch)
52 = 2 (SBM)

Then use this automation to dim the bulbs:

Thank you. Yes, running firmware version 1.57. I will give this a try tonight when I get home.

1 Like

Good to know. It just sounded like it would make things easier for repetitive switch configs. I’ll try it without and see what I come up with.

Thanks Eric, I appreciate the help. I’ve got a few good suggestions to try out in my copious spare time, ha ha. I’ll report back later this weekend with what works.

It definitely would take a bit longer the first time - but luckily after you make one automation, you can just duplicate it x amount of times and then just rename the dups appropriately and just change the drop down for which bulb(s) it’s controlling as well as the node ID.

Basically I just duplicate this automation, change the node ID to the node ID of the switch I’m dealing with then change the device it’s targeting (and below that, slightly off screen and not visible, the specific action it takes on said device - eg. Brightness 90%)

Yeah man, happy to help! Wish I knew more about HA, but glad I could point you in the right direction :slight_smile:

Looking forward to hearing how it goes this weekend!

Thank you! I got this working with the help of the automation code provided. I first tested it out on a single pole dimmer and it sort of worked until I realized that I couldn’t have the dimmer set to instant on at which point it started working exactly as expected. When I reproduced it on my 3-way, it worked great from the dimmer, but not the aux even though it was showing as configured in HA as a 3-way with aux. I manually configured it at the dimmer and presto! it now works from the aux switch. Thanks again for your kind assistance.

3 Likes