LZW36 1.34 - 1.36 upgrade (Hubitat). Problem with flash stage?

Hi,

I’m having a problem that I haven’t seen anyone else post about.

I’ve gone through numerous problems that others have already (re-adding the device with no security, being sure to use the binary version of the Firmware Updater etc).

Where I’m at now is that the firmware upload completes, the device logs that it’s flashing, and then nothing further happens.

The Firmware Updater’s Version Report returns applicationVersion:1.36, and the Firmer Updater Driver’s page shows currentFirmwareVersion: 1.36. Sounds good so far.

But when I switch back to the LZW36 driver, it shows firmware : 1.34. Furthermore if I select a value for the new option (51. Disable Physical On/Off Delay), it doesn’t stick.

So what I think I’m seeing is that the firmware uploads to the device, but it doesn’t actually flash.

Log entries, from the last upload fragment to when I pushed the button to turn the fan on:

dev:772021-07-10 04:10:10.992 pm infoOffice Fixture: Button 1 was pushed
dev:772021-07-10 04:10:10.983 pm debugOffice Fixture: CentralSceneNotification(keyAttributes:0, sceneNumber:2, sequenceNumber:1) 0
dev:772021-07-10 04:09:02.113 pm infoVersionReport- applicationVersion:1.36
dev:772021-07-10 04:09:02.109 pm infoVersionReport- zWaveProtocolVersion:7.13
dev:772021-07-10 04:08:38.166 pm debugskip: MeterReport(scale: 2, rateType: 1, scale2: 0, deltaTime: 0, previousMeterValue: [], meterType: 1, precision: 1, size: 4, meterValue: [0, 0, 2, 161])
dev:772021-07-10 04:08:35.491 pm debugskip: [email protected]7
dev:772021-07-10 04:08:32.578 pm debugskip: CentralSceneNotification(keyAttributes:0, sceneNumber:1, sequenceNumber:0, slowRefresh:true)
dev:772021-07-10 04:07:49.182 pm debugskip: MeterReport(scale: 2, rateType: 1, scale2: 0, deltaTime: 0, previousMeterValue: [], meterType: 1, precision: 1, size: 4, meterValue: [0, 0, 0, 9])
dev:772021-07-10 04:07:46.585 pm debugskip: [email protected]4
dev:772021-07-10 04:07:46.535 pm debugskip: [email protected]16
dev:772021-07-10 04:07:44.458 pm debuglocked by: 
dev:772021-07-10 04:07:44.449 pm infoNew image was successfully stored in temporary non-volatile memory. The device will now start storing the new image in primary non-volatile memory dedicated to executable code. Then the device will restart itself.
dev:772021-07-10 04:07:44.445 pm debugStatus: FirmwareUpdateMdStatusReport(status:255)
dev:772021-07-10 04:07:33.116 pm debugGot request for fragment #:4655 packing report and sending

Oh! And the fan does turn itself off when it would ostensibly be flashing, so it’s definitely doing something.

Any ideas? Thanks for you time!

Well… reading through some topics that others have raised, I saw one that mentioned clicking “Save Preferences” after switching back to the LZW36 driver, and that updates the firmware on that page to the flashed version. I just tried that, and it is showing 1.36. Furthermore, my Preference 51 setting is now sticking. So I guess this is resolved, but it seems weird that I didn’t see the same effect before when I tried setting Preference 51 after switching back to the LZW36 (after both flash attempts).

Anyway, hope this is of help to anyone else who may come across a similar issue!