image not found img not found

LZW36 Fan/Dimmer with Zwave2Mqtt Add-On

Has anyone set up the LZW36 Fan/Dimmer switch with the Home Assistant addon Zwave2MQTT?

I set one up this weekend, but it only has 1 user config variable to set the “brightness”. I have heard that there should be 3 (1 fan, 1 light, 1 both). I made sure to update the Zwave database and refesh node info (from the toggles in Settings), but still only the 1 config.

Any ideas how to get this working properly?

Edit: For reference the add-on uses OpenZwave 1.6.974

Are you seeing the different instances in your zwave2mqtt control panel?

No, I only see 1. Maybe I need to delete the node and re-add it? Sorry, I’m fairly new to Zwave, so I am not sure what all the options are…

It should automatically detect the various endpoints/instances. I suppose it could be an issue with your config file though.

I would start by excluding/reincluding, to see if that fixes the problem.

I tried excluding and including. All it did was give it a different node number and wipe the name I gave it.

Any other tips?

Can you post your lzw36.xml file and your ozwcache.xml file?

There must be something wrong with the config.

I am unfamiliar with how to get this out of Zwave2MQTT. Could you explain, please?

So that was a journey, but I was able to get the lzw36.xml file out. Link to file: https://pastebin.com/BJAVFzvV. What am I looking for?

I mainly wanted to make sure the file was present and loading correctly. Are all the configuration options showing up for this device?

If not, have you tried the steps on the known issues page of the zwave2mqtt integration page?

My setup is through docker (I am not using the integration), so all my config files are in a different place from yours. That makes troubleshooting more difficult since I have to figure things out as we go.

I do seem to have all the configuration options. I was also able to get out my ozwcache.xml file. It seems mine does not have the correct instances on CommandClass 38 that I have seen in other threads.

Here is a link to the Fan/Light Dimmer config (https://pastebin.com/hDCegkGg). If you post yours, I can compare them as well.

And if it is the config, is there a way to reset it for this device to “re-configure” itself through Zwave2mqtt?

Edit: I guess if I can find the differences in our ozwcahce files, I could just add the missing lines to mine right?

Generally, you dont want to manually update the ozwcache.xml file for this version of OZW.

Did you add this device securely? If so, could you try adding it non-secure to see if that affects anything?

Adding it non-secure worked! I have no idea what the difference is between the two, but it worked!!! Thanks so much for your help.

For me it goes from added to dead right away. Secure or non secure doesn’t matter.

Is your Zwave database up to date? There is an auto update option under the Zwave settings.

Yes, I have that option checked. Also I have changed controllers from a Go Control to a Aeotec Gen5 and still having the same issue. I checked assume awake, and unchecked refreshdevice, and finally got it to add successfully, however it is still not controllable with the following in the log.

OpenZWave Info, Node006, WARNING: ZW_SEND_DATA failed. No ACK received - device may be asleep.
OpenZWave Warning, Node006, WARNING: Device is not a sleeping node.

When I change the control using the bright/dim buttons in the UI the lights on the switch light up like I think they should, however I think my controller in the fan is now out of sync. These are my first Z-Wave devices in this house using Home Assistant. Was using Smartthings for years, and I did not have this much problems getting the controls to work.

Now I am getting dead nodes with a expected callback that is correct from what I can tell.
2020-08-08 18:06:30.885 Detail, Node002, ZW_SEND_DATA Request with callback ID 0x23 received (expected 0x23)
2020-08-08 18:06:30.886 Info, Node002, WARNING: ZW_SEND_DATA failed. No ACK received - device may be asleep.