LZW36 fan/light switches light always returns to the full level


I started to have problems with the light of my fan. No matter what I do, the light always returns to a the full level. But not in the application nor on the led indicator.

If I scale it to a certain level, it scales well, but after about 2 seconds, it goes back to 100%.
If I turn it off, it turns off fine, but after about 2 seconds, it turns back on at 100%.

However, the LED indicator shows the correct level or the off state when it is. When it resets to 100%, the led indicator keeps the level previously set. In the SmartThings application, the level remains correct too.

It is now impossible to turn it off, it turns on all the time.

I turned off the braker for 1 minute and turn it back on. The problem goes away and the lignt stays off. But as soon as I turn it back on or scale it at any level, it is then impossible to turn it off, the light goes back to 100% again.

It has been installed since September 2020 and I have never had a problem before.
I have four LZW36 fan/light switches and this is the only one that has this problem. The others work fine.

Do you know what could cause this problem?



Does anyone have any idea how I can fix this problem?

I am not sure what is causing that issue, but have you excluded and factory reset the switch?

1 Like

I’ve not yet excluded and factory reset the switch.
I have a little more than 30 scenes and automations with this switch. Everything will disappear with the reset.
I have just finished recording images of all these programs. I wanted to make sure that there really are no other options before I lose everything.

I will try to reset, but I have doubts since the problem does not come from SmartThings, but from the switch itself which changes its local state at the canope level and not at the switch.
My firmware is the latest available for this switch (1.36 vertion)

Not sure which hub you are using. If you are using SmartThings, create a dummy virtual switch and put that in the Routine along side of the switch you are going to be removing. That way, the Routine will not get removed when the switch disappears. Once it is re-added, you can add it back to the Routine and remove the placeholder virtual.

That’s a great idea, I hadn’t thought of that. Thanks for the tip.
I actually use SmartThings.
Is there any way to keep the button shortcuts?

I just reset it and it seems to work.
Thanks for your advice

1 Like

I did several tests and everything seemed fine. When I went back some time later, the light was back on. I turned it off and waited. It came back on. However, on the led indicator and in the SmartThings app, it does say it is off.

So the problem persists.
The reset did not solve the problem.

How about factory reset and not attaching it to ST. See if the canopy/switch turn on without a zwave influence.

1 Like

I just tried to reset without attaching it to ST. The problem is still there.