LZW36 - How to disable physical load control?

I’m trying to use a LZW36 with smart bulbs.
I set the parameter “Disable Physical On/Off Delay” to “Yes” but it doesn’t do anything.
I tap on the button and it is still turning the lights off.

Am I missing something?

I’m using Hubitat 2.2.6 and the latest LZW36 driver (2021-03-10).
LZW36 firmware: 1.34

Which switch are you referring to? You posted in the LZW31 section but the title of your post says LZW36.

The fan switch doesn’t have a physical load, so I’m thinking LZW31, but not sure. The firmware suggests the fan/light switch though.

Sry for posting in the wrong forum, maybe someone can move it for me.
I’m referring to LZW36.

Whie the switch itself doesn’t have a physical load, the canopy module has so I was hopping I could control that and the driver does have the “relay” option:

image

image

I got you - I think it was my bad anyway as I didn’t have a fan/light tag.

As for the smart bulb mode - what you’ll have to do is find a feature that says something like, “Disable Local Control”. I don’t have the driver info handy right now so I’m going off memory.

So, set your bulb to 100% (or 99) and then set, “Disable Local Control” to On.

That should keep your bulbs on. From there, setup the scene control to get them to turn on/off/dim, etc

No worries. I think I got thrown off by the dimmer tag. This will improve as Inovelli is working on the tags.

I don’t have a LZW36, but I think what you want to turn on is Disable Local Control. I don’t know the parameter number, but the spec sheet indicates that capability.

The parameter to disable the delay only makes the light turn on and off 700 ms more quickly. Disabling local control keeps physical presses of the switch from turning on and off the load.

I don’t know if the LZW36 has a Smart Bulb Mode, so start by cranking the dimmer all the way up. Once you DLC, turn the switch on via your hub.

The closest thing I have is “Create Disable Local Control Child Device”.

image

Man, I read that a milion times in the driver, I wrote it and I even screnshoot it but in my mind I had: “disable RELAY” and not “delay” :smile:

Hubitat, right? I’m a ST guy, though. In ST, you don’t need to create a child device to DLC. Maybe you do in Hubitat?

@harjms ?

I tried it.
It creates a child device with two options: on and off.
I turn it on and it disables the whole thing. I can no longer turn on the lights or the fan.

I got it. It is called “Local Protection Settings” (kind of an unexpected name if you ask me :slight_smile: )

image

I see two issues with this configuration:

  1. It is no longer reporting on/off state which means I cannot do things like mirror state and so on. LED is always on, if I had to guess I would say it is because it is reflecting the “relay” state which is is always on. While this make sense I think when you “disconnect from the relay”, would be cool/usefull to still be able to have this “virtual on/off” state for different applications.

  2. I can still turn power on and off using z-wave. I think this is risky because one can turn it off accidentally or if for whatever reason the switch is exposed to google home or amazon echo, people will eventually cut the power to the smart lights. Maybe an option to disable z-wave on/off (like Zooz have in their switches) would add some value as well.

These are my two cents and please let me know in case all of this is possible and I missed it.

Yep. You are basically disabling the switch, so you can’t mirror what you’ve disabled. Since you are using smart bulbs, don’t you want to mirror them instead?

Yes, but you can disable that too. In ST, it’s called Disable REMOTE Control. No idea what the Hubitat driver calls it.

I might be wrong about this, but in the back of my mind I’m thinking that for Hubitat, there is a Hubitat Inovelli driver which is different than the real Inovelli driver. Maybe you’re using the Hubitat one which is why the name of the setting is different?

A Hubitat user should weigh in on this.

I have a Zooz switch that works light this so I kind of got use to it.
Mirror the bulbs is a less than ideal solution for me since the Hue bridge doesn’t report state to Hubitat in real time (it can taker up to a minute).

But I got your point, what you mentioned does make sense and I may be overthinking this

I don’t see this option but I will keep digging.

Yes, I’m using the one I got from inovellis website.

Is there anything related to Remote Protection Settings?

Nope. Maybe they didn’t implement it in the hubitat driver.

In Hubitat it should be there as - “Create “Disable Remote Control” Child Device” right after the Disable Local Control Child Device -

Edit - also if you want to mess with the LED level to change it from being always on you can use rules to try and keep them in sync either with custom commands or using notification children if it’s a couple specific variations you’re looking for.

Yep you want disable local control and disable remote control “on” or enabled so that nothing changes the power being fed to the bulbs always. The bar will stay at 100% in this case. You can then use scene controls to turn off/on/dim/brighten. If you are using z-wave you can alternatively use associations which don’t use the hub to control them but report state back to the hub.

You would then control the lights, not the switch.

I do want the LED to indicate some state or at least blink when they push the button indicating it was pressed… something like this. Just trying to get some value out of it since it is there and it is beautiful :slight_smile:
I will playing around with rules and see what I can do.

I just went ahead and performed some testing:

  1. First i checked the option “Create ‘Disable Remote Control’”.
  2. It created a child device.
  3. I opened the child device and turned it “On” which disables remote control.

The result: I can no longer turn the fan on and off remotely which means, buttons and voice command will no longer work.

The child device “Disable Remote Control” disables everything.
I think what I need is something like the “Local Protection Settings” but for remote control, where you can choose fan, light or both.

I just got 20 red series (between fan, switches and dimmers) so I need to wrap my brain around the mindset behind them so I can take full advantage of it (I’m moving away from a competitor).

I think that most disable local control but leave remote control (i.e control via the hub) enabled, so that there is a quick an easy way to turn the switch off if need be. I know you’re concerned with inadvertant remote control turn-offs via voice. It might be better to leave remote control enabled and disable the switch device in Alexa or Google home.

Got it, I think I misunderstood your goal with the protection maybe then? I’d agree with @Bry that the solution sounds like you should leave the light switch itself out of Alexa/Google Home, and if you need to control the Fan separately you can stick to voice/zwave for that. Then you use the bulbs in the light via zwave and can do scene control using the light button or use voice commands through Alexa/Google Home.

Personally, I use the LED bars to indicate mode (in Hubitat) based on color, and on some, a “notification” effect on the LED to indicate other states (e.g., motion at the front door). These are two different things for me: the “regular” LED vs. the notification effect (so when the notification is done, it reverts to the regular LED — which for me is still special). This is mostly for the switches and dimmers. Pretty much all of my bulbs are smart bulbs, and I have little use for the dimmer bar indicating how bright/dim my lights are (I can already see that…), so I don’t really mind this setup.

For the LZW36 (fan/light) switch, however, I basically just do that for the top LED bar (next to the light button). I leave the fan one pretty much alone, letting it show me the fan speed or on/off state (it’s a bit harder to eyeball speed, so I do find that helpful). You may find other, more creative uses for one or both of these.

Anyway, back to your smart bulbs: Inovelli’s (current) “smart bulb mode” works differently from Zooz. On the Zooz, you can “mirror” the internal switch or level/dimmer state to bulbs. The Inovelli does not currently track this when physical control is disabled, so what you can do instead is respond to the scene/button events. For example, you could create a new Rule, use the “Button Device” (not “Button”) trigger capability, and set up actions like:

Button 1 pushed: turn on light
Button 7 pushed: adjust lights by (+)15%%
Button 7 held: adjust lights by -15%

(If you’re using Inovelli’s driver, “button 7” is the rocker/dimmer next to the light button, and “pushed” means up, while “held” means down. Confusing, but Hubitat’s button model doesn’t do well with extreme numbers of multi-taps, so it’s a workaround.)

You can do even more fun things, like dim while holding a button until released, but only the fan and light buttons support that, so it’s not quite as intuitive on here as it is with the dimmers/switches, I don’t think (those would be the “Start raising/lowering dimmer level” and the “Stop changing dimmer level” actions in RM, if you’re interested.; your bulbs also have to support the corresponding device commands, startLevelChange() and stopLevelChange()).

Just some ideas that might get you started. :smiley: In any case, as you may have figured out by now, with the Inovelli, the idea is that you control the bulbs and not the switch/dimmer directly; it’s just a hardwired button/remote device in this mode. (Z-Wave Association opens up more options here, but I can’t use that since my bulbs are Hue, and you normally don’t get quite as much power that way — but I can’t speak to the LZW36 in that configuration since I’ve never used it that way. But the advantage is that it would still work if your hub is down.)