Lzw42 not retaining the color

hi, I´m having a very strange issue that began (or I discovered) the other day when google misintepreted my command to turn on a switch and changed all the lights to orange.

all my bulbs turned orange but the most annoying thing is that I can´t change them back to ANY color. they would go back to orange. more annoying is the fact that in this group I have one of my zigbee bulbs that wasn´t affected.

I also discovered that the ilumins would retain the color as long as I changed it through the google home app, which is frustrating given the fact that the color choices there are very limited AND… I don´t want to use g-home app to change my bulbs. that led me to believe that reconnecting smartthings with google would solve the problem, which didn´t. I even unlinked smartthing from google so it won´t have any influence over the bulbs and the problem persists…

I really (like… REALLY) don´t want to go through the process of excluding them, resetting them, pairing again and then setting all the automations again. obviously I´d do it if I had to, but wanted to ask first, just in case I´ve missed something.


Weird issue for sure. Note that color and white temperature are different settings, so make sure that you aren’t changing to a white then back to a color.

Honestly though that is weird. You should be able to change colors via hub to whatever you want!

What hub?

I recently purchased 4 of the illumin bulbs. I successfully paired 3 of them so far. My issue is similar. Delayed color change response and it reverts to red color frequently. I’ve also experienced the color changing on it’s own. This is consistent with the 3 bulbs I have paired. Unsure if this has anything to do with the range/distance from the hub. I do have zwave rocker switches within the same room so I can’t imagine this would be a range issue.

I really like the concept of these bulbs as I discovered them being reviewed by Reed-Smart Home Solver. I hope this is an easy quick fix.

The 4th bulb I can’t get to reset / exclude. I’ve tried the method of On/Off power to bulb 6x within the 2 seconds but I get no response from the bulb. I will attempt it again today same method and also will try exclusion process from the hub as well.

Any in-sights and recommendations is much appreciated ahead of time.

Irvine, CA

1 Like

Please let us know hub you’re using.

oops sorry about that
Smarthings Hub Version 2 (non-wifi)
Smartthings App version / Android phone

Do you have any smart apps that control color in any way?

Are you using the Inovelli device handler or edge beta driver?

I’m using the Inovelli device handler. No I am not using any smart apps to control the color.
I have no problem with White colors. When it comes do switching colors…it has a tough time. It will go to a blue when selected but then it will go to red. I can go to green or any other color but then it it will switch to Red on it’s own…and it also reflects that color change in the app too.

1 Like

exact same issue. the only difference is I’ve been using these bulbs for like 2+ years flawlessly and just the other day they all began that crazy color behavior. mine too go to red shortly after I change the color. regardless of the color I chose through the smartthings app.

BUT if I try to change the color through the google home app, they’ll stay in the chosen color. smartthings hub v3 is my hub.

1 Like

i just added more information on my above post and I thankyou for replying

that’s very interesting…I just got these bulbs brand new…this week. I stayed up late lastnight pairing the 3 out of the 4 bulb successfully. I’m awaiting for Inovelli support to respond back.

the color changing has a mind of it’s own. Then when you try to force a color change…it will try to change to that color for a quick second…then it goes to Red color…
it does the same on the smartthings app…reflecting the color change

1 Like

try doing the color change through Google (or Alexa if that’s your assistant).

1 Like

i will give Alexa a try…when I get home later tonight…
Hopefully Inovelli support with have some answers

1 Like

This is sounding like a ST issue, but perhaps with recent update the driver needs updating? @EricM_Inovelli

Go into the ST IDE and look at the lines for 3 bulbs you added. What is listed in the “Type” column for each?

Then, open each bulbs page and post the raw description lines up to and including the ver.

In the ST app, open the page for one of the bulbs. Click on the 3-dot menu top right. Is one of the menu picks “Driver”.?

in my case, I haven’t been able to use the edge drivers. even by deleting the custom DH. installed the DH again.

they just began working erratically with the colors out of nowhere.

Type Inovelli Bulb Multi-Color LZW42
Raw Description zw:Ls type:1101 mfr:031E prod:0005 model:0001 ver:2.31 zwv:4.38 lib:03 cc:5E,98 sec:86,85,59,72,73,33,26,70,27,5A,7A
3 dot menu is Edit , Settings, Information

the above is just for 1 bulb…I have to step away for a few…i couldn’t lookup for the other 2 bulbs just yet. Hope this info helps

Was that out of nowhere AFTER you tried loading the Edge drivers and then had to revert?

I’m not going to be of much help, unfortunately. You are on the current firmware and it doesn’t appear you’ve integrated Edge. Just doing @EricM_Inovelli 's groundwork, lol.

1 Like

sorry guys…what are Edge drivers? I just loaded the Github code per instructions and paired the bulbs…and went from there. I’m somewhat of a novice…apologies…

Correct right from the beginning…the shades of white are no problem. It’s when I started to venture in the different colors…it would start acting on it’s own behavior. For some reason it likes to revert to Red. I would try Blue, Green…but then it would revert itself to Red…
same thing when I would power Off and power On…