LZW42 zwave A19 bulb

Hi guys,

Anyone try their zwave bulbs from the black friday sale? Installed them and they’re looking great. I’ve got all the functions working in openHAB, and the bulbs look great. However, they don’t seem to dim gradually.

For instance, when I change the brightness in software from 100% to 50%, they jump down to the expected brightness rather than slowly dim down to it. Is this the expected behavior?

They also dim the same way when dimmed through hardware (via LZW31)

ive been using them since i received them late last week. they behave the same for me. I don’t see any parameters that can be adjusted on the device tab in Hubitat. I believe the good folks at inovelli said they would be pushing firmware updates fairly regularly, so i’m sure that would be something they would address.

These bulbs were a surprise release, so i’m sure they will only get better as time goes on.

I also noticed that the configuration options for theses bulbs are limited in ST. I believe the bulbs that shipped w the BF kit are white label (rebranded) so they are just running a stock manufacturer firmware. According to the Product Roadmap, the more advanced firmware features are being reserved for Phase 2 which will be a new device based on the 700 series chipset.

That being said, I’m also hoping that additional features can be exposed by an updated device handler or firmware. If these natively supported a default state vs the current behavior of returning to the previous state at power on, that would make them far more useful in my setup.

The product page (https://inovelli.com/shop/z-wave-smart-bulbs/z-wave-rgbw-smart-bulb/) does hint at some of the functionality, such as remembering the last state. I do wonder if the driver might have been rushed out before any options could be added.

That being said the driver link is broken on that page so…

Here’s the link to the driver that was posted on another thread. I don’t think the product page was ever updated with the link. the link in the product page is for the dimmer


I installed these bulbs in Hubitat using the driver from above. Can’t change the color or temp of the bulbs. I get the following error logs:

I have posted to HE forum as well for guidance there as well

Tried doing an exclude to rejoin my Hubitat Z-Wave network and now one of the 2 bulbs I received just flashes. Tried then doing a factory reset on the bulb and still will only flash. Any suggestions?

how many devices do you have on your hub? could it be that it is not within range? i got some funky errors when i tried to join my front door lock at first. Turns out it was just out of range and i needed a repeater.

as for resetting the bulbs, i had to do it 3 separate times on one of them to get it to reset.

It’s not a hub issue. There are 2 lights in the same fixture. Other bulb joined just fine along with inovelli switch at the wall. Tried reset multiple times but no way to tell if it was successful because it just flashes non stop

Did you join them one at a time? I read somewhere that zwave cannot join multiple devices at once…or something along those lines.

Maybe remove one bulb, reset, join to the hub. Remove that one, then do the same with the 2nd bulb.

I ran into this issue with Hubitat. You can only join 1 light at a time.

Hope I Can get help with this. My LZW42 Connected to Hubitat fine with the correct device handler. It works great through Hubitat. However, in Alexa most functions work except being able to change color. When looking in the settings for this device in Alexa is states it’s “Connected Via - Hue Hub”. Under Capabilities it states “Color”. I have Excluded, Reset and re-Included and it still says and does the same. Any one have any ideas? Just got today. Maybe it needs a firmware update? I don’t know.

I just checked mine…connected through habitat and it works just fine with Alexa. I checked the settings and mine states that it is connected via habitat.

Do you have a Hue hubin use by any other lights?
Does your Alexa device work with all your other lights/switches/etc?
did you install the Alexa app in hubitat and enable that particular bulb within that app?

What i’m thinking is that perhaps you didn’t include that bulb in the alexa app within the habitat system. Alexa then may be trying to pick it up through a secondary route (hue) and that’s why it’s not working as itended.

Thanks for the response. I don’t have a Hue hub or any other Hue devices. I did purchase the Inovelli White Z-wave bulb. I didn’t check to see if I had the same issue with that. All the commands on both bulbs work through Alexa except color changing on the Color LZE42. The Alexa app is installed in Hubitat as well as the devices are added to the Alexa app in Hubitat (Otherwise they wouldn’t work at all). Let I said before I tried excluding and re-including them In Hubitat’ as well as a factory reset. All my other devices work in Hubitat and Alexa.
Any ideas and help is appreciated .

Do you have the Hue app installed in habitat?

You might want to check out and post the question on the habitat boards. Sorry I couldn’t be more help. I’m learning a lot about this stuff as I go…only got about 3 months of this stuff under my belt.

Best of luck figuring this out…I know i can’t rest until i get things sorted out…hopefully you’re not as obsessive :slight_smile:

I’ve also reached out to Inovelli support. They have yet to respond. I believe they are unavailable at the moment. They maybe at a FEW show or something. It is that time of year.

The alexa app is hue bridge emulation… The alexa skill app is through the HE skill and is more versatile… And you shouldn’t have both installed…


I don’t have hue installed anywhere. I checked Alexa and that skill isn’t enable. Nor is the app enabled in Hubitat.

ok…first chance i get to actually be at my computer where all this stuff is done at my home. I just checked my Hubitat setting and noticed something that i overlooked before. At the bottom of the Alexa “app” within Hubitat there is a toggle that says Exclude Hubitat integrated Hue Devices. Mine is set to on. Perhaps yours is not set that way.

Bought these also during Black Friday sale. They were part of the Dimmer switch X4 sale. installed one yesterday and it works fine with some delay in ST updating status. The second bulb connected to ST but wont turn on. Even tried it on a regular lamp to see if it was functioning. I get nothing. once in a rare while it flashes once. Thoughts or suggestions. I am really struggling with Inovelli on yet another issue of Red Series Gen 2 switches. 2 of the 4 do not work and Inovelli is barely responding or helping over past 3 weeks. Last try before I give up on them and refund/