Mea culpa: Messed up firmware update - LZW30 (black series)?

Hey - I was trying to update the firmware on my switch using @bcopeland’s Z-Wave Firmware updater tool and I gave the wrong link to the file (LZW30-SN instead of LZW30). The tool gave me a message saying that it failed to find a match :+1:t3:. However, now I cannot update the firmware - message says “Please wake up your sleepy device”. I switched the drivers back to the Inovelli ones and the switch will not respond (also will not respond from the physical switch).

What options do I have… I know, I know it’s my fault :pray:t3::pray:t3:

There’s a post on the forums about how to wake the device. I believe you’re suppose to start the OTA update and then air-gap the switch; or something like that. Let me look for the thread.

1 Like

@rakeshg - Check out these steps:


Try the steps that GavinCambell found

  1. Change the driver to the firmware updater driver.
  2. Ensure the switch is responding by clicking on Get Version Report.
  3. Put in the URL this is in post 3 of this thread ( ) and click on Update Firmware let it get to the parsing step
  4. Airgap the switch.
  5. When it says to wake up the sleepy device, push in the airgap switch (quickly). If it takes a few seconds to push in the airgap it likely won’t move on and you’ll have to start over.
    (Slietly condensed version that worked for all of mine)

Thanks! I went through the steps and I can’t get past the “sleepy device” step. The air gap pull brought my switch back to life (could control it from the physical switch as well as the device page from Hubitat). On the LZW30 (not SN), the air gap is a “pull” (not push) and I’ve done that a couple of times.

For now my switch has re-joined the land of the living :crossed_fingers:t3:, so I may just let it be for now.

I’m having the same issue and I had the correct file all along (although its now v1.19

Its always “please wake up your sleepy device” no matter how many times or how quickly I use the airgap. One thing not mentioned is I never get past Step 2 “Ensure the switch is responding by clicking on Get Version Report”. It does not respond to the Get Version Report. However, if I switch back to the regular LZW30 driver it all seems to function properly and it also functions at the physical switch. Its only when I try to update the firmware that it seems to be in permanent sleepy mode

Any other ideas/tricks?

Unfortunately, it seems to be a bit hit or miss. Some people have had luck with the airgap process but I did not, and have left the switch be on the older firmware. This does not seem to be an issue with the red series dimmers as I have updated 2 without any major issues.

I think its something related to @bcopeland 's Z-Wave Firmware updater tool and something different about this model LZW30 (black series on/off switch). I’ve had no problems with LZW31-SN (red series dimmer) and his updater tool

After failing this with many different “wake up” attempts, I then tried using the Silicon Labs Z-Wave PC Controller method and it worked perfectly the first try. I now have v1.19 loaded in my LZW30

1 Like