Missing Associations in HomeSeer from a backup installation

My Windows 10 HomeSeer computer suffered a failure and I’m trying to get my environment working on a different computer. I installed the HS4 software and then copied the backup I had of my HS4 directory on to the new machine. All my devices and events came back, but my plugins were missing. After some playing around I’ve managed to get all of my X-10 devices and some of my z-wave devices operational. However, none of my Inovelli switches are responding. The device exists in HomeSeer, HomeSeer says that it is sending a comand to the device, HomeSeer is able to ‘audit’ the node, but the switches do not respond. When I look at the configuration for the switches, I see that there are ‘no associations’ for the switches. I believe there should at least be one association with the HomeSeer environment?

Anyway I’m wondering if anyone has any tips on what I might do to get my Inovelli switches working again without removing/reinstalling all of the nodes. I’m not a z-wave expert and what I don’t want to do is end up messing with the information on my Z-wave controller.

Any information anyone can provide would be greatly appreciated.


I’m running HS4 so maybe I can help.

You said you can audit the node, does the audit return responses such as:

HomeSeer was able to send a frame to the node.
HomeSeer was able to query the node and receive information back from it.
The node’s neighbor rating is: Acceptable with 9 neighbors.
Neighboring nodes to Light:…

For one of the switches, I see this:

HomeSeer was able to send a frame to the node.
HomeSeer was able to query the node and receive information back from it.
The node’s neighbor rating is: Excellent with 22 neighbors.
Neighboring nodes to Z-Wave Master Bedroom Bedroom Hall Light Switch:
Z-Wave Soffits Main Hall Soffit (Node 4)
Z-Wave Soffits Front Hall Soffit (Node 5)
… some more nodes …


This node supports associations on the following groups:
Node is missing Association Groups information.

If I click the ‘Associations’ section, I see this:

There is no association information for this device. Before associations can be changed, the list of associations that it supports must be updated at a minimum. Click the button to the left to attempt to get this information from the node. If the node is a battery operated node or one that is not always listening, please make sure to wake up the node prior to clicking the button.

I’ve tried using the ‘Rescan’ button, but nothing changes. I haven’t checked every Inovelli switch but the ones I did check all look similar. None of them have Associations and I don’t seem to be able to add one.

Rescan isn’t going to help, what happens if you hit the Update button in the Associations section (like the instructions indicated)?

Sorry, I didn’t mean ‘rescan’, I used the ‘retrieve’ button in the Associations section, but I got the following message:

Failed to get Association Group Count information for device


My suggestion is that this discussion really belongs in the Homeseer community forum at the Homeseer site, this is not necessarily an Inovelli problem. Something doesn’t quite make sense if you are able to audit the node and yet not retrieve the associations from the same node.

Thanks. I’ve posted something similar on the Homeseer forum as well. Since the only z-wave devices that aren’t currently working are my Inovelli switches, I figured I would ask here as well.

Hmmm… the only suggestion that comes to mind is use the replace node procedure, that way you won’t have to recreate any events or triggers that utilized those devices.

At a high level, do a factory reset of the Inovelli device at the device.
In Homeseer goto the device Zwave tab for that node. Attempt to do a Rescan.
The scan should fail, this will allow you to initiate a Replace Node procedure.
Hit the Replace Node button in HS. Once it starts the process, goto the Inovelli device and initiate the inclusion process.
If successful then the Inovelli device should reappear and associated with HS.

Thanks for the suggestion. I followed your steps with one of the switches and unfortunately the Replace Node operation didn’t work. I got to the step of doing the include operation on the switch, I clicked the button 3x, got the flashing blue led, and then nothing. Eventually I got a red led and Homeseer was unable to complete the operation. Since this particular switch was fairly new to my system, it wasn’t included in many events, so I did a ‘Remove Bad Node’ which removed it from Homeseer, and then I was able to include it using normal operations. I might just have to bite the bullet and remove/re-include my Inovelli switches. Thanks again for your help!

Glad you got it working, but I have no idea why only the Inovelli devices didn’t come back gracefully.

I only have one of their dimmers and don’t intend on buying anymore until they work out some issues with their firmware. Debatable if the company will be around for the long haul.

I just tried a second switch using your instructions and that one worked! I’m going to try others. Hopefully most of them will come back to life without removing and re-adding them completely.

1 Like

I’m hopeful that the company will be around, I really like the design of their switches. Hopefully they can get firmware issues ironed out.