Need help with LZW30-SN LED color strip

Greetings everyone. I posted this message a few days ago in the Hubitat community, and sent a support ticket to Inovelli, but am now reaching out here for help. I installed an LZW30-SN / Red Series switch in my garage. Using Hubitat, I updated the firmware to 1.19. In the parent app, I changed the color of the LED strip from blue to white. I then scrolled further down, and created a child app in the LED notifications center. LED Effect Color - Notification 1: Red; LED Effect Level - Notification 1: 100%; LED Effect Duration - Notification 1: Indefinitely; LED Effect Type - Notification 1: Fast Blink. When I press On in the child app, the LED strip does not change color.

I created a rule. If the garage freezer is open, turn on Notification 1. The LED strip does not change color.

Can someone please look over my set up and tell me what I am doing wrong? Do I need the LED Color child device? If so, what for?

I tried the instructions at
But this looks like it was created before firmware 1.19, and makes no mention of using the Notification 1 (or 2, etc.) child apps.
This didn’t work either.
I’m hoping I just missed something in the set up.

@Eric_Inovelli @EricM_Inovelli

I don’t think I’ve ever tried to press the “on” button in the child app. Not sure if it’s meant to respond.

Let me look at your rule real quick.

I think I figured it out. I noticed your deviceType under the Light Switch is deviceType: 4. This corresponds to a Black Series Switch. You need a Red Series Switch in order for it to act like Notifications. You have the wrong driver selected for this product.

You can set custom led parameters with rule machine, but not like notifications rules.

I installed this device driver through Hubitat’s Package Manager.

I uninstalled the Inovelli Driver from Hubitat Package Manager, and copied and pasted the driver from Inovelli’s website and am using that now. It still shows up as deviceType 4.

This is from the Driver code I am using:

It was the same using Hubitat’s Package Manager driver. I am thinking deviceType is something else?

The deviceType is hard coded in the device I believe. The LZW30 device code can be found at:

Unless things have changed recently and according to the link above, the type 4 is a black series or LZW30 device.

Also the name of the device should be identified as a Inovelli Z wave Smart Scene Switch S2. Here’s a Red and Black example on my Hubitat.

Thanks. How do I get it to be recognized as the smart scene switch, deviceType 2? It’s definitely a Red Series switch.

Try excluding it and then including it back into your Hubitat.

Excluding and re-including brings it back as deviceType 4 still. What security level should I use? I usually uncheck all the boxes.

You’re fine to just uncheck the boxes for the security level if that’s what you want. That “Inovelli Z-Wave Smart Switch S2” along with the device type being 4 match up with a black series and not the red series which is very odd though (Red series shows up as Smart Scene Switch).

@Eric_Inovelli @EricM_Inovelli did something change with these?

Did you flash firmware by chance or was it new in box?

Using Hubitat’s firmware tool I updated it to 1.19 as soon as I installed it.

Could you have used the wrong firmware?


@harjms That is also what I was thinking. Make sure you used the correct firmware file.

1 Like

I updated the firmware using the above link, with Hubitat’s Device Firmware Updater. It successfully installed, but the switch still shows deviceType 4. Do I need to reset/reboot anything on the switch or Hubitat to change to the updated firmware?

Disregard. Exclude and Include got it working!

Thank you @harjms !!! Apparently I had installed the wrong firmware. You guys were correct about the deviceType 4 being the issue. I installed the correct firmware, am using the latest driver, and now I can change the LED strip!

Thank you all again. Cris.