New to Zed-Wave, which stick?

Do you only plan on buying the currently available Red switches and nothing else ever?

That said, I’ve got the HUSBZB-1 and it’s been working just fine.

Ha - that is a very good point and tbh, if there was stock I likely would have just gotten it without even asking. But, dimmers & switches are coming and it would be tragic to just wait for a stick…

Something to keep in mind is that upgrading your controller may not be trivial. A fair amount of information about your zwave network lives on the stick, and getting that information off of the stick to move to another isn’t guaranteed to be possible. Knowing that now, I might have waited for a 700-series stick and used a standalone zigbee stick for the few zigbee devices I have (that came with the house). As it stands, I think I’m looking at completely rebuilding my zwave network when I finally get a 700-series stick. I’m not looking forward to that.

1 Like

@krisk is right on this, I only had 9 devices so not to hard to rebuild.

Also keep in mind you will have to exclude and include devices onces you hub supports S2, if it doesn’t already, if you want to use S2 that is.

I upgraded to this one from a stick to add zigbee (and finally get off ST permanently) and it is perceptibly faster to me. I also rebuilt my entire network, so that might be part of it as well.

1 Like

I spent a good amount of time playing around with various different Zwave sticks as well as Zigbee sticks. I had bad luck with the Cronbee II for Zigbee, I moved away from that one after only a couple days. I also tried a couple no name Zigbee sticks and quickly concluded you get what you pay for.

For Zwave I had a horrible time with both the ZST10 500 and ZST10 700 from Zooz. They made my whole network sluggish and nothing I did fixed that.

The only thing that continues to work almost perfectly for me is the GoControl HUSBZB-1. It’s super speedy and always just works no matter where I place it. I recommend this one to everyone I know as a starting point if nothing else.

It’s not perfect of course, but no product is in the end.

and now for the exciting conclusion - ordered the stick because it was cheapest, then changed my mind, cancelled that order, and ordered the USBZB-1 instead.


The older Aeotecs have a battery and button but again not sure if that actually adds any value.

The value of the battery is that if you need to pair a device and you’re having trouble because of range issues - you could pull the stick out of your server and bring it to the device and re-initiate pairing.

So whether that is important for you is situational - if your furthest device will still have a decent signal going back to your server then the battery is an unneeded feature.

IMO – the best (and cheapest) option is the UZB-7 (SLUSB001A). It’s from Silicon Labs, it’s 700 series, firmware updates are readily available and it’s only $20.

The HUSBZB-1 is/was a good device, but it’s going on something like 5+ years old at this point. There are better options available for both Zigbee and Z-Wave at this point.

In general, doing this is a bad idea. Controllers are meant to be static and not moved around. Doing so is likely to lead to issues that may not be fixable with a network heal.

I can’t really speak to that - all I know is Aoetec specifically endorses this in their documentation. In fact, their steps for pairing a new device seemingly require it;

  1. Unplug the Z-Stick Gen5 from any USB connection, this will enable Network management mode.

  2. Tap the button once on Z-Stick Gen5+. Its LED will blink blue slowly to indicate it is in pair mode.

  3. Follow the instruction of the Z-Wave device that you want to pair. Typically the button press on the Z-Wave device is a single tap, but some have special button presses (ie. hold for 2 seconds and release, triple tap, double tap, etc).

Z-Stick Gen5+ LED will confirm if it paired something successfully by showing a solid blue LED for 2 seconds before returning to a slow blinking blue LED.

  1. Repeat step 3 for any device you want to pair if you have multiple devices that you need to include.

  2. When done, tap the button once on Z-Stick Gen5+ to bring it out of pair/include mode. The LED will de-activate.

1 Like

@kelchm Now I want to update my Aeotec stick to a 700 series before doing any more device pairing and setup in the new house.

Just a word of caution. I spent a good chunk of last weekend troubleshooting a zooz 700 USB stick and found it does not play nicely with raspberry pi 4. Basically the driver gets hung on boot and HA can’t use the device unless you manually unplug it and plug it back in, same issue if you update HA. No issues on raspberry pi 3b+. I suspect the issue is with the pi 4 only because they have had issues with other USB devices but just my best guess.

I have this issue on my desktop. The below solution works for me. I set it to run at boot.


Thanks Stu! I looked for a solution like this on the pi 4 but sadly you can’t individually control USB ports on the pi 4, you can only toggle all of them which won’t work for my current setup because it’s USB boot. I do plan to switch to an Intel nuc so this might come in handy soon!!

1 Like

Try a usb hub, if i remember correct the non plus AeoTec stick had a issue with the pi 4. People report a usb hub fixed the issue.

I gave that a shot with the non-external powered Aukey USB hub I had on hand without any luck. For now I’m going attempt connecting the stick to a pi 3b+ and use the zwavejs ingeration on my pi 4 to communicate via websocket. I setup a small POC and was really happy with how well it worked. I have 2 more zwave sticks in route and intend to setup one per floor at my home. I want to try eliminating “hops” and have all my zwave devices direct connected to a stick.

1 Like

RPI4 GPIO to relay to USB breakout board. manually disconnect the USB device with the relay.


Ok that was the conclusion of book one.

Now for the more exciting conclusion of book two: ran into issues with Inclusion documented here .

Bought an Aeotec 5 stick, solved my Inclusion issue (I suspect it was the range but can’t say for sure).

Try a firmware update on the stick and a hard reset. I’ve not experienced this with my HUZBZBZBZBBZB.