LZW31-SN won't Include

I installed 8 LZW31-SN dimmers this weekend. One of them won’t Include.

I have a HUSBZB stick, with zwavejs2mqtt and Home Assistant. The other 7 dimmers included with no issues (well there’s an S2-authenticated issue but will talk about that in a separate post).

The one that won’t Include is in a 3-gang plastic box, beside two other LZW31-SN’s from the same batch that work just fine.

I have:

  • Excluded (no response)
  • Factory reset by holding config for 20 seconds (switch appeared to reset per the LED indicators, but still can’t Include)
  • Rebooted HA/zwavejs2mqtt
  • Airgapped

After each of the above I tried including again (and can see the LED pulsing), but it’s just not happening. I watched the zwave logs during the process and I can see the stick going into inclusion mode, but no traffic after that.

The dimmer has a neutral, and is connected to a load with a single LED bulb, and controlling that load with the switch works fine.

It’s like the ZWave radio just isn’t “on”.

Is there something else I should try before asking for an exchange?

1 Like

I don’t know HA, but when you say you excluded, was that device specific or a general exclusion? I would try that latter if you didn’t do that.

1 Like

Sorry I’m kinda new, and don’t know what a “device specific exclusion” is. I would assume though that it would be something where I’d need to specify a device (crazy guess), and that’s not what I did.

There’s an option in the zwave-js control panel to “Manage Nodes”, and within that I can select Include, Exclude, or Replace. I’m choosing Exclude. I have to assume that it’s a general exclusion…

Go to the node itself, under advanced, there should be an “exclude node” option.

1 Like

Also, I recommend airgapping the 2 side switches to get a more direct communication from the hub. You can heal later to get them talking to each other, you need it to get on the network first.

If the device has never included then you can’t device specific exclude it. You can’t exclude it at all using any method.

Did you try the range test? Hold down the config button for 5 seconds. I think the LED goes green then will flash red, yellow or green depending on the range. Or it just simply goes red, yellow or green depending on the range. The manual describes it.

Ok so I’ve made a bit of progress here. I’ve confirmed that, at least, the device’s radio is functional. I came across the range test procedure that @PJF mentioned above earlier today, and discovered that, even through the dimmers beside it tested “good”, this one tested “bad”.

While I was standing beside it, I realized that where I have my stick is a direct line through the other two dimmers (and then some walls/etc). I had assumed that with the mesh I have going that can reach other switches further away than that one, that it would be able to include. But it seems like “network wide inclusion” is not universal, so either my USB device (HUSBZB-1), or zwavejs require a direct link to include?

In any case that was the theory I ran with, and I jumped through the hoops needed to install the PC Controller on my laptop, moved the stick to it, and moved the laptop and stick to about 5 feet away from the dimmer. I was able to include it using the “NWI” (network wide inclusion) option in PC controller.

Moved the stick back to my server (had to reboot the VM because apparently you can’t just plug it in and have it pass through while running), and now I can see the device! Which I guess makes sense if zwavejs or the HUSBZB-1 stick requires direct communication for inclusion, but not for regular communication.

It responds to pings. BUT it shows up as Unknown Manufacturer/Unknown Product. Reinterviewing does not seem to populate those fields. I’m not sure how to get zwavejs to pull that data from the device when it’s not doing the initial inclusion.

In case I’m banging my head against a wall (which has been known to happen), I’ve gone ahead and ordered an Aeotec stick in case its range is better.

1 Like

If you’re not getting the info then it has an issue or simply didn’t include correctly. A re-interview should pull the config data and information. Try one more reboot of zwaveJS first before doing anything else.

I have devices across the house and on a floor higher than my stick and they include fine. It seems to work hopping through other devices just fine.

Rebooting zwaveJS (the whole VM) and then reinterviewing resulted in no changes. I can follow along in the log and see the interview process completing, and it does say that it worked.

It looks like it’s bringing in some of the capabilities (multi-level switch/etc), but it does NOT populate the manufacturer ID and so on.

When the new stick arrives tomorrow, I’ll try it with that one, failing that I’ll pull the switch and connect it in my lab and try it from there.

1 Like

Try factory defaulting the switch (hold config down for 20+ seconds). Then try to reinclude.

Thanks, already tried it in the original post, didn’t change anything…

I had issues including some devices until I added a USB extension cable and moved the USB stick away from my computer. What hardware are you using? RPI? Linux server? Other?

It’s a homebuilt server (Unraid), with an active USB extension cable that goes through the wall of my server closet. The stick is currently macguyver’d to a wall, about 7 feet off the floor.

Nice! Mine is a 10ft unpowered USB cable hung on a nail in the basement ceiling. Maybe try wiring up the switch closer to the server temporarily?

Yep that’s what I intend to do - first I’ll try with the Aeotec stick which Amazon indicates I’ll receive today - if that doesn’t work, I’ll pull the switch out and bring it back to my lab, plug it in on my bench and see if I can get it working that way. If that works, I can assume that somehow Inclusion on my setup is only direct to hub, not network-wide (learning a lot very fast here so not sure exactly which component would cause that), regardless, I’ll just make that part of my provisioning process - wire it up in my lab and include, then install it in it’s final destination.

Did you try my idea of pulling airgaps on the side switches? That could be interfering!

1 Like

Oh shoot no I didn’t try that! Will definitely give that a go first, seems like the least invasive option :slight_smile:

1 Like

Ok tried that, airgapped those suckers - the two that are working, beside the one that is not. No joy, can’t exclude or include.

Next up, trying with replacement stick.

It was the stick! Swapped in the Aeotec stick that Amazon just delivered. Dimmer Included on the first try…

So now I get to exclude/include the other 18 devices I’ve done so far. That’s ok. Keeps my weekend project time full :slight_smile:


I was just dealing with this exact problem. Same issues as you… Other dimmers added fine but one did not. Range test green. Like you, the node popped up during inclusion but it was stuck interviewing and it said unknown manufacturer. I already have an aeotec USB stick as well and it still happened.

Anyways, eventually it worked after trying a few more times. I didn’t even do anything special. Maybe it just needed more time to interview? I’m not sure but it seemed stuck. The others interviewed much faster.

What does removing the air gap mean?