Newly installed switches, scenes not working

A year or so ago I bought a 10 pack of inovelli red dimmers and a few red switches. I’ve installed a bunch of them throughout the house with no problems. Yesterday I installed 2 more (one dimmer, one switch) and cannot get the scenes to be recognized in home assistant. I’m seeing this log when pressing the config button:

2021-07-16 10:05:25.978 Detail, Node020, Received: 0x01, 0x0b, 0x00, 0x04, 0x00, 0x14, 0x05, 0x5b, 0x03, 0x2a, 0x80, 0x03, 0x10
2021-07-16 10:05:25.978 Detail,
2021-07-16 10:05:25.978 Info, Node020, Received Central Scene set from node 20: scene id=3 in 7680 seconds. Sending event notification.
2021-07-16 10:05:25.978 Warning, Node020, No ValueID created for Scene 3

I assume the no ValueID created for Scene 3 is the issue.

When looking around, I’m seeing a lot of advice related to changing config files, but I don’t really want to do that since other “identical” switches are working just fine and I don’t want to break their functionality.

Any ideas?

What Zwave integration are you using for HA?

“Z-Wave (deprecated)”

I looked into upgrading to the newer JS version a week or so ago but the docs made it sound like if I didn’t have a problem I didn’t need to… Maybe this is the problem that makes me need to? haha

Zwave JS is definitely “THE” path forward. I would recommend upgrading. Z-wave you will need to make config file changes and other hassles (and it’s not actively being supported very much anymore).

1 Like

This seems to have worked. I followed this guide to migrate:

And now I’m seeing “zwave_js_value_notification” events being fired when activating scenes on all of my switches (instead of zwave.scene_activated).

It will take a little time getting everything running again as it looks like now instead of using the 4 digit “scene data” number that I had been using (IE: double click a button = 7860) . I now use a more readable “value: KeyPressed2x”.

So far everything with zwave js seems to make more logical sense, so thats good, but it’ll take a little bit of time to just get everything moved over and working again.

Thanks! Definitely feels like the right move to have upgraded.

2 Likes

Note also the bulk set parameters works well for the LED notifications!

O_O I was literally JUST starting to tackle bulk notifications last week and started to write some functions to do that for me instead of copy/paste 20 times. What great timing!

Thanks!

I’m still seeing that HA is saying that zwave (deprecated) is installed and configured through configuration.yaml (although it isn’t running).

I think this is because I have

zwave:
  config_path: ozw/config

Is this, and that whole folder with all the manufacturer specific info no longer needed?

Just comment it out for now. No need to really destroy it until you are up and running cleanly on ZJS.

Thanks! Adding this here for any future readers. Started playing with setting notifications on multiple switches in one go and found this for node red: node-red-contrib-ha-inovelli-manager (node) - Node-RED

So far seems fantastic.

Upgrading to ZJS has unleashed an avalanche of improvements to my setup :smiley:

1 Like

Nice find. I’m doing this manually