Not able to add NZW97 to Smartthings app

I got a second-hand NZW97, I plug it in and the button lights up so I assume that it is working. When I scan for a new device in Smartthings it never finds the device. I have also went ahead and installed the device handlers in the IDE so I can attend that later. What could be causing the issue that the app is not seeing the device? I tried hitting the button “5 times in 1 sec” to try to force a re-pair, but nothing.

Do a General Zwave exclude in SmartThings. Since it’s second hand, you probably need to clear the prior pairing.

Hi, sorry, the NZW97 is second-hand not the Smartthings. I cannot see or add the NZW97 at all to Smartthings and when I go into exclusion mode nothing happens.

I’ll expand on @Bry response. Open the ST app and select the hub. Go to menu and select zwave utilities. Select zwave exclusion. Then unplug and plug in the nzw97.

1 Like

Ok, thanks. So I followed you and did the exclusion, unplugged the device and it said one device deleted.

I went back to re-add by scanning but did not see it in the list.

I even when to the manufacturer section, but it only shows a switch/dimmer

It does not appear for me to add, but it also does not show listed as a device. Is there something else I need to do in the IDE or something other than the Device Handler?

I would search for a “z-wave” device or the search nearby function. Unplug and plug in to start inclusion

That appeared to work! Although Smartthings complaining about security of the device and skipped that, it does respond. Thank you!

This is the error in the IDE

  • networkSecurityLevel: ZWAVE_S2_FAILED

Exclude the device again and include. Move it directly next to the hub. Sometimes that happens if the mesh isn’t strong.

Ok, I tried that, sitting right next to the hub and same thing. Do you happen to know if this is a known issue with the new ST app?

Is it prompting you to enter DSK or scan qr code? Did you include via scan nearby or generic z-wave?

No prompt to enter or scan. Just Skip or Exclude it. I tried both ways again, scan fails to see it, generic adds it but gets the security issue.

@Bry any more ideas? I don’t have any real experience with the gen1 hardware?

Tbh, the S2 implementation on these were always kind of suspect and one of the reasons we moved manufacturers.

I think it should work fine aside from failing S2, but it’s my understanding that they will default back to S0 (still secure).

Can you let me know what it says in the Raw Description section? Specifically here:

Here you are: