Notifications in the new Smarthings App

I am running into an issue with notifications in the new Smartthings app. All of a sudden, I have lost the On/Off indicator and I now have a “no cloud symbol”. As a result, my notifications are not working properly. I can turn on/off the notification in the old Smartthing app. I am using the red series dimmer. Any clue how to fix this?

Hey @bgratigny - this is strange! Question for you - did you just move over to the new app or have you been on the new app for a bit and this just happened?

I moved over to the new app about a month ago. It worked fine at first, but I was still having the issue where I would lose my notifications. I tried to update the firmware to 1.48, then back to 1.47 to see if it would fix the lost notification issue, then this issue started.

Right now I am trying to reset the switch and reload 1.48. I will keep you posted.

1 Like

The cloud icon indicates that the switch is offline. So I don’t think this is a notification issue. It’s an issue of the switch connecting to the hub.

Only the notification is showing offline. The normal switch is fine.

I had one that was acting up a while back, I pulled the airgap switch out, popped it back in and basically rebooted the switch and it started working again.

This brings up an interesting question from my perspective. I have very recently migrated from using the classic app to the new app.

When I saw the OP’s screenshot, it looked like the device page for the parent device. So I opened the device page for several of my switches on which I have notifications set, working properly. I just realized that unlike in the Classic app, the device page does not have a notification section where you can manually turn the notification on and off. Is this a limitation of the new app or did I not migrate completely?

The children are now separate devices. Mine are also showing offline but working properly…

That sort of what I figured when the OP said that it was the notification offline, but I don’t have any. I just have the parent devices, not the notification devices.

I believe it to be the case that you have to exclude/include again for these to show, but @EricM_Inovelli might now how to trigger their creation.

So getting back to the OP’s issue, the fact that the notification device is showing offline may or may not matter. Yours is showing offline but still working.

I don’t want to hijack this thread, so I’ll repost if @EricM_Inovelli doesn’t comment.

I’m experiencing the same issue as the OP, I think. The parent device works correctly. The child device shows as “checking status” forever. As a result, the child device can be operated from the location/rooms screens (at least it can be turned ON; turning off it’s less reliable), but it cannot be operated from its own details screen because the on/off button is replaced by a cloud indicator.

I’m attaching screenshots of the rooms page, both before she pressing the on/off button for Notification 1. (The notification activates immediately, but SmartThings keeps the spinning indicator, like it’s waiting for confirmation that the action was taken.) I’m also including screenshots of the details pages for the parent and child devices. @EricM_Inovelli let me know if there are logs you’d like me to send.

My theory is that there is some status or health-check function that the new ST app started requiring in the last couple of weeks, and which the parent device implements, but the children do not.

Note that this appears to affect ST “Automations” that check the state of the notification child, but those that blindly set the state are able to do so.

I am also seeing this and can only edit settings from the old app if I try to edit notification settings in the new app they are not saved!
This needs to be resolved soon because the old app is going away!

I believe this issue is fixed in the latest device handler. After the handler is updated the child devices need to be re-created. If you go into the old one and delete it just go back into the parent device and toggle any setting and it will create them again in the new way.

@scpickle I am still not sure about this problem. I had this happen to me this morning for a bit and then it stopped so I wasn’t able to troubleshoot it further. Can you try again to see if the issue is resolved.

I have updated the dth apparently I was 2 versions behind.

The new app is now showing the notifications online and I can toggle them on and off. :slight_smile:
However, I still cannot create a new notification or edit an old one in the new app, this can only be done in the classic app!:frowning:

I have a similar notification situation. In my case, notifications are working fine, but the separate (child) notification device does not show up in the list of devices on the new app or the IDE. This is for LZW30-SN switches:

  • I migrated from Classic to the new app with an older DH in place.

  • I added a new LZW30-SN using the new app with an older DH in place. Notifications trigger fine and I can see the notification section in the parent device’s entry, but there is no separate child device entry.

  • I updated to the 2020-09-21 DH. In the IDE, I changed the type for the new switch to something else and saved. Then put it back to the proper Inovelli one.

  • I changed a Notification settings and pulled the airgap. Notifications work fine, but not way to control them in the new app. I can still turn them on and off in the Classic app, but that’s going away at some point.


Sure would be a shame if we had 51 child devices 99% of which are in multiple smartapps and automations…

Thanks Smartthings…

1 Like

Unfortunately the new device handler needs to be in place when the child devices are created. I have found no way to convert the child devices to the new format that the new SmartThings app requires.

@spickle I will look into this some more. SmartThings must have changed something that is making this happen.

1 Like

I think your right because it worked when I first installed the dth because I remember not being able to turn them on in the new app to see what the looked like. and was pleasantly surprised on how they worked in the old app ‘to bad Samsung has to kill it’.

Anyways it appears to be working again today in the new app, its weird because I was able to edit all the other parameters just not any for the notifications for the past couple of days.
There were no errors it just would not save the new setting
Thanks for looking at this!

1 Like

Uhh, that was DEFINITELY worth it, somehow these are WAY snappier and WAY more efficient in the app. I wonder if the child devices created the old way we’re causing some of my issues.

Definitely HIGHLY recommend re-creating child devices. $hit’s almost instant now…

1 Like