Notifications still not consistently working on Inovelli Dimmer Red Series LZW31-SN

I have spent way to much time trying to figure this out without any luck. I have a LZW31-SN switch set to show a notification if my garage is open. The issue is that it does not show the notification on the physical switch all of the time, but Smartthings show’s the notification as “On”.

I have tried using webcore and smart lighting and still have the same issue. I have tried different switches around my house, and they show the notification on a consistent basis, while this one switch does not. As a result, I thought it was a faulty switch and swapped the switch, however I am having the exact same issue. This switch is connected to GE add on switch, could that be causing the issue?

Any other suggestions on how to fix this issue?

What’s triggering the garage door open notification?

I have a gocontrol Garage Door Opener Remote Controller Accessory and a tilt sensor. When the tilt sensor is open, it triggers the notification.

Do you have a child device for the notification in ST? If you do, does the notification on the child device turn on and off properly? If this isn’t clear, post back and I’ll elaborate.

Yep, I have the child device for the notification in ST. On/Off shows up properly in ST, just not on the physical switch.

Strange. I can’t imagine the Aux is causing the issue but nothing would surprise me.

Which DH are you using? The latest is 2020-11-13.

I am using the most recent DH. Which DH should I be using for child device? Right now I am using “Switch Level Child Device”. I have also tried “Switch Child Device”.

I haven’t loaded the most recent child device dh as they are optional. I still have an older switch level child device loaded only because it used to be required. I can’t remove it until I unpair and then repair my older switches.

If you can, try removing the child device. Also make sure the notification effect level is set to 100% or something high. That’s probably not the problem since this is the 2nd switch, though.

Also, tagging @EricM_Inovelli. TLDR version is that notifications don’t work on one Red dimmer. Swapped the dimmer . . same problem so it’s not the switch. Child device in ST displays the notification turning on and off ok but the LED does not light up indicating the notification. This is on a 3-way with a GE Aux.

I don’t think it is the GE add on causing the issue. I just did a test of another LZW31-SN connected to a GE switch and it is working fine. This is very odd.

1 Like

Agreed. You could exclude/factory reset it and see what that does.

Can you confirm the version of firmware that is on the device?


Could multiple smart lighting automations cause issues? I have one automation that turns on the notification and one that turn on the light when the garage door is opened. I deleted the automation for the light and for the last couple of hours the notification is working properly.

Could be, but as @Bry states it may be worth it to do a factory reset. Also, you may want to try to flash the .bin file again. Watch the flash process to make sure it completes then do an exclusion and a factory reset.

I reflashed the bin, and then did the exclusion and factory reset. I am still having the same issue. It has something to do with my garage door opener. If I delete the SmartLighting automation that turns on the light when the garage door opens, the notifications work fine.

Still no idea, but can you post the automation that is killing the notification?

Just saw your issue in the weekly Inovelli summary. I too have been having issues with notification lights not appearing correctly, and I have them syced up to 4 switches, and all of them are exhibiting the same problem.

For me it is very intermittent, and I would say that it started right after the Smarthings migration. I have been having all kinds of problems since the migration, which is why I had not raised the issue here.

Well, that’s pretty straightforward. It’s hard to see how that could prevent a notification.

Do you have a child entry for the notification? If you had used an earlier DH and then added the dimmer, the notification would still work but you wouldn’t have the child device. If that’s the case, remove the dimmer and re-add it after insuring you are using the latest DH.

How are you turning on the notification, SmartLighting or something else? If you want to experiment, maybe try setting the notification with something else to see if it is still blocked. i.e use an Automation or better yet, something outside of ST. i.e Rule Engine or webCore.

I did a factory reset, so I had to create a new child entry using the most current DH.

I was originally using SmartLighting to turn on the notification. I just moved it to webcore and for the last couple of hours it appears to be working properly. I will keep my fingers crossed.

Spoke too soon, the issue is back. The odd thing is that I have the exact same switch and set up right next to it and it works fine.