NZW30 will not pair

I have 3 NZW30 switches that were previously on a SmartThings hub - which is no longer available. However, I did remove them before taking that hub down, as well as removing them form the SmartThings online api.

I have a z wave network running on Home assistant and have 2 Nortek GoControl garage door openers added. So I know my Home Assistant and the hub are operational.

I cannot get any of the three NZW30 switches to pair with Home Assistant. I have tried powering them off at the fuse box, and then back on. They do not pair. I have tried pushing the down (Button B, or off button) 6 times within 2 seconds. Then powering them off and back on, still nothing. I have tried pushing the top button 6 times in 2 seconds. I just can’t get them to pair. They are within about 10 feet of the Home Assistant Raspberry Pi - which is located in the same location as the previous SmartThings hub so they should be within range. I have the Inovelli files located in my folder config/ozwave/config and that is in my configuration.yaml file.

I am at a loss as to what else to try. Please help.


Does no one have any idea on this?

Hey, so I’m not too familiar with Home Assistant (although, I’m in literally the same boat as you as my Raspberry Pi showed up today and I’m planning on taking a stab at HA – coming from ST too) and I know you said you removed them from your ST Hub, but would you mind putting HA in exclusion (again, sorry, I’m not sure how to do this) and then try to exclude the switches first?

The exclusion is the same as inclusion (press paddle 6x quickly).

I believe (going off memory) depending on the version of NZW30, the light should blink to confirm if exclusion/inclusion was successful. If not, then I may have just made that up as it’s been a while since I’ve played with one.

Keep us posted!


Thanks you. I was surprised but it partially worked. Surprised because I had never had these switches paired to the Home Assistant hub.

I was able to get one of the first two closest ones to pair. however it is showing up as a Zooz (Willis Electric) Manufacturer=015d, type=1e01, id=1e01 (unknown type and d). Both of those codes are from the Inovelli manufacturer.xml file as correct for my switch, but not the manufacturer. I have tired and tired to remove it and I cannot get it to remove. I also cannot get the second one to pair.

Do you have more suggestions?


Sorry for the delay here – not sure how I missed this one.

Yeah, this was an issue on one of the batches of our switches. Zooz was made at the same manufacturer (Willis) as our Gen 1’s and they accidentally put the wrong MFR ID on it.

What do you mean, “cannot get it to remove”? I thought you meant that you were successful based on the first paragraph:

The tapping up 6x doesn’t work to remove the device?

For the second one, were you able to exclude that one before pairing?

NET: You should make sure to exclude both switches (factory reset) before trying to include them to Home Assistant.

Keep me posted!

I am having a similar issue with all 10+ of my gen 1 NZW31 w/Scene. I am pretty sure I excluded it correctly from smartthings. Although getting either no response from home assistant or an error when trying to add that I previously submitted into support.

Here is the error I am getting

What are you using for the zwave component in HomeAssistant? And have you checked the logs to see if there’s any more information about the error you’re getting?

If you want to make sure you excluded them, you can repeat the exclusion process via HomeAssistant.

I did the exclusion again through Zwave PC Controller Software.

I am using the following zwave component. [GoControl CECOMINOD016164 HUSBZB-1 USB Hub]

I was an early adopter of Inovelli and most of my devices are Inovelli Dimmer NZW31 w/Scene and probably need firmware updates.

I have not looked at the logs as I am pretty new to Home Assitant.

1 Like

When you set up Home Assistant, how did you do that? (Installed directly on an rpi, inside a docker container, etc?) And then when you set up Zwave, did you just set it up directly in Home Assistant (Z-Wave JS I’m guessing)?

These help point out where log locations will be or how to do each step, etc :slight_smile:

I have home assistant installed directly on rpi and using z-wave JS.

Found this in the JS log when trying to add switch
2021-12-15T15:57:38.398Z CNTRLR Adding the node failed

Try a factory reset on the dimmer. Hold the up button then power on the device and keep holding for at least 5 more seconds after power was applied. Not very easy, but that will reset it. I’m not sure if the air-gap would work to remove the power, but it might so you could try that first.

Then, start the inclusion process in HA followed shortly after by tapping up 6X within 2 seconds on the dimmer.

Finally, you didn’t try to do any changes to files or such for zwave, right? None of those old notes are needed for zwaveJS.

Did the reset, and tried adding again and got the same error. I confirm that I do not have any of those manual config file changes previously communicated enabled.

2021-12-15T16:15:26.494Z CNTRLR Adding the node failed

Might be worth going to the Z-Wave JS integration logs and lowering the level to debug or silly and then trying to include the switch again?

2021-12-15T15:57:38.398Z CNTRLR Adding the node failed
Subscribed to Z-Wave JS Log Messages…
2021-12-15T16:15:26.494Z CNTRLR Adding the node failed
Subscribed to Z-Wave JS Log Messages…
Log Level changed to: Silly
2021-12-15T17:33:50.279Z CNTRLR Starting inclusion process with strategy Default…
2021-12-15T17:33:50.510Z SERIAL » 0x0105004ac1cdbc (7 bytes)
2021-12-15T17:33:50.708Z DRIVER » [REQ] [AddNodeToNetwork]
payload: 0xc1cd
2021-12-15T17:33:50.719Z SERIAL « [ACK] (0x06)
2021-12-15T17:33:50.729Z SERIAL « 0x0107004acd0100007e (9 bytes)
2021-12-15T17:33:50.744Z SERIAL » [ACK] (0x06)
2021-12-15T17:33:50.751Z DRIVER « [REQ] [AddNodeToNetwork]
payload: 0xcd010000
2021-12-15T17:33:50.770Z CNTRLR The controller is now ready to add nodes
2021-12-15T17:34:08.612Z SERIAL « 0x0107004acd0200007d (9 bytes)
2021-12-15T17:34:08.619Z SERIAL » [ACK] (0x06)
2021-12-15T17:34:08.626Z DRIVER « [REQ] [AddNodeToNetwork]
payload: 0xcd020000
2021-12-15T17:34:08.634Z DRIVER handling request AddNodeToNetwork (74)
2021-12-15T17:34:08.636Z DRIVER 1 handler registered!
2021-12-15T17:34:08.639Z DRIVER invoking handler #0
2021-12-15T17:34:08.643Z CNTRLR handling add node request (status = NodeFound)
2021-12-15T17:34:09.553Z SERIAL « 0x0107004acd07210059 (9 bytes)
2021-12-15T17:34:09.560Z SERIAL » [ACK] (0x06)
2021-12-15T17:34:09.566Z DRIVER « [REQ] [AddNodeToNetwork]
payload: 0xcd072100
2021-12-15T17:34:09.588Z DRIVER handling request AddNodeToNetwork (74)
2021-12-15T17:34:09.591Z DRIVER 1 handler registered!
2021-12-15T17:34:09.594Z DRIVER invoking handler #0
2021-12-15T17:34:09.598Z CNTRLR handling add node request (status = Failed)
2021-12-15T17:34:09.603Z CNTRLR Adding the node failed
2021-12-15T17:34:09.611Z CNTRLR stopping inclusion process…
2021-12-15T17:34:09.654Z SERIAL » 0x0105004ac5cebb (7 bytes)
2021-12-15T17:34:09.658Z DRIVER » [REQ] [AddNodeToNetwork]
payload: 0xc5ce
2021-12-15T17:34:09.669Z SERIAL « [ACK] (0x06)
2021-12-15T17:34:09.679Z CNTRLR stopping inclusion process…
2021-12-15T17:34:09.717Z SERIAL « 0x0107004ace0621005b (9 bytes)
2021-12-15T17:34:09.720Z SERIAL » [ACK] (0x06)
2021-12-15T17:34:09.727Z DRIVER « [REQ] [AddNodeToNetwork]
payload: 0xce062100
2021-12-15T17:34:09.750Z SERIAL » 0x0105004ac5cfba (7 bytes)
2021-12-15T17:34:09.754Z DRIVER » [REQ] [AddNodeToNetwork]
payload: 0xc5cf
2021-12-15T17:34:09.758Z CNTRLR The inclusion process was stopped
2021-12-15T17:34:09.761Z DRIVER the message was handled
2021-12-15T17:34:09.768Z SERIAL « [ACK] (0x06)
2021-12-15T17:34:09.812Z SERIAL « 0x0107004acf0621005a (9 bytes)
2021-12-15T17:34:09.817Z SERIAL » [ACK] (0x06)
2021-12-15T17:34:09.823Z DRIVER « [REQ] [AddNodeToNetwork]
payload: 0xcf062100
2021-12-15T17:34:09.835Z CNTRLR The inclusion process was stopped

1 Like

Which raspberry pi and is your USB stick plugged directly into it or using an extension cable? Something you might consider that I’ve seen elsewhere is using a USB extension cable on the raspberry Pi. The USB3 ports can cause interference on the 4 at least, so the cable should help with that.

Another possible thing to try is unplugging/replugging the zwave stick and then restarting zwave (or I suppose homeassistant if you can’t restart zwave js separately) and seeing if that clears it up.

(Unable to include new devices · Issue #1069 · zwave-js/zwavejs2mqtt · GitHub) < I know this is for zwavejs2mqtt also instead of just zwave js, but it came up with the same inclusion failure, etc also on an rpi.

Looks like that did the trick. I have completed a couple and will go down the list of others. Should I also be taking this opportunity to update the firmware on the switches?

1 Like

Glad to hear it! (Guessing it was the unplug/replug and restart that did it?)
^I’m only showing the firmware for the NZW31. If you’ve got the NZW30, I’m not sure that there’s anything you’ll need to do there.

Hey so there really isn’t much in the sense of upgrades with the Gen 1’s and the process can be extremely tricky with them and can lead to bricking if not done properly.

I personally wouldn’t recommend updating them, but if you really want to, let me know and I’ll walk you through it!

1 Like