NZW31 Dimmer - instant on/off setting on Hubitat

I am trying to use the NZW31 (w/o scenes) as a non-dimming switch, to be able to turn light on and off without dimming effect. I am using the Inovelli Dimmer NZW31 latest driver, however I seem to be unable to set it to instant on/off. I even tried to use NZW30 driver and a Generic Z-wave Smart Switch driver to with the same result. Is there something I am missing? Looks like I am on firmware 1.01. This is my first post, not sure what else might be useful, but here is the screenshot of some settings:

I don’t have this model so I can’t test but have you tried changing the Dimming Step Size to 0?

Actually I was able to solve this just now, I changed the “Dimming Step Seiz Percentage of step when switch is dimming up or down Range:0 to 99 (0 - Instant)” setting to 99 instead of 0. I thought this is a bit counterintuitive in my opinion, but it worked!

1 Like

Use correct driver and set “Ramp rate” param to “0” for instant on/off