Overriding Blue Series natural LED on/off state

Hey guys,

I have a Blue Series switch connected to a dumb light and I have an automation that sets only the top LEDs to 100% when it’s on, then 5% when it’s off. This works but the switch always goes fully on (all LEDs) for 2 seconds before the bottom LEDs go to 5%.

This is the case for every switch that isn’t in Smart Bulb Mode.

Is there a way to disable this behaviour so that I don’t have to wait 2 seconds each time for the LED states to correct themselves?

For some context, I use the bottom LEDs to indicate if a separate set of smart lights are on/off which is the use case here.

Do the bottom LEDs go back to the original state, or does that behavior override how you had them displayed? (If the separate set of smart lights is on, do those stay at 100%?)

The LEDs eventually do what I want, but are temporarily overridden by the default behaviour for 2 seconds.

So when the lights are all off and the switch is pressed (in my case, up single for the dumb light), all 7 LEDs will light up to 100% and then 2 seconds later the bottom LEDs will go to 5%.

I don’t have any automations that would be telling the bottom LEDs to go to 5% after 2 seconds and this is only an issue with switches that are connected to a dumb light (I have 3 of these and they all do the same thing) so it’s related to that somehow.

I’ve also tried changing the switch’s “LED % when on” to 5% which does the same thing but keeps the LEDs at 5% for 2 seconds until the automation’s rules kick in.

I kind of prefer to have it set to 100% when on rather than 5% so that I can get the immediate visual feedback but doing it the other way looks less “glitchy” (just slow because it takes 2 seconds).

But obviously just having this behaviour removed entirely would be the best.

I’m not aware of any way to disable that currently, but I definitely get what you’re referring to (the on/off animation for the switch itself overriding for a couple seconds). Might be able to request to see if another parameter can get added as part of a future update that would make that controllable though? You would want to put that in this thread for it to get tracked.

May take a little for Erics to get back to you, I know they’re pretty heads down with shipping out the Reds and working on some of the other projects too.

1 Like

I’m not sure I understand the issue, but I think this will do what you want

1 Like


So this is almost exactly what I’m looking for. I tried it but now instead of it staying on for 2 seconds, it flashes for maybe 50-100ms. This is way better but clearly there’s something else still causing it to go on for a moment.

Any ideas?

Have you tried setting P97 and P98 to 0?

This unfortunately doesn’t fix the problem although it does have an effect.

The issue is that if I set the default on/off level of the LEDs to 0 (or 5 in my case as I like it having a touch of light at all times), it will again flash for maybe 50-100ms to that level (0 or 5 or whatever). This is a problem when I have the bottom set of LEDs at 100% to indicate a different light is on. When the lights are all off, setting it to 0 gives the illusion that it’s no longer flashing but as soon as there’s a conflict between that (P97/P98) setting and the setting set by an automation, the flash occurs.