Pairing LZW42 bulb with Smartthings, wont find correct Edge Driver

Hello, I recently pulled out a LZW42 bulb I had laying around and decided to add it to Smartthings. First I updated the firmware to the latest version, 2.31. I then installed the Edge Driver for the bulb on my hub. Issue is, when I go through the process of trying to add, Smartthings does not utilize the correct driver, it uses a Smartthings driver, Zwave Switch. From there, if i try to change the driver to the one I installed, it will not give me an option to do so. I do have the option to use a couple of the Edge config drivers though and one of them show the Manufacturer, Product Type and Product ID as all zeros.

I am able to turn bulb on and off from within Smartthings, but of course dimming and color change is not possible.

How are you adding the bulb to ST? When it got added it did not pick up the bulb details (manufacturer, type or ID)which is why I think you wound up with the generic driver.

Do a Z-Wave exclusion and remove the bulb. Re-add it using scan nearby.

Hello, I did try that way as well, a few times. I have reset and tried to add via Scanning and via picking the Brand, but end result is always the same


Resetting the bulb (if that’s what you mean by “reset”) is not the same as doing a Zwave exclusion. You need to exclude that bulb from the hub before re-adding it.

Post a screenshot of the Edge Drive channels your hub is registered to. Open the page for your hub in the app. From the 3-dot menu, select Driver and scroll to the bottom. The hub registered Edge drivers are displayed there.

Hello again, sorry poor wording. I have done both a few times. Excluded and reset. See below screenshot of driver

That’s the proper channel registration that should cover the LZW42. It’s possible a fingerprint is missing from the driver.

If you have Todd Austin’s API browser installed, you can try changing the driver from there.


1 Like

Hi Bry, I tried changing using his tool earlier, received a failure.

That said, I just connected the bulb back to the Zwave PC Controller and updated firmware again, to same version. Once done, I then tried to add back to Smartthings and on the first try it worked, grabbed the proper driver!

Appreciate your help, Bry. Not sure if something happened during the first firmware update or not, but I added and removed the bulb 20 times. :slight_smile:

1 Like

Glad you got it going! I think you are correct about something going sideways on the first flash.