Pairing with S2 security now not working (was: Firmware update for red dimmer not “taking”)

EDIT: now that I got the firmware installed, I still can’t pair with S2 security. Expected? See more starting here

I’ve tried updating two red dimmers to 1.48. Both on 1.47. Firmware update seems to complete, then I switch the device type back to the dimmer from the firmware update and the firmware is once again listed as 1.47. Any ideas? Thanks!

Screen recording: Firmware update not taking - Album on Imgur

After flashing, and setting back to dimmer, hit the configure or refresh button. Check firmware version then.

Wow, that’s was simple. Thank you. Definitely thought I had tried pressing that, but apparently not. Worked for both dimmers I’ve flashed. So now if I want to take advantage of S2 security on each dimmer I need to exclude and include and then I should be prompted for the Device Specific Code (DSK)?

@bressler - Correct.

I’ve tried three times now since upgrading the firmware. I’ve confirmed that the DSK is correct. And yet still I see None listed for security. Screenshare of the entire thing (sorry for low quality, couldn’t fit into 1 minute to post on Imgur):

Which hub are you using? C5 or C7?

C7 with platform version

Weird…is there a way you could get closer with the hub to include it?

Not easily. I’ve been unscrewing all these face plates and getting hub closer for days and it’s so annoying. That was just to get the initial pairing to work. I never realized how hard and painful Z-Wave was going to be vs. Wi-Fi…

Any other tips/suggestions?

I can’t view your video where I’m currently at, so I will review it when I get home.

Are you leaving all the checkboxes checked or just S2 when including?

Here’s the checkbox situation, taken from 0:25 into the video. I leave all but the first checked, which is how the checkbox is presented to me. I’ve never known enough about S2 security to customize. Should I uncheck all but the 2nd box?


Nope, that’s usually what I do as well…only thing I can think of is it’s a weak signal and downgrading itself to no security.

You could temp hook up a CPU cord to the switch and plug into the nearest outlet to the hub for inclusion. Then move it back to the light box and repair Z wave…but that’s a bit much. You could uncheck all of them and verify the correct DSK, but you’ve probably done that.

Okay. Maybe I’ll try getting closer. This is <15 feet already through a plastic electrical box, so that feels pretty close. I guess not…

Anyone else have any ideas?

Yea…that’s fairly close.

@EricM_Inovelli - Any thoughts on inclusion?

Thank you so much already for all your help and insanely fast responses. It’s made this painful process a bit less painful

Try entering the DSK faster. If the “Found device with ID xyz…” pops up before the DSK is entered, then I suspect it’s too late and the device has already joined without security.

In the video it was more than 15 seconds waiting for the DSK to be entered; I’m wondering if it’s timing out and falling back to “No Authentication” because the hub can’t initiate security pairing until the DSK is entered.

1 Like

Switching from ST to HE and I ran into the same issues. Moving the hub closer (thank you extension cord and 50’ Cat6) and entering the DSK quicker did the trick.
Thank you @darthandroid