Plans to join Home Assistant's built-in OTA firmware update?

Per Home Assistant release info built in OTA updates are available but so far only one company has joined on.

I know i’ve held off on a lot of firmware updates because the computer running the zwave tools is different than the home assistant server, so it’s a whole ordeal to do any updates.

Would love to see this implemented.

7 Likes

Zwavejs2mqtt does firmware updates quite capably on HA. I caught up on all of my LZW30 and LZW36 updates a few months ago with zero drama.

With that said, the new transparent OTA updater in HA that checks with the device manufacturer for available firmware updates and notifies you in HA is the cat’s meow should Inovelli have some free programmer resources to code it…

2 Likes

Agreed. Integrating with the Zwave JS upgrade system would be awesome.

It doesn’t look terribly hard to do either. Just need to generate a json file per device model containing all of the update metadata and links to the firmware and add it here: firmware-updates/firmwares at main · zwave-js/firmware-updates · GitHub

4 Likes

Not sure if this is part of the, “Works with HA” certification process, but we are in the middle of becoming officially certified. I would imagine it is, but I’m not sure.

Either way, definitely something we want to be a part of on our end as we update our firmware a lot.

I know some of the beta testers were working on an easy OTA solution for Zigbee, so hopefully it’s a similar process for Z-Wave.

I’ll check with Zack over at HA and let you guys know!

13 Likes

I second that this would be cool.

It pops up a nice message that your device can be updated then it’s a one click update process.

Would make upgrade large rollouts so much easier! Also has the ability in the z2m addon to downgrade!

Home Assistant added a great Zwave auto update feature, any plans to participate? firmware-updates/firmware-files.md at main · zwave-js/firmware-updates · GitHub

This???

2 Likes

Yup thanks!

1 Like

@dmeglio – just merged your post with this thread so we can have it all under one thread. Hope that’s ok.

Quick update – talked with Zack from HA last night and one of the engineers from HA reached out to us with instructions to get this up and running.

Likely when @EricM_Inovelli is finished with the Edge Drivers he can work on getting this implemented. I think it’s awesome and a gamechanger for HA. It’s been a great feature for Hubitat and I’m glad to see other platforms taking notes.

9 Likes

On the zigbee side, would be great if the 2-1 Blue series were part of the OTA updates that zigbee2mqtt can find and apply. Very limited subset of zigbee vendors seem to be part of this program. Right now, only my Ikea devices can be updated through z2m.

1 Like

Can confirm the Blue Series will be able to get OTA updates through both ZHA and Zigbee2MQTT :slight_smile:

6 Likes

As mentioned, for Zigbee, OTA is ready to go for the platforms @chack mentioned.

For Z-Wave, I started working on this a couple weeks ago and didn’t quite finish. It is still on my radar.

4 Likes

Currently doing an OTA update on a zwave device through this new firmware update system. I have to say, it’s a great experience! Notification showing the update on the settings icon. Shows the update up top where all the HA updates go. Click on it and click install and it does it’s thing. Honestly this is even smoother than the zigbee2mqtt update process because I don’t even have to open the addon to check it.

1 Like

Just came here to see if there was an update to the firmware being available on HA considering I just got notification in HA that 3 of my switches have firmware available to update. Was kinda surprised considering there hasn’t been any mention of inovelli being added.

Hot dog!

3 Likes

From the github link above, only the LZW31-SN is provided. I went ahead and clicked the update. It went through, but everything still reports the older firmware version. Of my two lights, one no longer says it needs an update, even though it is 1.56, not 1.61. The other is still showing it is at 1.47 and wants to update.

I gave the system a reboot to see if that changes anything. Nope. This time I watched the install closer and it just stopped at 54%. Looking at the logs:

2022-09-16T14:43:39.010Z CNTRLR « [Node 014] Firmware update completed with status OK_RestartPending
2022-09-16T14:43:39.011Z CNTRLR [Node 014] Firmware updated, scheduling interview in 5 seconds…
2022-09-16T14:43:39.013Z CNTRLR [Node 014] Downloading firmware update from https://files.inovelli.com/firmwar
e/LZW31-SN/Beta/1.61/LZW31-SN_1.61.otz…
2022-09-16T14:43:39.332Z CNTRLR [Node 014] Firmware update https://files.inovelli.com/firmware/LZW31-SN/Beta/1
.61/LZW31-SN_1.61.otz downloaded, installing…
2022-09-16T14:43:39.337Z DRIVER » [Node 014] [REQ] [SendData]
│ transmit options: 0x25
│ callback id: 117
└─[FirmwareUpdateMetaDataCCMetaDataGet]
2022-09-16T14:43:39.343Z DRIVER « [RES] [SendData]
was sent: true
2022-09-16T14:43:39.362Z DRIVER « [REQ] [SendData]
callback id: 117
transmit status: OK
2022-09-16T14:43:40.396Z CNTRLR [Node 014] Timed out while waiting for a response from the node (ZW0201)
2022-09-16T14:43:44.015Z CNTRLR [Node 014] Beginning interview - last completed stage: None
2022-09-16T14:43:44.016Z CNTRLR [Node 014] new node, doing a full interview…
2022-09-16T14:43:44.017Z CNTRLR » [Node 014] querying protocol info…

It looks like the first file completed, but then there was a timeout on the second *.otz file.

I’m also having an issue. The progress bar goes up to 50% and then stops. As if nothing happened. I tried two switches with the exact same result.

I’ve updated two of my Red Dimmers through zwavejs2mqtt this morning. The only problem I’ve seen so far, and I plan on opening a ticket for it, is that the logic for figuring out if there’s a firmware update available only considers target 0, not both. So on my first switch I updated target 0 and “no available updates” even though target 1 was still behind. Doing target 1 and then 0 solved that, but it’s still not ideal.

When you updated via zwavejs2mqtt, did you use 1.61 for target 0 and 1.45 for target 1?

I noticed it thinks 1.61 should be on both but from looking at the firmware page for the switch it looks like 1.61 is for target 0 and 1.45 is for target 1.

Strange, just now I updated one of my switches using zwavejs2mqtt and only did 1.61 on target 0 and it now shows up to date with no updates needed both in zwavejs2mqtt and HA. Didn’t do anything with target 1.

It was hard to tell what that little firmware update card was showing for the files it was using, so I did some hand tweaking:

It’s showing the 1.45.bin file for target 1 and the 1.61.otz for target 0, as it should.

I had to update target 1 (on switches requiring an update of target 1) first to get z2m to continue to prompt to update the firmware. It’s obviously comparing firmware versions for target 0 only.