Point of Parameter 51 with Black On/Off

I was doing some testing using node-red in Home Assistant (z-wavejs) and scene control events.

Using a Red Dimmer, I find it easy to listen for scene events with multi-tap, with the black series I was unable to get any scene event to execute. Now originally this was my assumption, black series doesn’t have scenes as a feature, but if the black series doesn’t have scenes then what is the point of ever leaving parameter 51 set to 1?

It’ll be from the common code that is shared with the red series. The newer firmware does have scenes, but only single tap or hold events.

The correct question would be why the delay is enabled.

1 Like

From @Eric_Inovelli in another forum:

Q: Why do these switches default to having over a half second delay if there’s no multi-tap options???

A: There’s no reason, it was just an oversight on our part. We try to be perfect, but we screwed up.

Man, now my PTSD on this topic is back lol. We even had an ugly Christmas sweater made with 700ms Delay put on it to remind the other Eric of the constant pain this feature has put us through.

In all seriousness, do you have a means of updating the firmware? We’ve fixed it so that you can remove the delay.


Founder | Inovelli

I’d already disabled it last night. I was just worried i was doing something incorrect

@Bry Is the delay disabled in the new software after a factory reset? If it’s not, then no-one has cared enough to make sure the oversight was corrected.

I have no idea. I think I only have one black switch and it’s never been installed. If you have one installed, reset it and let us know what happens. @Eric_Inovelli said it was fixed so that you can remove the delay. The OP was able to do that.

You can disable the delay on all the devices. But, I don’t believe any device has it disabled by default in any firmware and it should have been in the black series.

I think the device parameter needs to be configured as it doesn’t default to 0 or 1 the first go around.