Power display Red Series switch

Where can I view the power being used in the new Smartthings app? Not seeing an option for it.
I have two of the LZW30-SN Red Series switch. Is there another way to view power draw if not available in ST?

You should see it on the device’s page in SmartThings. Make sure you are using the latest DH, which is 9/21/20. If you have to update the DH, you will probably have to exclude and then re-include the switch.

1 Like

Thanks for the help. Where can I view the version of Device Handler? I went to the ST API device handler section. Here is what I see

You have to log into the SmartThings IDE, https://graph.api.smartthings.com/ . It’s the same place where you went to install that Device Handler. I don’t think there is any place to see it in the SmartThings app.

Go to the My Device Handlers section and then select the Inovelli Switch Red Series LZW30-SN entry. The version is listed at the top of the entry.

1 Like

I add a new DH dated 9-21-2020. I was unable to delete the existing DH as it said DeviceType still in use by devices so I found a way to edit the source code and added the new code saved and published it. Now I have three DH: One is a child DH dated 2017 not sure how to update that one and the other two are the existing DH that I updated to 9-21-2020 and then I created a new one also. I still don’t see power option in the new ST APP after restarting the APP. What is the child DH for?

Did you exclude and re-add the switch?

The child is left over from the older DH. No need to worry about that now. You won’t be able to delete it until you have all of your switches using the new DH.

By exclude does that mean deleting the device from the ST APP and delete from API under devices and then re-include through the ST App?

Exclude is basically properly removing from your Z-Wave hub.

Basically, with ST, you can enter the, “Remove” mode and if you’re device removes properly, it will confirm with ST (and it will say, “your device has excluded” or something along those lines) whereas if it isn’t able to be removed, ST will say, “Force Remove”?

Force Remove will remove the device from IDE, but the device will still think it’s paired to ST.

So, when you exclude it, it not only deletes it from ST, it factory resets the device.

Hope that helps?

Here is how to exclude. This will remove the device from SmartThings so that you can re-add it just like the first time you installed it:

Resetting via the SmartThings App

  • From the home screen, click on the three lines at the top left of your screen to open the menu

  • Click on the, “Devices” icon

  • In the search bar, search, “Hub” and select your Hub

  • Click on the three dots at the top right of the screen and select, “Z-Wave Utilities”

  • Then press, “Z-Wave Exclusion” and the process will start

  • On your Inovelli Switch, press the config button 3x rapidly (the LED bar should pulse blue)

  • If the exclusion was successful, your Inovelli switch LED bar should turn from pulsing blue to GREEN

  • In addition, the SmartThings app should say that your switch was excluded successfully

The above copied from:

1 Like

I removed two of the switches using the exclusion process which did work. I tried adding back both switches. The basement light switch was successful but gave me message: “Some security features not supported. Device is not using the highest level of security. Use a newer Z-wave device for better security” and now all it says is connected when I go into it. Tried adding porch light back and it fails shows red light on the switch. The porch light switch has been working for a good year now but no longer works.

How did you add the basement switch? Did you do it by scanning the barcode? What that message means is that the switch is connected to the hub but added at a lower security level known as s0. That can happen when you do not use the barcode to add the switch or it can happen when things don’t go just right. I would exclude and add it back again using the barcode.

ok, now the power is showing in ST for basement but shows 0 power usage when lights are on. Porch shows correct power usage

I redid it and it shows correctly now in ST but power shows 0 when the lights are on for basement only?

Ok, just so I understand . . .

The basement switch is a LZW30-SN. After adding the latest Device Handler, you excluded and re-included the switch. Now, in the SmartThings app, when you open the device page for the basement switch, you see the Power Meter and Energy Consumption sections, but with the light turned on, the Power Meter shows 0?

Seems to be working now. Must have been some sort of delay but it’s working now in both Sharptools and ST. Thank you for the help. How do I enable dark mode in ST like u have?

Good question. I just migrated to the new app a few weeks ago. I don’t remember turning it on and couldn’t find anywhere that you could. I’m on an Android.