Red Series Dimmer Exclusion Issue

I have a Red Series Dimmer that I am trying to exclude. It seems like this should be simple enough. I put the Hubitat into exclusion mode, press the config button 3 times. After 30 seconds, they both time out but and the device is still in the list and controllable by the hub. Am I missing something?

Doesn’t sound like you’re missing anything. This is a problem I’ve seen reported occasionally here and on the Hubitat forums. If you’re able to move the hub closer to the dimmer (or vice versa), that is one thing people have claimed to help. This shouldn’t be necessary because the dimmer should support network-wide exclusion (i.e., doing so through repeaters), but if it helps… :man_shrugging:.

Otherwise, I ran into this problem myself this morning. It worked after I tried a few times. Trying again is worth doing if you haven’t already. Restarting the switch (pull the air gap, then push it back in) can’t hurt, either. Restarting Hubitat (once — don’t go crazy with that idea, and it’s sometimes recommended against because it can make things worse if your Z-Wave coordinator disappears and then a bunch of things are frantically trying to communicate with it when it comes back) can’t hurt either, maybe powering it off for a few seconds and then restarting instead of a “plain” restart to ensure the Z-Wave radio gets fully powered down.

Thanks for the response @BertABCD1234 !

So I have a couple more things I can add.

  • It appears that this is only happening to my Dimmers. I was able to exclude an Inovelli Black Switch and another Z-wave device. Very easily! YA! Rules to fix.

  • I’ve tried to exclude two additional Red Series Dimmers, One that I just installed yesterday (Original FW) and the other I have previously excluded in order to update the FW. Both failed to be excluded.

  • If I hang out at the dimmers and wait for the exclusion process to time out, The dimmers LEDs flash red… Guessing that’s the dimmer letting me know that the exclusion failed…

  • As I expected, moving the hub closer (within 4’) didn’t change anything. I have been able to do this several times before without issue.

So at this point, what are the implications of forcibly removing the two dimmers and performing a factory reset on them? I thought I read somewhere in the HE forums that this isn’t a good practice to do?

The red would indeed indicate that the exclusion (or inclusion) failed. It sounds like you’re doing everything the way it should work, so if a force-remove and reset of the switch might be all you can do. Some users on the Hubitat forums do report problems if they have “ghost nodes,” but if you remove it from the UI somehow, this shouldn’t cause that to happen (and if by chance it still does, it should still get cleaned up by the nightly maintenance, and if that fails, a reboot plus the next maintenance cycle then should; some people use third-party tools to compare their Z-Wave nodes from Hubitat to the one the radio itself reports, which would also be a possibility here if you’re super-concerned, but I wouldn’t be worried if you somehow remove it yourself).

Yeah, I tried rebooting the hub and removing a few other Inovelli non-dimmer devices as a sanity check. Everything was easily excluded. Just none of the existing dimmers I tried.

I installed a couple of new ones yesterday and tried to exclude them as well. No can do. I haven’t created any rules around these yet. So, I may try to exclude them before doing so, just so I don’t break any more of my rules :crazy_face:

@Ma2J Did you ever get your dimmer issue resolved? I’m having a similar problem with one of my Reds.

@clambert First welcome to the community.

No, not back then. I ended up having to forcibly remove them and then perform a factory reset on the dimmer. Thankfully, I didn’t have any issues with ghost nodes (verified via secondary controller).

I am about to try again as I migrate from my C4 to my new C7. Currently, work has me pretty tied up (thankfully) to where I don’t have any free time to do home automation projects. :frowning: Hoping the migration can start within the next week or so…

Ok, thanks. I kinda did the same thing. These Inovelli Red Dimmers have been a pain for me on my C7. Part of it might be me being a noob but they don’t seem to include or exclude that easily.

Yes…My issues were on the C4… So nothing has really changed since my last experience. Not sure if this issue started with a FW/Driver update to the inovelli’s or if this was a FW update on the HE…

My experience back then, demonstrated, The Switches and the LZW36’s seem to exclude pretty easily, like they should. So I am guessing this issue is on the Inovelli side… But again, that’s just a guess. I didn’t have/make the time to dig in to it as there were alternative routes. :slight_smile:

Yeah, I’m having a hell of a time including them again. One seems to choke after the encryption stage. Have you happened to have seen this before?

Strange, I haven’t had that issue. Once I forcibly removed the dimmer from Hubitat and performed a factory reset, I was able to update the FW and then re-include it onto my C4.

Did you try to exclude them from the C7 as well?

Seems as though I had to move the HE closer to the dimmers. Once I did that the inclusion / exclusion issues went away. It must have been just on the fringe. Thanks for the help.

1 Like