Red Series dimmer not dimming Ilumin bulbs

I am trying to control 2 Ilumin bulbs in a ceiling fixture with a Red Series Dimmer (Gen 2). Right now I can turn the bulbs on and off via a Z-Wave association, but the bulbs do not dim or brighten at all, just off/on, when controlled by the dimmer.

My Dimmer has the following config:

  • Neutral wire
  • Disabled Internal Relay (via config button)
  • Hubitat Preferences:
    ** AC Power Type = Neutral
    ** Smart Bulb Mode = Yes
    ** Switch Type = Load Only

I created two Z-wave association groups (group number 2 and group number 4) with the Dimmer as the source device and the Bulbs as the destination devices for both groups.

I would like to be able to dim the bulbs from the switch using a Z-wave association but haven’t been able to find a step by step walkthrough of the instructions to do this, along with recommend settings for the preferences on Hubitat.

Does anyone have any good walkthroughs of how to configure this kind of setup? Or any troubleshooting advice?

Hmmm…this was simple when I just created mine. Did you disable local relay? first, you should turn on the Dimmer and ensure it’s at the maximum level (99%); then, disable local relay by pressing the config button 8 times. After that, redo your associations. Group 2 and 4 should be all you need. Post screen shots of your associations. Also, ensure the switch and bulbs are included with S0 or S2. It doesn’t seem to work if the switch is at S0, but the bulbs are at S2.

1 Like

Thanks for the tips, I think that has helped narrow things down.

First, I think I had toggled the relay one too many times and I had it enabled (not disabled) during my last set of testing. The bulbs turning on and off was likely them actually turning on and off due to that.

Now it looks like an issue with the Z-Wave association. Based on your comment about S0 and S2 it looks like my bulbs are added with S0 but the switch has security “None” when viewing the Z-wave details page on the Hubitat. I have tried excluding and including the switch again. The hubitat prompts me to select the security toggles (which I left at the defaults, see attached image) and then I entered the first 5 digits of the DSK (from the QR code on the switch) when prompted. However the switch remains listed with Security “None” (on Hubitat’s Z-Wave details page) and the associations don’t appear to be functional.

The Z-wave associations look like this:
Group 2

Group 4

Association looks good. Try unchecking the three toggles and see if it includes with none.

Unfortunately that had no effect. It looks like the issue is with the Z-Wave association specifically (possibly caused by the security issue).

The Hub is seeing the various button clicks etc. (and I’ve been able to setup a rule to workaround the on/off issue at least) but I was hoping to avoid the lag that is introduced by that approach.

I opened a support ticket with Inovelli so I hope that they can help shed some light on this issue.

So here’s my setup. Look for the data under each of your devices. This will tell you if you’re S0 or S2. My S2 bulb labeled Ilumin-2 is S2 and doesn’t work in the Association with the dimmer and other bulbs (still need to fix, but too lazy to get the ladder out).

1 Like

I am using smarththings not hubitat but I had the same issue with security settings. Tried multiple times to get the bulbs to add as s2 and could not do it, finally just deleted the switch then added it back in using the scan nearby feature rather than the qr code scan and it add the switch back in with S0 security and everything works now.

1 Like

Thanks for the suggestions everyone. I was asked by the support to update my firmware[1] to a later version which has now allowed my switch to be added using S2 security to my Hub. Still having issues with the Z-wave association but the examples you have posted have given me a reference point to work with so I really appreciate that.


Been a busy few days working on other things but finally wanted to close the loop here for anyone that encountered the same issue as me. Long story short upgrading the firmware and then reincluding the switch at S0 (instead of S2, as suggested by @PJones) let me successfully setup the z-wave associations. It looks like there is an issue with the Ilumin bulbs and S2 based on the support teams comments in my ticket, so will be satisfied with S0 for now.

Finally, the instructions provided in the post [HOW-TO] Hubitat: Setting Up "Scenes" in Rule Machine helped me get all the scene control items setup as well. All-in all happy with the setup now.

Thanks again for all the assistance on my questions.

1 Like

That is very good to hear. Just to note, the bulbs do not support S2 so it is required to use S0 or no security to control them with associations (as you discovered).

@EricM_Inovelli are there plans to update the Ilumin with the 700 series when it’s released?

Not at this time. To use 700 series would require a re-write of the firmware so we will keep using 500 series with this model. We may add S2 support but have not discussed it at this point.

1 Like

S2 with the 500 series would be great. I understand S2 is not required for light bulbs but would be nice for associations with switches. Would that be a firmware update or a hardware changed?

Just to note, the bulbs do not support S2

Yes, trying to get the bulbs working with the switch at S2 level added some time to the overall troubleshooting process for me.

I’d suggest updating the spec sheet as it currently indicated that S2 Encryption is supported which sent me down a bit of a wild goose chase trying to get that to work properly :slight_smile:

Given the out of the box experience of the switch and bulb with Hubitat doesn’t work as expected, perhaps worth recording a short video to walk people through the setup so they don’t hit the same issues I encountered? Would be good to add to the excellent library of videos that have already been put together on other topics.


@stu1811 it would be a firmware update.

@ben, thanks for the heads up. I’ll update the kb article.

Great. I was going to hold off getting some bulbs if it was a new hardware rev. Buy buy buy! :slight_smile:

Part of the issue as well is that we want to update these bulbs, but Silicon Labs (who owns Z-Wave) has not released a 700 Series chipset for bulbs. They are working on one to comply with California’s Title 24. This requires a complete redesign of the bulb and the internals.

We’re waiting for this release date to officially update these bulbs. At that time, we will also update the firmware with what we want it to be. Currently, we are having to work within the confines of the 500 Series chipset and the manufacturer firmware.

Trying to work through this myself what exactly are you doing to get these devices to S0? I have a hubitat c-7 and when excluding and rediscovering I cannot get that security pop-up to show up again for my bulbs… I think I updated firmware on the switch, but still says 1.47 so not sure?