Red Series Dimmer relay disabled and C button non-responsive

TL;DR I am trying to reset some red series dimmers that had local relay disabled to factory defaults but holding down the C button for 20 seconds does nothing (LED color does not change) and neither does pulling the air gap (goes back to same settings when power restored).

I have been using 7 red series dimmers with Home Assistant OS on a RPi 3 with a HUSBZB-1 z-wave stick for nearly 3 years without issue. Once I had everything set up the way I liked, I ignored HA and stopped updating it. Recently I found myself wanting tinker again and take advantage of the newest version of HA. So I decided to do a fresh install on a new micro SD card. The new version of HA recognized my red series dimmers and included them right away. It also prompted me that new firmware was available. So I updated them. That might have been a mistake!

In my previous set up, I had some dimmers directly controlling the dumb lights that were wired to them and others with their relays disabled so they could control smart lights not wired to them. Now I would like to re-enable the relay so they control the lights wired to them but I cannot figure out how.

I have tried the following but nothing seems to work:
-pressing the C button 8x to disable/re-enable the relay
-holding the C button for 20 seconds to factory reset
-pulling the air gap, waiting 10 seconds, and pushing it back in
-adjusting parameters in HA

The C button does not change the LED no matter how many times or how long I press it. After using the air gap, the dimmer seems to have the same settings as before. So I can’t enable the relay and I can’t reset the switch either.

I can still toggle these switches (and the lights hardwired to them) on/off and can adjust their parameters like LED brightness etc. in Home Assistant. Parameter 12, Behavior: Local, is enabled. Parameter 22, Switch Type, is single-pole (one switch). Parameter 52, Operation Mode, is normal. But the physical button presses still do not toggle the hardwired dumb lights and the C button does not want to reset the dimmer. How can I wipe these dimmers clean and set them up as new? Thanks!

Edit: I should add that Home Assistant sees the button presses as scenes “firing.” So the buttons work and are sending commands over z-wave. They just aren’t toggling the switch’s internal relay. I also just tried swapping SD cards on the Pi to use the older version of HA and the lights with the relay disabled still activate the old smart bulb scenes and can turn on/off the dumb lights via scenes but I still cannot change parameters with the C button to exclude them or reset them.

IIRC, when you exclude a Z-Wave switch it will factory reset it. Since it seems that your hub is communicating with the switches, can you exclude them?

1 Like

My understanding is that to exclude the switch, I have to enter exclusion mode in HA, then press the C button 3 times. Since my C button seems to be disabled, pressing it three times does nothing. Is there a way to exclude the switch without having to press a button?

That’s a general exclusion, which can’t work if your config button isn’t working.

This is a Gen 2 dimmer, right? LZW31 or LZW31-SN. If they are communicating with the hub, check to see if you can re-enable local control from the hub.

Or try changing the rate at which you are pressing the config button. I don’t know of anything that would prevent the config button presses from re-enabling local control.

1 Like

Certainly a strange one. I went through all the scenarios in my head and every time I re-read your message, all those scenarios fizzle out lol. I’m stumped.

Can you let me know what firmware version you updated to?

I’m wondering if somehow during the firmware update the switch got corrupted or something. Maybe you can also try reflashing the firmware.

1 Like

@peter.e.robbins here’s the cadence for the record:


Thank you @Bry and @Eric_Inovelli for your help! The switches are LZW30-SN (firmware 1.21) and LZW31-SN (firmware 1.57).

I figured I donked everything up by trying to set up a new instance of HA without excluding the switches from the old instance. So I swapped sd cards and booted up the old HA and started poking around the ZWaveJS settings. I noticed a section called “Protection” and that my dimmers with internal relay disabled were set to “local protection” (at least I think that’s what it said – it was late and I was a bit delirious at this point – you know how home automation debugging goes). I tried several times to change the setting to “unprotected” but for some reason the first few times it didn’t stick. But eventually the “unprotected” setting went through and I was able to exclude the switches and include them in the new instance of HA.

Anyone reading this trying to chase down their own similar issue, don’t be like me! Exclude your switches and reset them before setting up a new instance of HA! If you are unable to exclude your switch with the C button, check the ZWaveJS settings and make sure they are “unprotected” or “local protection” is disabled. Good luck and good automating!

1 Like