RED Series Dimmers not pairing on Hubitat Elevation

I messaged Scott on the Hubitat Community website telling him I could not pair my two new RED dimmers I purchased from Amazon. He said send them back to Amazon and mark them defective which I did. I ordered two more directly from Inovelli and the same problem…they refused to pair after many attempts to exclude and include. Next I tried a BLACK series dimmer and it paired perfectly. This is the second BLACK dimmer that paired fine. I tried factory resetting the RED dimmers but no help. I am at a loss on this and my faith in this company is fading. I want to get someone there to take these two new dimmers and either give me my money back or find a solution. I have experience in home automation with all types of devices and this is the first time having such difficulty.

Any help appreciated…thanks…

@neutronspin I had a couple that would not pair. Try factory resetting them by holding config button pressed for 20+ seconds. Then leave them powered up for 5-10 mins. Try pairing again after steps above are completed. All my Red switches have paired to my Hubitat device.

1 Like

Thanks…I tried factory resetting but no help. I did not leave them on for that long. Will try again and leave them powered up for 10 minutes. Also do you need a load connected to them?

@neutronspin, Second what @harjms said. I’m sure you checked this, but did the signal strength meter turn green? I have yet to have a problem including any of the Inovelli switches… Even one that I thought would be too far away.

1 Like

I didn’t have the load on. I literally just left them for a few minutes and came back to include them. No issues. I literally had two other non dimmer red switches next to it that had zero inclusion issues so I knew range was adequate.


I have them on an extension cord place a few feet from the hub…I just paired two BLACK dimmers…no problem…these RED dimmers are driving me crazy…lol…

I had the two BLACK dimmers at the same setup and they both paired OK…

Okay, a “Hail Mary” here, try to do a Z-Wave repair after factory resetting the Reds. Then try including them. I’ve had to do this with a couple of monoprice sensors before they would include. Even when 5’ from the hub. :crazy_face:

1 Like

Yippee!!!..Did another factory reset…waited 10 minutes and only tried six times and it finally was discovered…For some reason the RED dimmers must be a little fussy on the pairing. Wouldn’t think the firmware would take that long to update…Anyhow I am elated over this and thanks to all on here for the help…more Dimmers to follow…:grinning:

1 Like