Red Series Smart Fan Light Switch no longer turns on light after power outage

I have an inovelli fan/light switch which has been working perfectly for over a year. We had multiple power outages the other day one of which lasted more than an hour. When it came back, the light flashed on and off for a long time (several minutes) and then turned off. Now I cannot get the lights or the fan to work no matter what I do. The device has power and can be seen in smartthings. The switch leds match the status smartthings shows but the fixture has no light or fan. If I flip the breaker it goes back to the flashing state (so I know the bulbs are fine) and then again goes back to this nonfunctional state. How do I get it working again? It’s my only light in that room.

It may have been damaged by a power surge when power was restored. Not uncommon with smart switches. At this point, I would try to factory reset it.

And how do I factory reset?

1 Like

Thank you I tried the factory reset as suggested but it still doesnt work. Is it possible there is a problem with the receiver in the fixture? The switch seems to be functioning properly and is even communicating with smartthings but it’s like there is no power to the fixture. If I flip the breaker off and then back on the light and fan will come on and flash on and offer for an extended period before they just stop working. But I have no control over them while they are flashing.

It is certainly possible that the fan module could have been damaged by a power surge. However, it’s also possible that the module just lost its pairing with the switch.

I would try reconnecting the switch to the module. If that doesn’t work, I would try factory resetting the module and then re-pairing.

Those steps are all described in the manual.

Thank you. I tried that too. It flashed cyan 32 times before flashing red once and going back to normal. Is there anything else I can try? It’s a very expensive switch to have to replace for a power outage.

A factory reset of the switch and a re-pairing of the switch in the module are the two things that I can think of.

@harjms ??

You might want to submit a support ticket with Inovelli. They may have some thoughts.

Agree. Factory reset.

Thanks. I submitted a ticket. I appreciate you trying.

1 Like

This is finally resolved. I had to turn off the breaker, turn it back on, do a factory reset with the light button, a factory reset with the fan button, then a pair with the fan button, and then finally re-pair with smartthings with the light button. I am so happy to finally have lights in my office again.

1 Like

For anyone else encountering this issue, when you re-pair the switches to the canopy module, turn the breaker for the canopy module off then on and IMMEDIATELY initiate the re-pairing process. The canopy will look for a pairing partner for about a minute after the power-on.

1 Like

Thank you @blackeyes24 for your post, really helped me.
Just to add to this:

  • When I cycled the power at the breaker, the light would cycle on and off but was not controllable by the switch. This made me think the module was still good.

  • I didn’t bother doing a factory reset of the switch, only of the canopy module. This meant I didn’t have to worry about redoing the zwave stuff.

  • I was able to do the factory reset and the re-pairing in the same power cycle. Made it a lot easier.