Red Series switches / Bulbs go unavailable after restart. Unable to get them back

I am running the latest version of Hassio on a raspberry pie 2, with an Aeotec Z Wave stick.
I have numerous other z wave devices, and have never had any issues. I recently bought a bunch of Red Series Dimmers, On/Off switches and a few RGB bulbs. My goal was to replace my GE z wave switches while I was stuck at home.

I set up everything using this guide. After that, all features have been working normally.

Ive now installed a bunch of switches, and 2 bulbs. Pairing for all the devices went smoothly. The problem is, after a restart of my pie, 2 dimmers, 1 switch and 1 bulb have now shown up as “unavailable” in hass. Nothing I can do will bring them back. If I unpair/repair them, they will again work normally until a restart at which point the go unavailable again.

Has anyone else experianced this or know whats going on? I really want to keep these switches, but Im about ready to tear my hair out.

Hey Reddit friend! Let me tag a couple of guys here to see if they can help. We don’t want you pulling any hair out!

@EricM_Inovelli, @jtronicus, @doublepedaldylan

While the devices are listed as unavailable, does anything show up on your OZW_Log.txt file for those devices? If so, it is likely an issue with Home Assistant (or the way HA uses OpwnZwave).

My theory is that every time you restart, Home Assistant is completing its startup before Openzwave has finished querying everything. Since OpenZwave queries all devices every time it is restarted, the more devices you have, the longer it takes.

You mentioned you were replacing a bunch or GE switches with Inovelli. Did you remember to exclude the GE devices before removing them? If not, your Z-stick may be spending a lot of time during startup attempting to find those removed devices.

Some things I recommend trying:

  • Watch your OZW_Log.txt file while turning the switch on or off. If entries show up for that device, then the hardware is probably fine.
  • Try to heal your zwave network (and give it about 10-20 minutes to complete, especially if you have a bunch of nodes)
  • Try restarting Home Assistant under Configuration-> Server Controls -> Server Management instead of rebooting the whole pi if possible (I am not sure if this method also restarts OpenZwave, but it is definitely faster than rebooting the whole pi)
  • Nuclear option: Factory reset your z-stick and re-add nodes

Hopefully in the near future, HA will be switching to the new version of OpenZwave (1.6), and this should fix a lot of the problems people have been having (there might even be a beta version out there somewhere, but I am not familiar with it). I ended up switching to zwave2mqtt instead of the built-in implementation.

1 Like

Thanks for the reply.

In regards to the GE devices, they are still being used. I have installed these in new locations for the moment. I wanted to test them out before completely replacing working switches.

Im not sure what to even look for in the log, its so long. How do I tell which node is which?

Tried healing multiple times. Should I do anything after this? HEaling does not fix the issue.

I have restarted through the UI multiple times as well. No change.

That is not an option at this point as I have too much set up at this point, that unfortunately nuking my whole setup would not be worth it.

The latest part of the log is this:

But Im not sure if Node 33 is one of the faulty switches. When I look at the nodes in the ZWave panel, 33 does not show up. This shows up, which I belive is the faulty node:

Inovelli LZW30-SN Switch Red Series (Node:undefined undefined)

2020-03-29 16:58:29.130 Detail, Node033,   Received: xxxxxx
2020-03-29 16:58:29.131 Detail, 
2020-03-29 16:58:29.131 Info, Node033, Received SwitchBinary report from node 33: level=Off
2020-03-29 16:58:29.131 Detail, Node033, Refreshed Value: old value=true, new value=false, type=bool
2020-03-29 16:58:29.131 Detail, Node033, Changes to this value are not verified
2020-03-29 16:58:29.131 Detail, Node033, Notification: ValueChanged

Is there anything in your home-assistant.log file that that says anything similar to this?

2020-03-21 08:41:48 WARNING (MainThread) [homeassistant.components.zwave] Z-Wave node 14 not ready after 30 seconds, continuing anyway
2020-03-21 08:41:48 WARNING (MainThread) [homeassistant.components.zwave] Z-Wave entity Unknown Node 14 Sensor (node_id: 14) not ready after 30 seconds, continuing anyway
2020-03-21 08:41:49 WARNING (MainThread) [homeassistant.components.zwave] Z-Wave node 36 not ready after 30 seconds, continuing anyway
2020-03-21 08:41:49 WARNING (MainThread) [homeassistant.components.zwave] Z-Wave entity Unknown Node 36 Sensor (node_id: 36) not ready after 30 seconds, continuing anyway

I found a post that suggests there may be an issue with the latest version of Home Assistant:

Yep! Seeing the following. Guess Ill try to downgrade.

2020-03-29 12:57:06 WARNING (MainThread) [homeassistant.components.zwave] Z-Wave node 32 not ready after 30 seconds, continuing anyway
2020-03-29 12:57:06 WARNING (MainThread) [homeassistant.components.zwave] Z-Wave node 33 not ready after 30 seconds, continuing anyway
2020-03-29 12:59:01 WARNING (MainThread) [homeassistant.components.zwave] Z-Wave entity Unknown Node 32 Level (node_id: 32) not ready after 30 seconds, continuing anyway
2020-03-29 12:59:01 WARNING (MainThread) [homeassistant.components.zwave] Z-Wave entity Unknown Node 33 Switch (node_id: 33) not ready after 30 seconds, continuing anyway
2020-03-29 12:59:02 WARNING (MainThread) [homeassistant.components.zwave] Z-Wave entity Unknown Node 33 Power (node_id: 33) not ready after 30 seconds, continuing anyway
2020-03-29 13:01:20 WARNING (MainThread) [homeassistant.components.zwave] Z-Wave not ready after 300 seconds, continuing anyway

Hmm looking at that, it looks like just reverting might not fix it. Any idea how to go about getting it working again?

A couple posts in that github link suggest that reverting back to 0.106.2 may fix the issue. Unfortunately, it is not anything I can validate, since I am not experiencing the issue.

Tried to downgrade overnight but it didnt seem to work. Still on the latest hass. Strangely all switches are back online after it restarted, and still persist after a restart. So Im going to leave it for now and try to install another switch. And manually downgrade to a previous backup if I keep having issues.

But for now, it works. And I got scene controls to work, which Im pretty stoked about. I appreciate the help. Also ran into someone else on reddit with similar issues. Ill see if I can get him to post on here too

Ended up having issues again overnight. Downgraded to 106.5 and everything seems to be solid for the moment.

Thought Id post an update. For unrelated reasons (mainly boredom) decided to redo my entire setup with a clean install of hassio 0.106.5. I did not redo my zwave network though, Im not that bored. After doing that, and going through countless restarts I havent had issues. So it seems the 0.107 issue mentioned above may be the culprit.

Just thought I’d chime in here as I have a similar setup. I’m running Home Assistant v0.107.7 on an RPi3 with the same Aeotec stick as you. I have 12 Red Series dimmers, 4 Red Series switches and 4 of the RGB bulbs installed right now. Everything is running flawlessly. I’m not sure what firmware version my switches are running. All of the switches are installed as regular nodes, not secure nodes.

I update every version and never had any issues with my Inovelli stuff. My GE fan swtiches and Aeotec multi sensors were buggered for a bit but all is well now.

Updating to 0.107.7 might resolve your issue. Don’t hate me if it doesn’t though :wink:

Just realized I never actually put the version I was on, but pretty sure it was 107.7. Think Im just going to hold off updating for now.

Update: No issues after updating from 106.5 to 108.