Red Switch on SmartThings (new hub and new app)

I hope you can help me with the setup of my Red Series switch on SmartThings

I previously used the Red Series switch on

  1. V1 hub and Smathings Classic app - perfect
  2. V1 hub and new smart things app - perfect

I am now migrating from my v1 to v3 hub and setting everything up from scratch. The issue I have is that I don’t have any of the Inovelli switch configuration options in the app.

When I reinstalled my dimmers these automatically installed using the inovelli dimmer driver provided by Smart Things.

The red series switches defaulted to ‘Switch with power meter’, after that I installed the Red Series device handler provided by inovelli but the app is still not showing any configuration options. I changed the device handler for the device to make sure it was using the correct handler. I have not installed any child handlers

I also tried excluding and then including the device but no change

All suggestions welcomed !

Just to make sure (I think it’s what you’re saying, but let’s confirm it). You changed the device handler from within IDE and then applied it (ie: saved it), correct?

Sorry I’m on mobile so I can provide pics to show you what I’m saying.

Correct, I changed the driver in IDE. A copy is below

Here are a couple of screens hope from the iOS app

Smartthings can be a bit finicky sometimes so I have been through a process of deleting everything and restarting to see if that solved it

All ideas welcomed !

Ok, so the configuration options you are looking for are not in the two screenshots you provided.

Click on the 3-dot menu at the top right and select “Settings”. You should see a bunch of configuration in there.

1 Like

What @Bry said with the three dots :slight_smile:

Thanks so much. I selected the 3 dots earlier and I only got the two option (Edit and Information)

I think it might have taken some time for the changes to percolate through the system. I have the Setting option now. Thank you for your help !!

Have a good weekend

1 Like

@smartthing101 make sure you mark as resolved one of the posts so we can see this issue is closed!