relayClick attribute in zigbee2mqtt has reversed labels

I just installed my first Blue 2-1 On/Off switch and am getting everything set up. I’m using zigbee2mqtt on Home Assistant as my hub and it appears that the “Exposes” page shows the possible values for the relayClick backwards. When the value is “Disabled” the switch clicks upon toggle but when it’s set to “Enabled (Default)” the switch does not click.

Home Assistant: 2022.10.5, OS: 9.3
zigbee2mqtt: 1.28.1, Addon: 1.28.1-1
Switch firmware: 2.0.0

With the device in the state that it clicks when actuated:

1 Like

Seconded; I was going crazy thinking I couldn’t turn off the loud clicking! Thanks for posting this. I’m on firmware 2.00 as well using zigbee2mqtt 1.28.2.

The parameter is to disable the relay click sound

You can see the code snip here: zigbee-herdsman-converters/inovelli.js at master · Koenkk/zigbee-herdsman-converters · GitHub

It is as intended per the docs. Disabled means click sound is on.

I agree that the parameter and description could be better within z2m. @nathanfiscus it might be worth matching the documentation wording more closely.

Went ahead and proposed changes.

1 Like

Just FYI, I had already made a PR last night to support the changes in the 2.05 firmware. I included some clarity here on that parameter.

1 Like

Should I take down my PR? Sorry I didn’t see it.

Can the relay click be disabled on SmartThings? I don’t see that option in the edge driver. Thanks!

If it’s not in there it will need to be added by @EricM_Inovelli.

Don’t worry about it. Koenkk already closed it.

1 Like

I added this a few hours ago to the edge driver.


Thanks everyone! Will test this out.

Not sure if related but part of my confusion came from no option being selected by default in Z2M. Even now I don’t see my option highlighted although changing it does change the switch behavior.

Another bug perhaps?

I think this is more to do with how boolean data types are being defined in the converter that z2m-herdsman is using. I don’t see any of the enum data types that have re-cast standard boolean names (true/false) to use other words get updated in the frontend. Looking at the json for the switch state, all the values are set correctly, but it doesn’t show in the GUI. :man_shrugging:

Edit: updated to the latest converter and the re-cast booleans issue seems to have vanished. Selections are now sticking and showing in the UI for me.

Mark as resolved if your issue is fixed in the latest z2m!

1 Like