S2, Red On/Off, ZWaveJStoMQTT

Hello, has anyone got Red On/Off switch to work with S2 auth or S2 unauth with ZWaveJStoMQTT?

I seem to keep getting Security None

1 Like

Working with the people over at zwave-js, It looks like something not right with the S2 inclusion process on a Red Switch. They are saying the device isn’t requesting the keys. Any way to prove it not device?

@Eric_Inovelli @Eric_Inovelli

2 Likes

I tried it and was unsuccessful in including

1 Like

Damn… I mostly have red dimmers, and they include with S2_Authenticated just fine.

But just went back to test a stock red switch, and it failed to include properly and fell back to ‘none’ like you both have mentioned.

Maybe there is something a little different about the dimmers and switch?

1 Like

@Esh glad to hear no issues with dimmers, i pre-ordered a bunch.

Just an updated, submitted a support ticket :slight_smile: I hope this is best way to let Inovelli know.

Thanks! We are looking into it. There are some quirks that are being found by our friends at HA that were not discovered with other hubs. I’m not sure if it’s just not needed with other hubs, and it didn’t matter, but regardless, we have captured this and will try to get it updated.

The issue we are running into with the manufacturer is that their engineers are working on a large project for a separate Z-Wave company (rhymes with Bling) and don’t have the bandwidth right now to correct some of these bugs.

Hopefully we can bug them enough to take action, but @EricM_Inovelli has asked time and time again to fix things on our switch and is getting stonewalled.

Which firmware version do you have? Firmware 1.21 had an S2 inclusion fix in it.

I am on 1.22, I was going to downgrade to 1.21 to see if it a regression, but I can not find the link to 1.21 anymore.

Wow, good to know about the manufacturer.

I can see how other hubs will not see this. Joys of FOSS vs close software.

https://files.inovelli.com/firmware/LZW30-SN/Beta/

@HAJeremyC did 1.22 S2 inclusion work for you? Are you doing S2 unauth, auth, or door/locks, or all?

@EricM_Inovelli I tired 1.20 and 1.21. Both ended in a node failed state. I didn’t have time this morning to try 1.22. I’ll try tonight.

@stu1811 1.22 fails for me and I tested 1.21 which fails for me as well.

1 Like

Thanks for the info. Is there any workaround that can be implemented on the ZWaveJS side? The S2 inclusion works on SmartThings, Hubitat, and PC Controller so there seems to be a difference there with how that software is handling it.

So I went back and gave it another go here. But this time I checked the ‘force security’ check box. This seemed to work for me on one of my red on/off switchers. It included properly with ‘S2_Authenticated’

It still doesn’t seem to work for me if I don’t ‘force security’, where the dimmers do seem to work without forcing.

I don’t know any workaround. Zwave-js people say it on the device side :frowning:

I will try this tomorrow? What version of ZWavejs are you using?

Zwave-js: 8.2.1, zwavejs2mqtt: 5.5.1

Which firmware?

1.21 - I haven’t tried 1.22

1 Like