Scenes Not Working with ZwaveJS2Mqtt

Hello, I can’t seen to get scenes working on with my Inovelli switches. I am using ZwaveJS2Mqtt and I am not seeing anything when listening to zwave_js_value_notification. I’m not sure where to begin. Any thoughts?

1 Like

Are you using node red?

So you have HA, you have the zjs2m add-on enabled/set up, and you have the integration properly set up?

Are you using MQTT or websockets?

Are you seeing anything on zwave_js_notification event?

@stu1811 Yes, I am but have tested outside of node red.

@kreene1987 I do, and yes I believe it is. I can control the lights, configs and the LED notifications fine using HA or node red.

I am not using MQTT, it is turned off.

I’m not seeing anything other than when I send a zwave_js_notification event in the dev page. I assume if I click the config button on the switch or double tap the on/off I should see a zwave_js_notification event pass while listening.

I’m hitting my head against the desk trying to figure this out.

1 Like

Do you have parameter 50 set to 0? That disables scenes (other than 1x config press). You might also have parameter 51 set to something very fast and you aren’t pressing the button fast enough? Try 8 (800ms).

I don’t see a parameter 50. Is something missing?

What is the firmware version? 1.49 added parameter 50.

I’m on 1.48,1.41. So you are running beta?

1.55 or 1.52 on my dimmers

Are you on the latest version of Home Assistant? Some changes were made a while back on how scenes were reported.

If you open the zwavejs2mqtt control panel (web interface), do you see the scene events there?

I am on 2021.9.7, so yes it is the latest. I did not see any events in the zwavejs2mqtt control panel. I assume you are talking about the debug tab?

1 Like

This is the way.

image

2 Likes

Open the device line in zwavejs2MQTT and then open the Central Scene. Clicking should show the events there as the button presses instead of the undefined. It only pops up for an instant each time.

I just checked in HA and tried clicking a dimmer a few times and it seems the central scenes are coming through. This is 2 clicks down, I did it twice. I think the scene number represents the down key and the key attribute obviously shows how many times it was pressed.

2021-09-22T01:27:06.172Z DRIVER « [Node 017] [REQ] [ApplicationCommand]
└─[CentralSceneCCNotification]
sequence number: 69
key attribute: KeyPressed2x
scene number: 1
2021-09-22T01:27:06.174Z CNTRLR « [Node 017] received CentralScene notification {
“nodeId”: 17,
“ccId”: “Central Scene”,
“ccCommand”: “0x03”,
“payload”: “0x458301”
}
2021-09-22T01:27:08.786Z DRIVER « [Node 017] [REQ] [ApplicationCommand]
└─[CentralSceneCCNotification]
sequence number: 70
key attribute: KeyPressed2x
scene number: 1
2021-09-22T01:27:08.787Z CNTRLR « [Node 017] received CentralScene notification {
“nodeId”: 17,
“ccId”: “Central Scene”,
“ccCommand”: “0x03”,
“payload”: “0x468301”
}

1 Like

Very cool. I didn’t know that was there. Took some poking around to find. Here’s a screenshot that may help. (2x Press Up)

1 Like

That’s good to know. It seems my switch isn’t passing along any scenes. Nothing shows in the Central Scene section when I double press. It did work prior to zwavejs and I did update the firmware. So I hope this is just a silly setting I am missing.

Maybe try un-pairing and then hold the config button for >20 seconds to reset the switch and then pair it again and see if that helps.

I found this in the ZwaveJS2Mqtt logs, thoughts?

“command must be encrypted but was received without Security encapsulation - discarding it”


I’d bring this over to the discord for HA in the zwave channel. They are incredibly helpful there and the devs are on there almost every day.