Secure Pairing ZWave JS

I’m starting my migration from ST to HA. I’m using supervisor with the zwave js addon and integration. So far I’ve paired two devices and I can control they from the UI. When pairing a LZW30-SN I tried the secure inclusion but it did not prompt for the DSK. Is that normal? How can I verify the security level of the device? In ST you could look at the raw description.

It’s on the roadmap, but not yet available on ZJS.

Welcome, btw. It’s an awesome piece of tech, HA.

1 Like

Thanks! Is S0 currently supported? If how do you see S0 vs unsecure?

If you shut down ZJS and instead start up ZJS2MQTT and turn off the MQTT and websockets, their UI will show you the security I believe. ZJS does not (yet) have any front-end UI that shows any of this information (again, yet, they are programming furiously!).

1 Like

Ok. Thanks again.

1 Like

My recommendation — don’t use secure pairing with switches / dimmers. There’s a lot of extra network overhead that comes with secure pairing, so it’s really best to reserve using it for devices where you actually need it (like locks).

@kelchm I have most of my devices in smartthings paired with S2. Thus far I haven’t had any issues. I thought S0 had a lot of traffic and S2 improved on that.

While you are correct, no security is still faster than S2. it’s how I have ALL of my inovelli kit set up. I’m not convinced someone is nefarious enough to get in and, god forbid, make my lights misbehave :D.

Fortunately my toddler is not smart enough to hack my zwave network, otherwise we would have a constant light show.

1 Like

That’s true, but give that we’re stuck with S0 for now in Home Assistant I think it’s best to avoid it entirely for devices where there’s no real ‘risk’ involved.

1 Like

I have an August deadbolt lock and I tried to use s0 instead of secure but it won’t let me lock or unlock in that case. Is there any solution?

S0 is a secure pairing. Did you try unsecure?

He didn’t have a key setup in ZwaveJS, we solved this on the HA discord the lock is working correctly now. :slight_smile:

2 Likes