Setup Red Switches/Dimmers with Home Assistant & Z-Wave JS

Hi,

I have a house full of Red switches & dimmers (new construction) :slight_smile: and I’m brand new to Home Assistant and not sure if I’m following the right resources.

I have home assistant setup on docker and z-wave JS also setup on docker.

I found this article, but it relies on open z-wave and I’m not sure if that is different than z-wave JS and I should be doing things differently, or if this is the right way to set things up.

Could use some guidance to ensure I set this all up correctly.

Thanks!

Yes Zwave JS is different than open z-wave.

Get Zwave JS Server set up via docker and make sure it is seeing your stick in the logs.

Home assistant SHOULD see the Zwave JS Server, but if it doesn’t, then add the following integration within Home Assistant: Z-Wave JS - Home Assistant

It should find the server and communicate over port 3000.

If you have any issues let us know! Welcome to Inovelli and Home Assistant!

Helpful links here: https://community.home-assistant.io/t/zwave-home-assistant-overview/277253

Thanks for the quick response. I believe I have home assistant and z-wave JS all setup on my NAS device.

What I’m confused on is what I need to do to start “adopting” the Inovelli switches. The doc I linked to above suggested a number of config changes and such, but that only applies to Open Z-Wave…so what setup/config changes do I need to make in my current setup?

The best news, NONE!

ZJS already has the config files that are being updated by the community. OZW relied on modifications because they stopped updating configurations.

It should find the manufacturer/device from the node information, match it to a config file, and set it up automatically!

That’s amazing!

That was what I was missing context on. So basically, I’ll just run through the “Include The Device” steps in that link.

Appreciate the extra context

1 Like

I would highly recommend you run the zwaveJSMQTT docker container instead. Works the same as the zwaveJS container but has a user interface. You just disable the MQTT since it’s not necessary. Then, you can do the adding and naming in this container before starting HA and letting the devices appear there.

There are some settings you can’t change in HA right now, but you can in the zwaveJSmqtt interface.

This is what I went with based on the various docs I read. I’m assuming it’s the one you’re referring to?

https://hub.docker.com/r/zwavejs/zwavejs2mqtt

That’s the one.

The zwaveJS server is also available as a docker container, but then maybe it’s only available in the HA supervisor where it runs as a container, not for general use on docker hub.

So I’m ready to setup all my switches, but I think I’m missing some steps.

I’m in the HA/Configuration/Integrations screen. I tried to “Add Integration”, but Inovelli doesn’t show up in the search. I triple clicked on the config button of a switch hoping it would trigger some notification, but nothing happened.

How do I initiation the adoption process?

If you use zwave js, on the config screen go to your zwave js integration. Select configure and then add none. Enable inclusion on switch.

If you’re using zwavejs2mqtt you can do the same method of use the zwavejs2mqtt ui to add a node.

Right, the Inovelli is talking to the Zwave JS software through the USB stick. Assuming you have the USB stick seen by zwave JS server, you would then add the Zwave JS integration, and inside that via config, you can add node to put the USB stick in inclusion mode, then hit the Inovelli config 3 times to add. It might take up to a minute for it to include fully!

Since you’re using ZwaveJStoMQTT bring the web interface up for that. Hit the blue add/remove device button and pick inclusion.

Once you a device added, click it which opens a drop down box and under device ID you can put in a name for what it is. Make sure you hit the arrow to save it.

While in that drop down box, you can also click on the different rows in the values section and change the settings you want. For example change “[17-112-0-51] Physical On/Off Delay” to disabled to remove the 0.7 second delay between pressing the toggle and a switch or dimmer turning on or off.

Then, in HA you add the zwaveJS integration. It will pull in the devices with the names you gave them so you know which switch is doing what function.

Thanks…this is what I needed.

Glad to know I can reduce the delay (it was bugging me!)

Separately, most switches are adopting fine, but a few are coming up as “Unknown”

Unknown manufacturer 0xXXXX 0xXXXX Unknown product 0xXXXX